old code would nuke default_config.xml, this version will add it to a local
[plcrt.git] / plcrt.spec
index a11e296..0308dae 100644 (file)
@@ -28,6 +28,7 @@ Group: Applications/System
 Requires: python
 Requires: perl
 Requires: rt3
+Requires: rt3-mailgate
 Requires: myplc
 
 %description
@@ -35,8 +36,6 @@ PLCRT is a collection of configuration scripts for configuring RT.
 By default RT does not come with all the settings needed for a standard PLC,
 or PlanetLab in particular.  
 
-
-
 %prep
 %setup -q
 
@@ -59,7 +58,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files 
 %defattr(-,root,root)
-%config /etc/rt3/RT_SiteConfig.pm
 #%config /etc/plcrt.conf
 %{_datadir}/%{name}
 %{_sysconfdir}/plc.d/plcrt
@@ -74,9 +72,13 @@ if ! grep '<category id="plc_rt">' /etc/planetlab/default_config.xml ; then
     sed -i 's|<category id="plc_net">| <category id="plc_rt">\n <name>RT Configuration</name>\n <description>RT</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the RT server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
 fi
 
-plc-config --save /etc/planetlab/default_config.xml \
-                       --category plc_rt --variable enabled --value true
+mkdir -p /etc/planetlab/configs
+plc-config --save /etc/planetlab/configs/site.xml \
+               --category plc_rt --variable enabled --value true
 
 %changelog
+* Fri Jun 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-1
+- trying to get the tag to work for new package.
+
 * Thu Jun 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-1
 - initial addition.