Setting tag PLCRT-1.0-9
[plcrt.git] / plcrt.spec
index c52d662..ce618ac 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name plcrt
 %define version 1.0
-%define taglevel 6
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -49,11 +49,14 @@ rsync -a ./ $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 
 install -D -m 644 rt.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/rt.cron
 install -D -m 755 getpersons.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/getpersons.py
-install -D -m 755 callplcsh.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/callplcsh.py
 install -D -m 755 adduserstort.pl $RPM_BUILD_ROOT/%{_datadir}/%{name}/adduserstort.pl
 
 echo " * Installing cron scripts"
-chmod 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}/cron.d/*.sh
+for file in $RPM_BUILD_ROOT/%{_datadir}/%{name}/cron.d/*.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/cron.d/*.sh ; do 
+       if [ -f $file ] ; then
+        chmod 755 $file
+       fi
+done
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -102,6 +105,16 @@ chown apache.apache /var/log/rt3/rt.log
 cp /usr/share/rt3/html/NoAuth/images/bplogo.gif /var/www/html/misc/logo.gif
 
 %changelog
+* Mon Sep 21 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-9
+- be more selective about which files to chmod
+
+* Mon Sep 21 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-8
+- shorter polling period for faster sync
+- remove attempt to install removed file
+
+* Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-7
+- replace callplcsh with simpler scripts for syncing users
+
 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-6
 - some plcs don't return site_ids so getpersons should not depend on this field
 - make scripts exec on install