care for floats being passed as a result of erratic / instead of // when migrating...
[plnode-utils.git] / plnode-utils-lxc.spec
1 %define name plnode-utils
2 %define version 0.2
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
8
9 Summary: Python utilities for a PlanetLab node
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Libraries
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Provides: bwlimit
24
25 %description
26 This python3 package provides utilities like bwlimit, used in various places on a PlanetLab node, nodemanager and mom among others. It aims at cleaning up the packaging scheme, as bwlimit used to ship with util-vserver-pl, but is relevant in the lxc variant as well.
27
28 %prep
29 %setup -q
30
31 %build
32 # xxx fixme
33 # this is where we choose which flavour of bwlimit gets shipped
34 cp plnode/bwlimit_lxc.py plnode/bwlimit.py
35 python3 setup.py build
36
37 %install
38 python3 setup.py install --skip-build --root "$RPM_BUILD_ROOT"
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %{python3_sitelib}/*
45 %{_bindir}/*
46
47 %changelog
48 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - plnode-utils-0.2-2
49 - import bwlimit from plnode dir, and keep legacy support.