Both e1000 and e1000e drivers recognize certain devices. Greylisting
[pypcilib.git] / pypcilib.spec
index 9ff74a8..3426a41 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL$
 
 %define name pypcilib
-%define version 0.1
-%define taglevel 1
+%define version 0.2
+%define taglevel 7
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -24,15 +24,15 @@ Distribution: PlanetLab %{plrelease}
 #URL: http://svn.planet-lab.org/wiki/pypcilib
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-BuildRequires: pciutils-devel
-
 Source0: pypcilib-%{version}.tar.bz2
 
+Requires: /sbin/lspci
+
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -un)
 
 %description
 pypcilib is a Python library to scan PCI devices using
-pciutils' libpci, and to parse the modules.pcimap file.
+libpci from pciutils, and to parse the modules.pcimap file.
 
 
 %prep
@@ -40,13 +40,14 @@ pciutils' libpci, and to parse the modules.pcimap file.
 
 
 %build
-CFLAGS="%{optflags}" %{__python} setup.py build
+%{__python} setup.py build
 
 
 %install
 rm -fr "%{buildroot}"
 %{__python} setup.py install -O1 --skip-build --root "%{buildroot}"
-touch %{buildroot}%{python_sitearch}/pypcimap.py{c,o}
+touch %{buildroot}%{python_sitelib}/pypcimap.py{c,o}
+touch %{buildroot}%{python_sitelib}/pypci.py{c,o}
 
 
 %clean
@@ -55,12 +56,36 @@ rm -fr "%{buildroot}"
 
 %files
 %defattr(-,root,root,-)
-%{python_sitearch}/pypciscan.so
-%{python_sitearch}/pypcimap.py
-%ghost %{python_sitearch}/pypcimap.pyc
-%ghost %{python_sitearch}/pypcimap.pyo
+%{python_sitelib}/pypcimap.py
+%ghost %{python_sitelib}/pypcimap.pyc
+%ghost %{python_sitelib}/pypcimap.pyo
+%{python_sitelib}/pypci.py
+%ghost %{python_sitelib}/pypci.pyc
+%ghost %{python_sitelib}/pypci.pyo
+# xxx - quick'n dirty
+%if "%{distroname}" == "f9" || "%{distroname}" == "f10" || "%{distroname}" == "f11"
+%{python_sitelib}/pypciscan*.egg-info
+%endif
 
 
 %changelog
+* Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-7
+- ready for fedora11
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-6
+- use 8139too driver over 8139cp for realtek 8139 chipsets
+
+* Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-5
+- support for building on fedora 10
+
+* Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-4
+- somehow the versions in the specfile are wrong in tag 0.2-3
+
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-2
+- fixes for building on f9/gcc-4.3 - no functional change
+
+* Fri Mar 14 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.2-1
+- Remove pypciscan library, reimplemented in Python
+
 * Mon Nov 19 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
 - initial release