Setting tag pyplnet-4.3-20
[pyplnet.git] / pyplnet.spec
1 %define name pyplnet
2 %define version 4.3
3 %define taglevel 20
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Summary: PlanetLab Network Configuration library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Requires: python >= 2.4
24 BuildRequires: python, python-devel
25 BuildArch: noarch
26
27 %description
28 pyplnet is used to write the network configuration files based on the
29 configuration data recorded at PLC.
30
31 %prep
32 %setup -q
33
34 %build
35 python setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
40 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
41 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
42 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(-,root,root,-)
49 %{_bindir}/plnet
50 %{python_sitelib}/*
51
52 %changelog
53 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - pyplnet-4.3-20
54 - last version for python2, runs on f27 and f29
55 - remove 'NM_CONTROLLED=no' from ifcfg file, as we now rely on NetworkManager
56
57 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-19
58 - always set NM_CONTROLLED=no in ifcfg files
59 - more modern python
60
61 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-18
62 - IPv6 changes from Thomas Dreibholz
63
64 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-17
65 - Added tags for configuring OvS interfaces
66
67 * Thu Jan 03 2013 Scott Baker <smbaker@gmail.com> - pyplnet-4.3-16
68 - verify ovs is running before setting up ovs bridge
69
70 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-15
71 - Add support for bridging using Open vSwitch
72
73 * Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-14
74 - Fix stupid bug
75
76 * Mon Apr 30 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-13
77 - Support for VLAN interfaces
78
79 * Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
80
81 * Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
82 - turn off verbose/debug messages
83 - pyplnet-4.3-10 was broken because of that
84
85 * Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
86 - Enable creation of bridged interfaces
87
88 * Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
89 - protect shell vars definition in ifcfg files with ""
90 - tweaks in numbering rules
91
92 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
93 - no semantic change - just fixed specfile for git URL
94
95 * Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
96 - Secondary interface fixes and features.
97
98 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
99 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
100
101 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
102 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
103 - this code can handle both..
104
105 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
106 - alias without a mac address: fix runtime error while issuing warning
107
108 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
109 - this patch addresses mlab and other multi-interface node confgurations where
110 - the generated boot image and network config files are mis-named.
111
112 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
113 - handle wireless settings back again
114
115 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
116 - fixes for 4.3
117
118 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
119 - initial release