reflect senslab -> iotlab in rpm packaging
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 3.0
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package senslab
83 Summary: the SFA layer around SensLab
84 Group: Applications/System
85 Requires: sfa
86
87 %package dummy
88 Summary: the SFA layer around a Dummy Testbed 
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa-common
106
107 %description 
108 This package provides the registry, aggregate manager and slice
109 managers for SFA.  In most cases it is advisable to install additional
110 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
111
112 %description common
113 This package contains the python libraries for SFA both client and server-side.
114
115 %description client
116 This package provides the client side of the SFA API, in particular
117 sfi.py, together with other utilities.
118
119 %description plc
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description federica
127 The SFA driver for FEDERICA.
128
129 %description nitos
130 The SFA driver for NITOS.
131
132 %description senslab
133 The SFA driver for SensLab.
134
135 %description dummy
136 The SFA driver for a Dummy Testbed.
137
138 %description sfatables
139 sfatables is a tool for defining access and admission control policies
140 in an SFA network, in much the same way as iptables is for ip
141 networks. This is the command line interface to manage sfatables
142
143 %description xmlbuilder
144 This package contains the xmlbuilder python library, packaged for
145 convenience as it is not supported by fedora
146
147 %description tests
148 Provides some binary unit tests in /usr/share/sfa/tests
149
150 %prep
151 %setup -q
152
153 %build
154 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 %config (noreplace) /etc/sfa/api_versions.xml
175 /usr/share/sfa/migrations
176 /usr/share/sfa/examples
177 /var/www/html/wsdl/*.wsdl
178
179 %files common
180 %{python_sitelib}/sfa/__init__.py*
181 %{python_sitelib}/sfa/trust
182 %{python_sitelib}/sfa/storage
183 %{python_sitelib}/sfa/util
184 %{python_sitelib}/sfa/server
185 %{python_sitelib}/sfa/methods
186 %{python_sitelib}/sfa/generic
187 %{python_sitelib}/sfa/managers
188 %{python_sitelib}/sfa/importer
189 %{python_sitelib}/sfa/rspecs
190 %{python_sitelib}/sfa/client
191
192 %files client
193 %config (noreplace) /etc/sfa/sfi_config
194 %{_bindir}/sfi*.py*
195 %{_bindir}/sfi
196 %{_bindir}/get*.py*
197 %{_bindir}/setRecord.py*
198 %{_bindir}/sfascan.py*
199 %{_bindir}/sfascan
200 %{_bindir}/sfadump.py*
201
202 %files plc
203 %defattr(-,root,root)
204 %{python_sitelib}/sfa/planetlab
205 %{python_sitelib}/sfa/openstack
206 /etc/sfa/pl.rng
207 /etc/sfa/credential.xsd
208 /etc/sfa/top.xsd
209 /etc/sfa/sig.xsd
210 /etc/sfa/xml.xsd
211 /etc/sfa/protogeni-rspec-common.xsd
212 /etc/sfa/topology
213
214 %files flashpolicy
215 %{_bindir}/sfa_flashpolicy.py*
216 /etc/sfa/sfa_flashpolicy_config.xml
217
218 %files federica
219 %{python_sitelib}/sfa/federica
220
221 %files nitos
222 %{python_sitelib}/sfa/nitos
223
224 %files senslab
225 %{python_sitelib}/sfa/iotlab
226
227 %files dummy
228 %{python_sitelib}/sfa/dummy
229
230 %files sfatables
231 /etc/sfatables/*
232 %{_bindir}/sfatables
233 %{python_sitelib}/sfatables
234
235 %files xmlbuilder
236 %{python_sitelib}/xmlbuilder
237
238 %files tests
239 %{_datadir}/sfa/tests
240
241 ### sfa installs the 'sfa' service
242 %post 
243 chkconfig --add sfa
244
245 %preun 
246 if [ "$1" = 0 ] ; then
247   /sbin/service sfa stop || :
248   /sbin/chkconfig --del sfa || :
249 fi
250
251 %postun
252 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
253
254 #### sfa-cm installs the 'sfa-cm' service
255 #%post cm
256 #chkconfig --add sfa-cm
257 #
258 #%preun cm
259 #if [ "$1" = 0 ] ; then
260 #   /sbin/service sfa-cm stop || :
261 #   /sbin/chkconfig --del sfa-cm || :
262 #fi
263 #
264 #%postun cm
265 #[ "$1" -ge "1" ] && service sfa-cm restart || :
266
267 %changelog
268 * Wed Jun 19 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-3.0-1
269 - AM API v3-based first implementation.
270 - planetlab native V3 driver
271 - dummy native V3 driver
272 - introduction of v2_to_v3_adapter
273 - lease times in RFC3339 date format, not epoch
274 - mostly in line with geni-v2 for non-v3 issues like packaging and all
275
276 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-25
277 - sfi and sfaadmin list now share the same display code for related objs
278 - support for advertising alternate api urls - for other API versions - api_versions.xml
279 - cleaned up GID class
280 - senslab: improved importer
281 - senslab: add site to SlabLocation from Location
282 - senslab: new class JsonPage
283 - senslab:  fix debian packaging
284 - federica: fix list_slices
285
286 * Tue Jan 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-24
287 - merged the senslab driver from git.f-lab.fr
288 - merged the teagle flavour
289 - debian packaging should work much better
290 - added debug messsages for when db connection fails
291
292 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
293 - minor fix in registry
294 - fix for sfi gid, use clientbootstrap
295 - support for debians and ubuntus (packaging and initscript)
296 - deprecated cm package altogether
297 - pl flavour, minor fix for tags
298 - various fixes for the dummy flavour
299
300 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
301 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
302 - tweaks in nitos importer
303 - improvements to sfaadmin check-gid
304
305 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
306 - PL importer: minor fixes for corner cases
307 - PL importer: also handles last_updated more accurately
308 - sfi update can be used to select a key among several in PL
309 - sfi add/update usage message fixes (no more record)
310 - new feature sfaadmin registry check_gid [-a]
311
312 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
313 - fix 2 major bugs in PL importer
314 - esp. wrt GID management against PLC key
315
316 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
317 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
318
319 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
320 - support fordelegation in sfaclientlib
321 - sfi delegate fixed
322 - other delegation-related sfi option trashed
323 - new config (based on ini format)
324 - new dummy driver and related package
325 - pl importer has more explicit error messages
326 - credential dump shows expiration
327
328 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
329 - bugfix in forwarding Resolve requests
330 - various fixes in the nitos driver wrt keys and users
331
332 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
333 - various tweaks for the nitos driver
334
335 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
336 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
337 - deeper cleanup of the data-dependencies between SFA and the testbed
338 - in particular, sfi create issues Resolve(details=False)
339 - for that purpose, Resolve exposes reg-* keys for SFA builtins
340 - which in turn allows sfi list to show PIs, slice members and keys
341 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
342 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
343
344 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
345 - configurable data-dir (/var/lib/sfa)
346 - no more dependent on myplc-config
347 - some support for hrns with _ instead of \.
348 - fix for PL importing in presence of gpg keys
349 - DeleteSliver returns True instead of 1 in case of success
350 - Various improvements on the openstack/nova side
351 - new package sfa-nitos
352
353 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
354 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
355 - sfi to remove expired credentials
356
357 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
358 - Update Openstack driver to support Essex release/
359 - Fix authority xrn bug.
360   
361
362 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
363 - review packaging - site-packages/planetlab now come with sfa-plc
364 - new package sfa-federica
365 - clientbin moved one step upwards
366
367 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
368 - fix bug in sfi update()
369
370 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
371 - fix broken sfa.util.xrn class for lowercase
372
373 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
374 - new 'void' generic_flavour for running in registry-only mode
375 - first shot at refactoring importers - probably needs more work
376 - openstack: various enhancements
377 - sfi interface to registry not based on xml files anymore
378 - sfi show sorts result on record key
379 - bugfix in sfa update on users with a pl-backed registry
380
381 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
382 - renamed sfa/plc into sfa/planetlab
383 - plxrn moved in sfa/planetlab as well
384 - bugfix for sfaadmin reg update --pi <>
385
386 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
387 - native data model now has a authority x user (PI) relationship
388 - no call to 'augment_records_with_testbed_info' for GetCredential
389 - which means, registry can now be used without an underlying testbed
390 - reviewed code about relationships b/w objects and related in pl driver
391 - reviewed PL import wrt roles and pis
392 - removed mentions to is_enabled in driver
393 - small changes in update_relation* in driver interface
394 - sfaadmin: can create authorities and attach pi users to them
395 - sfaadmin: categories can be abbreviated
396 - sfi list and sfaadmin list have a new -r/--recursive option
397 - this means that List now supports an (optional) 'options' argument
398 - sfi config can display config vars
399 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
400
401 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
402 - make sync now supports vserver or lxc.
403 - Added slice expiration and login info to SliverStatus response. 
404 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
405   the 'component_name' attribute.
406 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
407   
408 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
409 - Introduced new administrative command line script, sfaadmin.py. Removed various single
410  purpose scripts and migrated their functionality into sfaadmin.py.
411 - Refactored Registry import scripts.
412 - Removed SQLAlchemy dependency from sfi.py.
413 - Fixed bugs in sfi.py
414 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
415
416 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
417 - slice x researcher rel. in database,
418 - plimporter to maintain that, as well as user.email, and more robust
419 - ongoing draft for sfaadmin tool
420 - support for a federica driver
421 - support for a nova/euca driver
422 - no more sfa-clean-peer-records script
423
424 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
425 - registry database has user's keys and mail (known as v0 for migrate)
426 - pl importer properly maintains user's keys and mail
427 - pl driver now to handle 'role' when adding person record (exp.)
428 - first draft of federica driver with config section
429 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
430 - plus, from master as of tag merged-in-sfa-2.1-2:
431 - disk_image revisited
432 - new nova_shell nova_driver & various tweaks for openstack
433
434 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
435 - uses sqlalchemy and related migrate
436 - thorough migration and upgrade scheme
437 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
438 - trashed dbinfo stuff in auth hierarchy
439 - data model still has little more than plain records
440 - checkpoint tag, not yet intended for release
441
442 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
443 - client: added -R --raw sfi cmdline option that displays raw server response.
444 - client: request GENI RSpec by default. 
445 - server: remove database dependencies from sfa.server.sfaapi.
446 - server: increased default credential lifetime to 31 days.
447 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
448 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
449 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
450  
451 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
452 - bugfix: 'geni_api' should be in the top level struct, not the code struct
453 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
454           output returned by the Aggregate Manager.
455 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
456 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
457 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
458           there is extra whitespace in the schemaLocation field.
459 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
460           advertisement rspecs.
461 - bugfix: <login> RSpec element should contain the 'username' attribute.
462 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
463  
464 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
465 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
466   exit when it encountered a user with an invalid public key.
467 - server: imporved logging in sfa-import-plc.py
468  
469 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
470 - bugfix: Fixed appending public keys in CreateSliver
471 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
472 - client: -c --current option allows users to request the current/uncached rspec.
473 - server: Added 'geni_api_versions' field to GetVersion() output.
474 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
475    
476 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
477 - bugfix: sfi was not sending call_id with ListResources to v2 servers
478 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
479 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
480
481 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
482 - client: sfi -a / -p deprecated (use -s instead)
483 - client: sfi cleaned up
484 - client: sfi has backward support for APIv1 aggregates again
485 - server: only APIv2 is supported and should be rather strict
486 - server: settings for turning on/off caching in sm or am
487 - server: plc-dependant code has moved from aggregate to pldriver
488 - server: driver interface extended accordingly
489
490 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
491 - screwed up previous tag
492
493 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
494 - client side revisited with a bootstrap library
495 - client side has a new source layout
496 - various (nasty) bug fixes wrt options and call_id
497
498 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
499 - various fixes in rspecs for sfav1&slice tags
500 - uses 'geni_rspec_version' and not just 'rspec_version'
501 - example flavour for the max testbed
502 - embryo for an sfa client library
503 - topology.py moved into plc
504 - sql: table is named records; record_types are enforced
505 - sql: table creation cleaned up
506
507 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
508 - cleaned up all references to SFA_*_TYPE in config
509 - enable cache at the aggregate by default
510 - registry now uses the driver in a sensible way (see managers/driver.py)
511 - slice manager supports sfav1/pgv2 neighbours
512 - get_key renamed into get_key_from_incoming_ip
513 - new sfa.storage module for record/table and all db-related stuff
514 - db schema in sfa.storage.sfa.sql
515 - init.d and cron.d move one step up
516 - cleaned up rspec/ directory
517 - add deps to pyopenssl and myplc-config
518 - start support for new API (return value)
519 - plc.remoteshell removed, use plshell instead
520 - plshell uses a 'capability' auth method whenever possible
521 - various tweaks in rspec elements
522 - made dependency on sfatables softer
523
524 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
525 - sfa should now be started *before* the initial import
526 - sfa to use its own database (default sfa) - can run without myplc
527 - server calls support optional 'options'
528 - client sends options in argument when needed
529 - fix infinite getattr recursion in elements/element.py
530 - error codes in line with geni
531
532 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
533 - fixed links and attributes in rspecs
534 - minor cleanup in the API methods, and more consistent names in manager methods
535
536 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
537 - ongoing refoactoring towards more genericity
538 - passes tests again although known issues remain with attributes/tags
539
540 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
541 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
542 - improvements in the pgv2 rspecs
543 - driver separated from api
544 - code starts moving around where it belongs
545 - sfascan caches getversion across invokations
546 - vini topology extracted as a config file
547
548 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
549 - first support for protogeni rspecs is working
550 - vini no longer needs a specific manager
551 - refactoring underway towards more flexible/generic architecture
552
553 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
554 - Unicode-friendliness for user names with accents/special chars.
555 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
556 - CreaetSliver no longer fails for users that have a capital letter in their URN.
557 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
558 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
559 - Fix bugs and missing imports     
560  
561
562 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
563 - new method record.get_field for sface
564
565 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
566 - new option -c to sfa-nuke-plc.py
567 - CreateSliver fixed for admin-only slice tags
568
569 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
570 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
571 - Fixed holes in certificate verification logic.
572 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
573 - Added 'boot_state' as an attribute of the node element in SFA rspec.
574 - Non authority certificates are marked as CA:FALSE.
575
576 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
577 - fix typo in sfa-1.0-31 tag.
578 - added CreateGid() Registry interface method.
579
580 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
581 - fix typo in sfa-1.0-30 tag
582
583 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
584 - Declare namespace and schema location in the credential.
585 - Fix bug that prevetend connections from timing out.
586 - Fix slice delegation.
587 - Add statistics to slicemaanger listresources/createsliver rspec.
588 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
589   of days a user can extend their slice expiration.
590 - CA certs are only issued to objects of type authority
591    
592 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
593 - tag 1.0-28 was broken due to typo in the changelog
594 - new class sfa/util/httpsProtocol.py that supports timeouts
595
596 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
597 - Resolved issue that caused sfa hold onto idle db connections.
598 - Fix bug that caused the registry to use the wrong type of credential.
599 - Support authority+sm type.
600 - Fix rspec merging bugs.
601 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
602 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
603  planetlab hosted initscripts using the <planetlab:initscript> tag  
604 - Can now handle extraneous whitespace in the rspec without failing.   
605  
606 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
607 - ProtoGENI v2 RSpec updates.
608 - Convert expiration timestamps with timezone info in credentials to utc.
609 - Fixed redundant logging issue. 
610 - Improved SliceManager and SFI client logging.
611 - Support aggregates that don't support the optional 'call_id' argument. 
612 - Only call get_trusted_certs() at aggreage interfaces that support the call.
613 - CreateSliver() now handles MyPLC slice attributes/tags.
614 - Cache now supports persistence.
615 - Hide whitelisted nodes.
616
617 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
618 - fixed issues with sup authority signing
619 - fixed bugs in remove_slivers and SliverStatus
620
621 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
622 - fix typo that prevented aggregates from operating properly
623
624 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
625 - load trusted certs into ssl context prior to handshake
626 - client's logfile lives in ~/.sfi/sfi.log
627
628 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
629 - includes a change on passphrases that was intended in 1.0-22
630
631 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
632 - Added support for ProtoGENI RSpec v2
633  
634 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
635 - stable sfascan
636 - fix in initscript, *ENABLED tags in config now taken into account
637
638 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
639 - some commits had not been pushed in tag 19
640
641 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
642 - GetVersion should now report full URLs with path
643 - scansfa has nicer output and new syntax (entry URLs as args and not options)
644 - dos2unix'ed flash policy pill
645
646 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
647 - fix packaging again for f8
648
649 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
650 - fix packaging (apparently broken in 1.0-16)
651 - first working version of sfascan
652 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
653 - deprecated the sfa_geni_aggregate config category
654
655 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
656 - Fix build problem
657 - First version of SFA scanner
658
659 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
660 - Add support for Flash clients using flashpolicy
661 - Fix problems with tag handling in RSpec
662
663 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
664 - Modifications to the Eucalyptus Aggregate Manager
665 - Fixes for VINI RSpec
666 - Fix tag handling for PL RSpec
667 - Fix XML Schema ordering for <urn> element
668
669 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
670 - just set x509 version to 2
671
672 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
673 - added urn to the node area in rspecs
674 - conversion to urn now exports fqdn
675 - sfa-import-plc.py now creates a unique registry record for each SFA interface
676
677 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
678 - undo broken attempt for python-2.7
679
680 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
681 - SMs avoid duplicates for when call graph has dags;
682 - just based on network's name, when a duplicate occurs, one is just dropped
683 - does not try to merge/aggregate 2 networks
684 - also reviewed logging with the hope to fix the sfa startup msg:
685 - TypeError: not all arguments converted during string formatting
686
687 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
688 - verify credentials against xsd schema
689 - Fix SM to SM communication
690 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
691 - new setting session_key_path
692
693 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
694 - fix registry credential regeneration and handle expiration
695 - support for setting slice tags (min_role=user)
696 - client can display its own version: sfi.py version --local
697 - GetVersion to provide urn in addition to hrn
698 - more code uses plxrn vs previous helper functions
699 - import replaces '+' in email addresses with '_'
700
701 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
702 - fix GetVersion code_tag and add code_url
703
704 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
705 - extend GetVersion towards minimum federation introspection, and expose local tag
706
707 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
708 - fixed some legacy issues (list vs List)
709 - deprecated sfa.util.namespace for xrn and plxrn
710 - unit tests ship as the sfa-tests rpm
711
712 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
713 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
714 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
715 - hrn-urn translations tweaked
716 - fixed 'service sfa status'
717 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
718 - started to repair sfadump - although not usable yet
719 - trust objects now have dump_string method that dump() actually prints
720 - unit tests under review
721 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
722 - binaries now support -v or -vv to increase loglevel
723 - trashed obsolete sfa.util.client
724
725 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
726 - various bugfixes and cleanup, improved/harmonized logging
727
728 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
729 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
730   to avoid returning a PLCAPI exception that might confuse users.
731 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
732 - fix build errors.  
733
734 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
735 - (Architecture) Credential format changed to match ProtoGENI xml format
736 - (Architecture) All interfaces export a new set of methods that are compatible
737    with the ProtoGeni Aggregate spec. These new methods are considered a 
738    replacement  for the pervious methods exported by the interfaces. All 
739    previous methods are still exported and work as normal, but they are 
740    considered deprecated and will not be supported in future releases.  
741 - (Architecture) SFI has been updated to use the new interface methods.
742 - (Architecture) Changed keyconvet implementation from c to python.
743 - (Architecture) Slice Manager now attempts looks for a delegated credential
744   provided by the client before using its own server credential.
745 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
746   This cache now exists only in memory and is cleared when service is restarted
747   or cache lifetime is exceeded.  
748 - (Performance) SliceManager sends request to Aggregates in parallel instead 
749   of sequentially.
750 - (Bug fix) SFA tickets now support the new rspec format.
751 - (Bug fix) SFI only uses cahced credential if they aren't expired.
752 - (Bug fix) Cerdential delegation modified to work with new credential format.
753 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
754   Aggregate instead of relaying through the Slice Manager.
755 - (Enhancement) Simplified caching. Accociated a global cache instance with
756   the api handler on every new server request, making it easier to access the 
757   cache and use in more general ways.     
758
759 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
760 - SfaServer now uses a pool of threads to handle requests concurrently
761 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
762 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
763 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
764 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
765 - Component manager does not install gid files if slice already has them  
766 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
767 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
768 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
769      
770 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
771 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
772 - - sfa-config-tty now has the same features like plc-config-tty
773 - - Contains code to support both urn and hrn
774 - - Cleaned up request_hash related stuff
775 - - SM, AM and Registry code is organized under respective managers
776 - - Site and Slice synchronization across federated aggregates
777 - - Script to generate sfa_component_config
778
779 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
780 - sfa-config-tty now has the same features like plc-config-tty
781 - Contains code to support both urn and hrn
782 - Cleaned up request_hash related stuff
783 - SM, AM and Registry code is organized under respective managers
784 - Slice synchronization across federated aggregates
785 - some bugs are fixed
786
787 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
788 - checkpoint with fewer mentions of geni
789
790 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
791 - checkpointing
792 - this is believed to pass the tests; among other things:
793 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
794
795 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
796 - This tag includes:
797 - - Sfatables
798 - - Preliminary version of hash based authentication
799 - - Initial code for Component Manager
800 - - Authority structure is moved to /var/lib/sfa/
801 - - some bug-fixes
802
803 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
804 - Create_slice and get_resources methods are connected to sfatables.
805 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
806
807 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
808 - Bug fix on update and remove_peer_object methods
809 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
810
811 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
812 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
813
814 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
815 - compatibility with RefreshPeer
816 - incremental mechanism for importing PLC records into SFA tables
817 - unified single database (still inside the underlying PLC db postgresql server)
818 - includes/improves call traceability and logging features
819 - several bug fixes
820
821 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
822 - added libxslt-python dependency
823
824 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
825 - unified single SFA database in the PLC-DB
826 - upcalls from  PLCAPI to SFA methods
827 - SFA call traceability and logging features
828 - many bug fixes
829 - includes first/rough version of sfatables for policy implementation
830
831 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
832 - snapshot after the GEC5 demo
833 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
834
835 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
836 - snapshot july 15 - has gone through superficial manual testing
837 - hopefully a good basis for gec5 demo
838 - multi-dir sfi client tested as well
839
840 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
841 - rename geniwrapper.spec into sfa.spec
842
843 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
844 - clean up in xmlrpc/soap, --protocol option to chose between both
845 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
846 - hopefully more helpful context in case of crashes when importing
847 - bugfixes for using only /etc/sfa for site-dep files
848 - bugfixes in wsdl generation
849
850 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
851 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
852 - config variables in sfa_config now start with SFA_ and not GENI_
853 - config.py can be loaded even with no config present
854
855 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
856 - first step for cleanup and reorganization
857 - mass-renaming from geni to sfa (some are still needed)
858 - sfa/trust implements the security architecture
859
860 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
861 - snapshot for reproducible builds
862
863 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
864 - snapshot for the convenience of alpha users
865
866 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
867 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
868
869 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
870 - ongoing work - snapshot for 4.3-rc9
871
872 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
873 - various fixes
874
875 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
876 - bugfixes - still a work in progress
877
878 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
879 - initial package
880
881
882 %define module_current_branch 0.2