Merge branch 'master' into senslab2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 21
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description dummy
141 The SFA driver for a Dummy Testbed.
142
143 %description sfatables
144 sfatables is a tool for defining access and admission control policies
145 in an SFA network, in much the same way as iptables is for ip
146 networks. This is the command line interface to manage sfatables
147
148 %description xmlbuilder
149 This package contains the xmlbuilder python library, packaged for
150 convenience as it is not supported by fedora
151
152 %description tests
153 Provides some binary unit tests in /usr/share/sfa/tests
154
155 %prep
156 %setup -q
157
158 %build
159 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %{python_sitelib}/sfa/__init__.py*
170 %{python_sitelib}/sfa/trust
171 %{python_sitelib}/sfa/storage
172 %{python_sitelib}/sfa/util
173 %{python_sitelib}/sfa/server
174 %{python_sitelib}/sfa/methods
175 %{python_sitelib}/sfa/generic
176 %{python_sitelib}/sfa/managers
177 %{python_sitelib}/sfa/importer
178 %{python_sitelib}/sfa/rspecs
179 %{python_sitelib}/sfa/client
180 /etc/init.d/sfa
181 %{_bindir}/sfa-start.py*
182 %{_bindir}/sfaadmin.py*
183 %{_bindir}/sfaadmin
184 %{_bindir}/keyconvert.py*
185 %{_bindir}/sfa-config-tty
186 %{_bindir}/sfa-config
187 %config /etc/sfa/default_config.xml
188 %config (noreplace) /etc/sfa/aggregates.xml
189 %config (noreplace) /etc/sfa/registries.xml
190 /usr/share/sfa/migrations
191 /usr/share/sfa/examples
192 /var/www/html/wsdl/*.wsdl
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files client
199 %config (noreplace) /etc/sfa/sfi_config
200 %{_bindir}/sfi*.py*
201 %{_bindir}/sfi
202 %{_bindir}/get*.py*
203 %{_bindir}/setRecord.py*
204 %{_bindir}/sfascan.py*
205 %{_bindir}/sfascan
206 %{_bindir}/sfadump.py*
207
208 %files plc
209 %defattr(-,root,root)
210 %{python_sitelib}/sfa/planetlab
211 %{python_sitelib}/sfa/openstack
212 /etc/sfa/pl.rng
213 /etc/sfa/credential.xsd
214 /etc/sfa/top.xsd
215 /etc/sfa/sig.xsd
216 /etc/sfa/xml.xsd
217 /etc/sfa/protogeni-rspec-common.xsd
218 /etc/sfa/topology
219 %{_bindir}/gen-sfa-cm-config.py*
220
221 %files cm
222 /etc/init.d/sfa-cm
223 %{_bindir}/sfa_component_setup.py*
224 # cron jobs here 
225
226 %files federica
227 %{python_sitelib}/sfa/federica
228
229 %files nitos
230 %{python_sitelib}/sfa/nitos
231
232 %files dummy
233 %{python_sitelib}/sfa/dummy
234
235 %files sfatables
236 /etc/sfatables/*
237 %{_bindir}/sfatables
238 %{python_sitelib}/sfatables
239
240 %files xmlbuilder
241 %{python_sitelib}/xmlbuilder
242
243 %files tests
244 %{_datadir}/sfa/tests
245
246 ### sfa installs the 'sfa' service
247 %post 
248 chkconfig --add sfa
249
250 %preun 
251 if [ "$1" = 0 ] ; then
252   /sbin/service sfa stop || :
253   /sbin/chkconfig --del sfa || :
254 fi
255
256 %postun
257 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
258
259 ### sfa-cm installs the 'sfa-cm' service
260 %post cm
261 chkconfig --add sfa-cm
262
263 %preun cm
264 if [ "$1" = 0 ] ; then
265    /sbin/service sfa-cm stop || :
266    /sbin/chkconfig --del sfa-cm || :
267 fi
268
269 %postun cm
270 [ "$1" -ge "1" ] && service sfa-cm restart || :
271
272 %changelog
273 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
274 - PL importer: minor fixes for corner cases
275 - PL importer: also handles last_updated more accurately
276 - sfi update can be used to select a key among several in PL
277 - sfi add/update usage message fixes (no more record)
278 - new feature sfaadmin registry check_gid [-a]
279
280 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
281 - fix 2 major bugs in PL importer
282 - esp. wrt GID management against PLC key
283
284 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
285 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
286
287 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
288 - support fordelegation in sfaclientlib
289 - sfi delegate fixed
290 - other delegation-related sfi option trashed
291 - new config (based on ini format)
292 - new dummy driver and related package
293 - pl importer has more explicit error messages
294 - credential dump shows expiration
295
296 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
297 - bugfix in forwarding Resolve requests
298 - various fixes in the nitos driver wrt keys and users
299
300 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
301 - various tweaks for the nitos driver
302
303 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
304 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
305 - deeper cleanup of the data-dependencies between SFA and the testbed
306 - in particular, sfi create issues Resolve(details=False)
307 - for that purpose, Resolve exposes reg-* keys for SFA builtins
308 - which in turn allows sfi list to show PIs, slice members and keys
309 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
310 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
311
312 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
313 - configurable data-dir (/var/lib/sfa)
314 - no more dependent on myplc-config
315 - some support for hrns with _ instead of \.
316 - fix for PL importing in presence of gpg keys
317 - DeleteSliver returns True instead of 1 in case of success
318 - Various improvements on the openstack/nova side
319 - new package sfa-nitos
320
321 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
322 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
323 - sfi to remove expired credentials
324
325 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
326 - Update Openstack driver to support Essex release/
327 - Fix authority xrn bug.
328   
329
330 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
331 - review packaging - site-packages/planetlab now come with sfa-plc
332 - new package sfa-federica
333 - clientbin moved one step upwards
334
335 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
336 - fix bug in sfi update()
337
338 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
339 - fix broken sfa.util.xrn class for lowercase
340
341 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
342 - new 'void' generic_flavour for running in registry-only mode
343 - first shot at refactoring importers - probably needs more work
344 - openstack: various enhancements
345 - sfi interface to registry not based on xml files anymore
346 - sfi show sorts result on record key
347 - bugfix in sfa update on users with a pl-backed registry
348
349 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
350 - renamed sfa/plc into sfa/planetlab
351 - plxrn moved in sfa/planetlab as well
352 - bugfix for sfaadmin reg update --pi <>
353
354 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
355 - native data model now has a authority x user (PI) relationship
356 - no call to 'augment_records_with_testbed_info' for GetCredential
357 - which means, registry can now be used without an underlying testbed
358 - reviewed code about relationships b/w objects and related in pl driver
359 - reviewed PL import wrt roles and pis
360 - removed mentions to is_enabled in driver
361 - small changes in update_relation* in driver interface
362 - sfaadmin: can create authorities and attach pi users to them
363 - sfaadmin: categories can be abbreviated
364 - sfi list and sfaadmin list have a new -r/--recursive option
365 - this means that List now supports an (optional) 'options' argument
366 - sfi config can display config vars
367 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
368
369 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
370 - make sync now supports vserver or lxc.
371 - Added slice expiration and login info to SliverStatus response. 
372 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
373   the 'component_name' attribute.
374 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
375   
376 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
377 - Introduced new administrative command line script, sfaadmin.py. Removed various single
378  purpose scripts and migrated their functionality into sfaadmin.py.
379 - Refactored Registry import scripts.
380 - Removed SQLAlchemy dependency from sfi.py.
381 - Fixed bugs in sfi.py
382 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
383
384 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
385 - slice x researcher rel. in database,
386 - plimporter to maintain that, as well as user.email, and more robust
387 - ongoing draft for sfaadmin tool
388 - support for a federica driver
389 - support for a nova/euca driver
390 - no more sfa-clean-peer-records script
391
392 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
393 - registry database has user's keys and mail (known as v0 for migrate)
394 - pl importer properly maintains user's keys and mail
395 - pl driver now to handle 'role' when adding person record (exp.)
396 - first draft of federica driver with config section
397 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
398 - plus, from master as of tag merged-in-sfa-2.1-2:
399 - disk_image revisited
400 - new nova_shell nova_driver & various tweaks for openstack
401
402 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
403 - uses sqlalchemy and related migrate
404 - thorough migration and upgrade scheme
405 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
406 - trashed dbinfo stuff in auth hierarchy
407 - data model still has little more than plain records
408 - checkpoint tag, not yet intended for release
409
410 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
411 - client: added -R --raw sfi cmdline option that displays raw server response.
412 - client: request GENI RSpec by default. 
413 - server: remove database dependencies from sfa.server.sfaapi.
414 - server: increased default credential lifetime to 31 days.
415 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
416 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
417 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
418  
419 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
420 - bugfix: 'geni_api' should be in the top level struct, not the code struct
421 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
422           output returned by the Aggregate Manager.
423 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
424 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
425 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
426           there is extra whitespace in the schemaLocation field.
427 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
428           advertisement rspecs.
429 - bugfix: <login> RSpec element should contain the 'username' attribute.
430 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
431  
432 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
433 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
434   exit when it encountered a user with an invalid public key.
435 - server: imporved logging in sfa-import-plc.py
436  
437 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
438 - bugfix: Fixed appending public keys in CreateSliver
439 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
440 - client: -c --current option allows users to request the current/uncached rspec.
441 - server: Added 'geni_api_versions' field to GetVersion() output.
442 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
443    
444 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
445 - bugfix: sfi was not sending call_id with ListResources to v2 servers
446 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
447 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
448
449 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
450 - client: sfi -a / -p deprecated (use -s instead)
451 - client: sfi cleaned up
452 - client: sfi has backward support for APIv1 aggregates again
453 - server: only APIv2 is supported and should be rather strict
454 - server: settings for turning on/off caching in sm or am
455 - server: plc-dependant code has moved from aggregate to pldriver
456 - server: driver interface extended accordingly
457
458 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
459 - screwed up previous tag
460
461 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
462 - client side revisited with a bootstrap library
463 - client side has a new source layout
464 - various (nasty) bug fixes wrt options and call_id
465
466 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
467 - various fixes in rspecs for sfav1&slice tags
468 - uses 'geni_rspec_version' and not just 'rspec_version'
469 - example flavour for the max testbed
470 - embryo for an sfa client library
471 - topology.py moved into plc
472 - sql: table is named records; record_types are enforced
473 - sql: table creation cleaned up
474
475 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
476 - cleaned up all references to SFA_*_TYPE in config
477 - enable cache at the aggregate by default
478 - registry now uses the driver in a sensible way (see managers/driver.py)
479 - slice manager supports sfav1/pgv2 neighbours
480 - get_key renamed into get_key_from_incoming_ip
481 - new sfa.storage module for record/table and all db-related stuff
482 - db schema in sfa.storage.sfa.sql
483 - init.d and cron.d move one step up
484 - cleaned up rspec/ directory
485 - add deps to pyopenssl and myplc-config
486 - start support for new API (return value)
487 - plc.remoteshell removed, use plshell instead
488 - plshell uses a 'capability' auth method whenever possible
489 - various tweaks in rspec elements
490 - made dependency on sfatables softer
491
492 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
493 - sfa should now be started *before* the initial import
494 - sfa to use its own database (default sfa) - can run without myplc
495 - server calls support optional 'options'
496 - client sends options in argument when needed
497 - fix infinite getattr recursion in elements/element.py
498 - error codes in line with geni
499
500 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
501 - fixed links and attributes in rspecs
502 - minor cleanup in the API methods, and more consistent names in manager methods
503
504 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
505 - ongoing refoactoring towards more genericity
506 - passes tests again although known issues remain with attributes/tags
507
508 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
509 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
510 - improvements in the pgv2 rspecs
511 - driver separated from api
512 - code starts moving around where it belongs
513 - sfascan caches getversion across invokations
514 - vini topology extracted as a config file
515
516 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
517 - first support for protogeni rspecs is working
518 - vini no longer needs a specific manager
519 - refactoring underway towards more flexible/generic architecture
520
521 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
522 - Unicode-friendliness for user names with accents/special chars.
523 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
524 - CreaetSliver no longer fails for users that have a capital letter in their URN.
525 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
526 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
527 - Fix bugs and missing imports     
528  
529
530 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
531 - new method record.get_field for sface
532
533 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
534 - new option -c to sfa-nuke-plc.py
535 - CreateSliver fixed for admin-only slice tags
536
537 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
538 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
539 - Fixed holes in certificate verification logic.
540 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
541 - Added 'boot_state' as an attribute of the node element in SFA rspec.
542 - Non authority certificates are marked as CA:FALSE.
543
544 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
545 - fix typo in sfa-1.0-31 tag.
546 - added CreateGid() Registry interface method.
547
548 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
549 - fix typo in sfa-1.0-30 tag
550
551 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
552 - Declare namespace and schema location in the credential.
553 - Fix bug that prevetend connections from timing out.
554 - Fix slice delegation.
555 - Add statistics to slicemaanger listresources/createsliver rspec.
556 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
557   of days a user can extend their slice expiration.
558 - CA certs are only issued to objects of type authority
559    
560 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
561 - tag 1.0-28 was broken due to typo in the changelog
562 - new class sfa/util/httpsProtocol.py that supports timeouts
563
564 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
565 - Resolved issue that caused sfa hold onto idle db connections.
566 - Fix bug that caused the registry to use the wrong type of credential.
567 - Support authority+sm type.
568 - Fix rspec merging bugs.
569 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
570 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
571  planetlab hosted initscripts using the <planetlab:initscript> tag  
572 - Can now handle extraneous whitespace in the rspec without failing.   
573  
574 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
575 - ProtoGENI v2 RSpec updates.
576 - Convert expiration timestamps with timezone info in credentials to utc.
577 - Fixed redundant logging issue. 
578 - Improved SliceManager and SFI client logging.
579 - Support aggregates that don't support the optional 'call_id' argument. 
580 - Only call get_trusted_certs() at aggreage interfaces that support the call.
581 - CreateSliver() now handles MyPLC slice attributes/tags.
582 - Cache now supports persistence.
583 - Hide whitelisted nodes.
584
585 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
586 - fixed issues with sup authority signing
587 - fixed bugs in remove_slivers and SliverStatus
588
589 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
590 - fix typo that prevented aggregates from operating properly
591
592 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
593 - load trusted certs into ssl context prior to handshake
594 - client's logfile lives in ~/.sfi/sfi.log
595
596 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
597 - includes a change on passphrases that was intended in 1.0-22
598
599 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
600 - Added support for ProtoGENI RSpec v2
601  
602 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
603 - stable sfascan
604 - fix in initscript, *ENABLED tags in config now taken into account
605
606 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
607 - some commits had not been pushed in tag 19
608
609 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
610 - GetVersion should now report full URLs with path
611 - scansfa has nicer output and new syntax (entry URLs as args and not options)
612 - dos2unix'ed flash policy pill
613
614 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
615 - fix packaging again for f8
616
617 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
618 - fix packaging (apparently broken in 1.0-16)
619 - first working version of sfascan
620 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
621 - deprecated the sfa_geni_aggregate config category
622
623 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
624 - Fix build problem
625 - First version of SFA scanner
626
627 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
628 - Add support for Flash clients using flashpolicy
629 - Fix problems with tag handling in RSpec
630
631 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
632 - Modifications to the Eucalyptus Aggregate Manager
633 - Fixes for VINI RSpec
634 - Fix tag handling for PL RSpec
635 - Fix XML Schema ordering for <urn> element
636
637 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
638 - just set x509 version to 2
639
640 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
641 - added urn to the node area in rspecs
642 - conversion to urn now exports fqdn
643 - sfa-import-plc.py now creates a unique registry record for each SFA interface
644
645 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
646 - undo broken attempt for python-2.7
647
648 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
649 - SMs avoid duplicates for when call graph has dags;
650 - just based on network's name, when a duplicate occurs, one is just dropped
651 - does not try to merge/aggregate 2 networks
652 - also reviewed logging with the hope to fix the sfa startup msg:
653 - TypeError: not all arguments converted during string formatting
654
655 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
656 - verify credentials against xsd schema
657 - Fix SM to SM communication
658 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
659 - new setting session_key_path
660
661 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
662 - fix registry credential regeneration and handle expiration
663 - support for setting slice tags (min_role=user)
664 - client can display its own version: sfi.py version --local
665 - GetVersion to provide urn in addition to hrn
666 - more code uses plxrn vs previous helper functions
667 - import replaces '+' in email addresses with '_'
668
669 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
670 - fix GetVersion code_tag and add code_url
671
672 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
673 - extend GetVersion towards minimum federation introspection, and expose local tag
674
675 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
676 - fixed some legacy issues (list vs List)
677 - deprecated sfa.util.namespace for xrn and plxrn
678 - unit tests ship as the sfa-tests rpm
679
680 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
681 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
682 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
683 - hrn-urn translations tweaked
684 - fixed 'service sfa status'
685 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
686 - started to repair sfadump - although not usable yet
687 - trust objects now have dump_string method that dump() actually prints
688 - unit tests under review
689 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
690 - binaries now support -v or -vv to increase loglevel
691 - trashed obsolete sfa.util.client
692
693 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
694 - various bugfixes and cleanup, improved/harmonized logging
695
696 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
697 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
698   to avoid returning a PLCAPI exception that might confuse users.
699 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
700 - fix build errors.  
701
702 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
703 - (Architecture) Credential format changed to match ProtoGENI xml format
704 - (Architecture) All interfaces export a new set of methods that are compatible
705    with the ProtoGeni Aggregate spec. These new methods are considered a 
706    replacement  for the pervious methods exported by the interfaces. All 
707    previous methods are still exported and work as normal, but they are 
708    considered deprecated and will not be supported in future releases.  
709 - (Architecture) SFI has been updated to use the new interface methods.
710 - (Architecture) Changed keyconvet implementation from c to python.
711 - (Architecture) Slice Manager now attempts looks for a delegated credential
712   provided by the client before using its own server credential.
713 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
714   This cache now exists only in memory and is cleared when service is restarted
715   or cache lifetime is exceeded.  
716 - (Performance) SliceManager sends request to Aggregates in parallel instead 
717   of sequentially.
718 - (Bug fix) SFA tickets now support the new rspec format.
719 - (Bug fix) SFI only uses cahced credential if they aren't expired.
720 - (Bug fix) Cerdential delegation modified to work with new credential format.
721 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
722   Aggregate instead of relaying through the Slice Manager.
723 - (Enhancement) Simplified caching. Accociated a global cache instance with
724   the api handler on every new server request, making it easier to access the 
725   cache and use in more general ways.     
726
727 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
728 - SfaServer now uses a pool of threads to handle requests concurrently
729 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
730 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
731 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
732 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
733 - Component manager does not install gid files if slice already has them  
734 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
735 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
736 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
737      
738 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
739 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
740 - - sfa-config-tty now has the same features like plc-config-tty
741 - - Contains code to support both urn and hrn
742 - - Cleaned up request_hash related stuff
743 - - SM, AM and Registry code is organized under respective managers
744 - - Site and Slice synchronization across federated aggregates
745 - - Script to generate sfa_component_config
746
747 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
748 - sfa-config-tty now has the same features like plc-config-tty
749 - Contains code to support both urn and hrn
750 - Cleaned up request_hash related stuff
751 - SM, AM and Registry code is organized under respective managers
752 - Slice synchronization across federated aggregates
753 - some bugs are fixed
754
755 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
756 - checkpoint with fewer mentions of geni
757
758 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
759 - checkpointing
760 - this is believed to pass the tests; among other things:
761 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
762
763 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
764 - This tag includes:
765 - - Sfatables
766 - - Preliminary version of hash based authentication
767 - - Initial code for Component Manager
768 - - Authority structure is moved to /var/lib/sfa/
769 - - some bug-fixes
770
771 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
772 - Create_slice and get_resources methods are connected to sfatables.
773 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
774
775 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
776 - Bug fix on update and remove_peer_object methods
777 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
778
779 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
780 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
781
782 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
783 - compatibility with RefreshPeer
784 - incremental mechanism for importing PLC records into SFA tables
785 - unified single database (still inside the underlying PLC db postgresql server)
786 - includes/improves call traceability and logging features
787 - several bug fixes
788
789 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
790 - added libxslt-python dependency
791
792 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
793 - unified single SFA database in the PLC-DB
794 - upcalls from  PLCAPI to SFA methods
795 - SFA call traceability and logging features
796 - many bug fixes
797 - includes first/rough version of sfatables for policy implementation
798
799 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
800 - snapshot after the GEC5 demo
801 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
802
803 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
804 - snapshot july 15 - has gone through superficial manual testing
805 - hopefully a good basis for gec5 demo
806 - multi-dir sfi client tested as well
807
808 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
809 - rename geniwrapper.spec into sfa.spec
810
811 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
812 - clean up in xmlrpc/soap, --protocol option to chose between both
813 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
814 - hopefully more helpful context in case of crashes when importing
815 - bugfixes for using only /etc/sfa for site-dep files
816 - bugfixes in wsdl generation
817
818 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
819 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
820 - config variables in sfa_config now start with SFA_ and not GENI_
821 - config.py can be loaded even with no config present
822
823 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
824 - first step for cleanup and reorganization
825 - mass-renaming from geni to sfa (some are still needed)
826 - sfa/trust implements the security architecture
827
828 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
829 - snapshot for reproducible builds
830
831 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
832 - snapshot for the convenience of alpha users
833
834 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
835 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
836
837 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
838 - ongoing work - snapshot for 4.3-rc9
839
840 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
841 - various fixes
842
843 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
844 - bugfixes - still a work in progress
845
846 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
847 - initial package
848
849
850 %define module_current_branch 0.2