bump version number to 3.1
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 3.1
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package senslab
83 Summary: the SFA layer around SensLab
84 Group: Applications/System
85 Requires: sfa
86
87 %package dummy
88 Summary: the SFA layer around a Dummy Testbed 
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa-common
106
107 %description 
108 This package provides the registry, aggregate manager and slice
109 managers for SFA.  In most cases it is advisable to install additional
110 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
111
112 %description common
113 This package contains the python libraries for SFA both client and server-side.
114
115 %description client
116 This package provides the client side of the SFA API, in particular
117 sfi.py, together with other utilities.
118
119 %description plc
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description federica
127 The SFA driver for FEDERICA.
128
129 %description nitos
130 The SFA driver for NITOS.
131
132 %description senslab
133 The SFA driver for SensLab.
134
135 %description dummy
136 The SFA driver for a Dummy Testbed.
137
138 %description sfatables
139 sfatables is a tool for defining access and admission control policies
140 in an SFA network, in much the same way as iptables is for ip
141 networks. This is the command line interface to manage sfatables
142
143 %description xmlbuilder
144 This package contains the xmlbuilder python library, packaged for
145 convenience as it is not supported by fedora
146
147 %description tests
148 Provides some binary unit tests in /usr/share/sfa/tests
149
150 %prep
151 %setup -q
152
153 %build
154 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 %config (noreplace) /etc/sfa/api_versions.xml
175 /usr/share/sfa/migrations
176 /usr/share/sfa/examples
177 /var/www/html/wsdl/*.wsdl
178
179 %files common
180 %{python_sitelib}/sfa/__init__.py*
181 %{python_sitelib}/sfa/trust
182 %{python_sitelib}/sfa/storage
183 %{python_sitelib}/sfa/util
184 %{python_sitelib}/sfa/server
185 %{python_sitelib}/sfa/methods
186 %{python_sitelib}/sfa/generic
187 %{python_sitelib}/sfa/managers
188 %{python_sitelib}/sfa/importer
189 %{python_sitelib}/sfa/rspecs
190 %{python_sitelib}/sfa/client
191
192 %files client
193 %config (noreplace) /etc/sfa/sfi_config
194 %{_bindir}/sfi*.py*
195 %{_bindir}/sfi
196 %{_bindir}/get*.py*
197 %{_bindir}/setRecord.py*
198 %{_bindir}/sfascan.py*
199 %{_bindir}/sfascan
200 %{_bindir}/sfadump.py*
201
202 %files plc
203 %defattr(-,root,root)
204 %{python_sitelib}/sfa/planetlab
205 %{python_sitelib}/sfa/openstack
206 /etc/sfa/pl.rng
207 /etc/sfa/credential.xsd
208 /etc/sfa/top.xsd
209 /etc/sfa/sig.xsd
210 /etc/sfa/xml.xsd
211 /etc/sfa/protogeni-rspec-common.xsd
212 /etc/sfa/topology
213
214 %files flashpolicy
215 %{_bindir}/sfa_flashpolicy.py*
216 /etc/sfa/sfa_flashpolicy_config.xml
217
218 %files federica
219 %{python_sitelib}/sfa/federica
220
221 %files nitos
222 %{python_sitelib}/sfa/nitos
223
224 %files senslab
225 %{python_sitelib}/sfa/iotlab
226
227 %files dummy
228 %{python_sitelib}/sfa/dummy
229
230 %files sfatables
231 /etc/sfatables/*
232 %{_bindir}/sfatables
233 %{python_sitelib}/sfatables
234
235 %files xmlbuilder
236 %{python_sitelib}/xmlbuilder
237
238 %files tests
239 %{_datadir}/sfa/tests
240
241 ### sfa installs the 'sfa' service
242 %post 
243 chkconfig --add sfa
244
245 %preun 
246 if [ "$1" = 0 ] ; then
247   /sbin/service sfa stop || :
248   /sbin/chkconfig --del sfa || :
249 fi
250
251 %postun
252 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
253
254 #### sfa-cm installs the 'sfa-cm' service
255 #%post cm
256 #chkconfig --add sfa-cm
257 #
258 #%preun cm
259 #if [ "$1" = 0 ] ; then
260 #   /sbin/service sfa-cm stop || :
261 #   /sbin/chkconfig --del sfa-cm || :
262 #fi
263 #
264 #%postun cm
265 #[ "$1" -ge "1" ] && service sfa-cm restart || :
266
267 %changelog
268 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-3.0-2
269 - -- core
270 - Extend all versions of rspecs in order to support "links" and "channels" management methods
271 - several fixes aroung Rspecs in order to make the code usable by 3rd-party tools
272 - expose PL node tags in PGv2 and GENIv3 rspecs
273 - fix default slivers mgt in sfav1 rspecs
274 - fix SM and AM urn format in GetVersion
275 - fix sfaadmin.py to handle extra testbed-dependent info
276 - -- PlanetLab
277 - Better management of external Slices/Persons/Sites
278 - Importer ignores external Slices/Persons/Sites
279 - -- Nitos
280 - uniformize Leases management
281 - address channels with urn
282 - -- IotLab
283 - Renaming slab folders, files and variables to iotlab, the new name of the platform.
284 - New class ParsingResourcesFull in Oarrestapi file. Contain all the parsing nodes functions.
285 - Adding a mobile field to iotlab rspec and a mobility type attribute .
286 - Granularity changed to 60 sec.
287 - Fixing returned rspec in GetSlices and GetLeases.
288 - Corrections in import (importing nodes)
289 - More testis in script files under testbeds/iotlab/tests . Creation of Rspecs request models under r testbeds/iotlab/tests /tests_rspec
290 - Lease filtering by date added in GetLeases.
291 - Commenting and cleaning
292
293 * Wed Jun 19 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-3.0-1
294 - AM API v3-based first implementation.
295 - planetlab native V3 driver
296 - dummy native V3 driver
297 - introduction of v2_to_v3_adapter
298 - lease times in RFC3339 date format, not epoch
299 - mostly in line with geni-v2 for non-v3 issues like packaging and all
300
301 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-25
302 - sfi and sfaadmin list now share the same display code for related objs
303 - support for advertising alternate api urls - for other API versions - api_versions.xml
304 - cleaned up GID class
305 - senslab: improved importer
306 - senslab: add site to SlabLocation from Location
307 - senslab: new class JsonPage
308 - senslab:  fix debian packaging
309 - federica: fix list_slices
310
311 * Tue Jan 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-24
312 - merged the senslab driver from git.f-lab.fr
313 - merged the teagle flavour
314 - debian packaging should work much better
315 - added debug messsages for when db connection fails
316
317 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
318 - minor fix in registry
319 - fix for sfi gid, use clientbootstrap
320 - support for debians and ubuntus (packaging and initscript)
321 - deprecated cm package altogether
322 - pl flavour, minor fix for tags
323 - various fixes for the dummy flavour
324
325 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
326 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
327 - tweaks in nitos importer
328 - improvements to sfaadmin check-gid
329
330 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
331 - PL importer: minor fixes for corner cases
332 - PL importer: also handles last_updated more accurately
333 - sfi update can be used to select a key among several in PL
334 - sfi add/update usage message fixes (no more record)
335 - new feature sfaadmin registry check_gid [-a]
336
337 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
338 - fix 2 major bugs in PL importer
339 - esp. wrt GID management against PLC key
340
341 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
342 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
343
344 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
345 - support fordelegation in sfaclientlib
346 - sfi delegate fixed
347 - other delegation-related sfi option trashed
348 - new config (based on ini format)
349 - new dummy driver and related package
350 - pl importer has more explicit error messages
351 - credential dump shows expiration
352
353 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
354 - bugfix in forwarding Resolve requests
355 - various fixes in the nitos driver wrt keys and users
356
357 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
358 - various tweaks for the nitos driver
359
360 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
361 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
362 - deeper cleanup of the data-dependencies between SFA and the testbed
363 - in particular, sfi create issues Resolve(details=False)
364 - for that purpose, Resolve exposes reg-* keys for SFA builtins
365 - which in turn allows sfi list to show PIs, slice members and keys
366 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
367 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
368
369 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
370 - configurable data-dir (/var/lib/sfa)
371 - no more dependent on myplc-config
372 - some support for hrns with _ instead of \.
373 - fix for PL importing in presence of gpg keys
374 - DeleteSliver returns True instead of 1 in case of success
375 - Various improvements on the openstack/nova side
376 - new package sfa-nitos
377
378 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
379 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
380 - sfi to remove expired credentials
381
382 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
383 - Update Openstack driver to support Essex release/
384 - Fix authority xrn bug.
385   
386
387 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
388 - review packaging - site-packages/planetlab now come with sfa-plc
389 - new package sfa-federica
390 - clientbin moved one step upwards
391
392 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
393 - fix bug in sfi update()
394
395 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
396 - fix broken sfa.util.xrn class for lowercase
397
398 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
399 - new 'void' generic_flavour for running in registry-only mode
400 - first shot at refactoring importers - probably needs more work
401 - openstack: various enhancements
402 - sfi interface to registry not based on xml files anymore
403 - sfi show sorts result on record key
404 - bugfix in sfa update on users with a pl-backed registry
405
406 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
407 - renamed sfa/plc into sfa/planetlab
408 - plxrn moved in sfa/planetlab as well
409 - bugfix for sfaadmin reg update --pi <>
410
411 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
412 - native data model now has a authority x user (PI) relationship
413 - no call to 'augment_records_with_testbed_info' for GetCredential
414 - which means, registry can now be used without an underlying testbed
415 - reviewed code about relationships b/w objects and related in pl driver
416 - reviewed PL import wrt roles and pis
417 - removed mentions to is_enabled in driver
418 - small changes in update_relation* in driver interface
419 - sfaadmin: can create authorities and attach pi users to them
420 - sfaadmin: categories can be abbreviated
421 - sfi list and sfaadmin list have a new -r/--recursive option
422 - this means that List now supports an (optional) 'options' argument
423 - sfi config can display config vars
424 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
425
426 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
427 - make sync now supports vserver or lxc.
428 - Added slice expiration and login info to SliverStatus response. 
429 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
430   the 'component_name' attribute.
431 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
432   
433 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
434 - Introduced new administrative command line script, sfaadmin.py. Removed various single
435  purpose scripts and migrated their functionality into sfaadmin.py.
436 - Refactored Registry import scripts.
437 - Removed SQLAlchemy dependency from sfi.py.
438 - Fixed bugs in sfi.py
439 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
440
441 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
442 - slice x researcher rel. in database,
443 - plimporter to maintain that, as well as user.email, and more robust
444 - ongoing draft for sfaadmin tool
445 - support for a federica driver
446 - support for a nova/euca driver
447 - no more sfa-clean-peer-records script
448
449 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
450 - registry database has user's keys and mail (known as v0 for migrate)
451 - pl importer properly maintains user's keys and mail
452 - pl driver now to handle 'role' when adding person record (exp.)
453 - first draft of federica driver with config section
454 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
455 - plus, from master as of tag merged-in-sfa-2.1-2:
456 - disk_image revisited
457 - new nova_shell nova_driver & various tweaks for openstack
458
459 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
460 - uses sqlalchemy and related migrate
461 - thorough migration and upgrade scheme
462 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
463 - trashed dbinfo stuff in auth hierarchy
464 - data model still has little more than plain records
465 - checkpoint tag, not yet intended for release
466
467 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
468 - client: added -R --raw sfi cmdline option that displays raw server response.
469 - client: request GENI RSpec by default. 
470 - server: remove database dependencies from sfa.server.sfaapi.
471 - server: increased default credential lifetime to 31 days.
472 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
473 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
474 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
475  
476 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
477 - bugfix: 'geni_api' should be in the top level struct, not the code struct
478 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
479           output returned by the Aggregate Manager.
480 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
481 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
482 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
483           there is extra whitespace in the schemaLocation field.
484 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
485           advertisement rspecs.
486 - bugfix: <login> RSpec element should contain the 'username' attribute.
487 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
488  
489 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
490 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
491   exit when it encountered a user with an invalid public key.
492 - server: imporved logging in sfa-import-plc.py
493  
494 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
495 - bugfix: Fixed appending public keys in CreateSliver
496 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
497 - client: -c --current option allows users to request the current/uncached rspec.
498 - server: Added 'geni_api_versions' field to GetVersion() output.
499 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
500    
501 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
502 - bugfix: sfi was not sending call_id with ListResources to v2 servers
503 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
504 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
505
506 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
507 - client: sfi -a / -p deprecated (use -s instead)
508 - client: sfi cleaned up
509 - client: sfi has backward support for APIv1 aggregates again
510 - server: only APIv2 is supported and should be rather strict
511 - server: settings for turning on/off caching in sm or am
512 - server: plc-dependant code has moved from aggregate to pldriver
513 - server: driver interface extended accordingly
514
515 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
516 - screwed up previous tag
517
518 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
519 - client side revisited with a bootstrap library
520 - client side has a new source layout
521 - various (nasty) bug fixes wrt options and call_id
522
523 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
524 - various fixes in rspecs for sfav1&slice tags
525 - uses 'geni_rspec_version' and not just 'rspec_version'
526 - example flavour for the max testbed
527 - embryo for an sfa client library
528 - topology.py moved into plc
529 - sql: table is named records; record_types are enforced
530 - sql: table creation cleaned up
531
532 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
533 - cleaned up all references to SFA_*_TYPE in config
534 - enable cache at the aggregate by default
535 - registry now uses the driver in a sensible way (see managers/driver.py)
536 - slice manager supports sfav1/pgv2 neighbours
537 - get_key renamed into get_key_from_incoming_ip
538 - new sfa.storage module for record/table and all db-related stuff
539 - db schema in sfa.storage.sfa.sql
540 - init.d and cron.d move one step up
541 - cleaned up rspec/ directory
542 - add deps to pyopenssl and myplc-config
543 - start support for new API (return value)
544 - plc.remoteshell removed, use plshell instead
545 - plshell uses a 'capability' auth method whenever possible
546 - various tweaks in rspec elements
547 - made dependency on sfatables softer
548
549 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
550 - sfa should now be started *before* the initial import
551 - sfa to use its own database (default sfa) - can run without myplc
552 - server calls support optional 'options'
553 - client sends options in argument when needed
554 - fix infinite getattr recursion in elements/element.py
555 - error codes in line with geni
556
557 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
558 - fixed links and attributes in rspecs
559 - minor cleanup in the API methods, and more consistent names in manager methods
560
561 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
562 - ongoing refoactoring towards more genericity
563 - passes tests again although known issues remain with attributes/tags
564
565 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
566 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
567 - improvements in the pgv2 rspecs
568 - driver separated from api
569 - code starts moving around where it belongs
570 - sfascan caches getversion across invokations
571 - vini topology extracted as a config file
572
573 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
574 - first support for protogeni rspecs is working
575 - vini no longer needs a specific manager
576 - refactoring underway towards more flexible/generic architecture
577
578 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
579 - Unicode-friendliness for user names with accents/special chars.
580 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
581 - CreaetSliver no longer fails for users that have a capital letter in their URN.
582 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
583 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
584 - Fix bugs and missing imports     
585  
586
587 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
588 - new method record.get_field for sface
589
590 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
591 - new option -c to sfa-nuke-plc.py
592 - CreateSliver fixed for admin-only slice tags
593
594 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
595 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
596 - Fixed holes in certificate verification logic.
597 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
598 - Added 'boot_state' as an attribute of the node element in SFA rspec.
599 - Non authority certificates are marked as CA:FALSE.
600
601 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
602 - fix typo in sfa-1.0-31 tag.
603 - added CreateGid() Registry interface method.
604
605 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
606 - fix typo in sfa-1.0-30 tag
607
608 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
609 - Declare namespace and schema location in the credential.
610 - Fix bug that prevetend connections from timing out.
611 - Fix slice delegation.
612 - Add statistics to slicemaanger listresources/createsliver rspec.
613 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
614   of days a user can extend their slice expiration.
615 - CA certs are only issued to objects of type authority
616    
617 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
618 - tag 1.0-28 was broken due to typo in the changelog
619 - new class sfa/util/httpsProtocol.py that supports timeouts
620
621 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
622 - Resolved issue that caused sfa hold onto idle db connections.
623 - Fix bug that caused the registry to use the wrong type of credential.
624 - Support authority+sm type.
625 - Fix rspec merging bugs.
626 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
627 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
628  planetlab hosted initscripts using the <planetlab:initscript> tag  
629 - Can now handle extraneous whitespace in the rspec without failing.   
630  
631 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
632 - ProtoGENI v2 RSpec updates.
633 - Convert expiration timestamps with timezone info in credentials to utc.
634 - Fixed redundant logging issue. 
635 - Improved SliceManager and SFI client logging.
636 - Support aggregates that don't support the optional 'call_id' argument. 
637 - Only call get_trusted_certs() at aggreage interfaces that support the call.
638 - CreateSliver() now handles MyPLC slice attributes/tags.
639 - Cache now supports persistence.
640 - Hide whitelisted nodes.
641
642 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
643 - fixed issues with sup authority signing
644 - fixed bugs in remove_slivers and SliverStatus
645
646 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
647 - fix typo that prevented aggregates from operating properly
648
649 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
650 - load trusted certs into ssl context prior to handshake
651 - client's logfile lives in ~/.sfi/sfi.log
652
653 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
654 - includes a change on passphrases that was intended in 1.0-22
655
656 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
657 - Added support for ProtoGENI RSpec v2
658  
659 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
660 - stable sfascan
661 - fix in initscript, *ENABLED tags in config now taken into account
662
663 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
664 - some commits had not been pushed in tag 19
665
666 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
667 - GetVersion should now report full URLs with path
668 - scansfa has nicer output and new syntax (entry URLs as args and not options)
669 - dos2unix'ed flash policy pill
670
671 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
672 - fix packaging again for f8
673
674 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
675 - fix packaging (apparently broken in 1.0-16)
676 - first working version of sfascan
677 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
678 - deprecated the sfa_geni_aggregate config category
679
680 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
681 - Fix build problem
682 - First version of SFA scanner
683
684 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
685 - Add support for Flash clients using flashpolicy
686 - Fix problems with tag handling in RSpec
687
688 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
689 - Modifications to the Eucalyptus Aggregate Manager
690 - Fixes for VINI RSpec
691 - Fix tag handling for PL RSpec
692 - Fix XML Schema ordering for <urn> element
693
694 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
695 - just set x509 version to 2
696
697 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
698 - added urn to the node area in rspecs
699 - conversion to urn now exports fqdn
700 - sfa-import-plc.py now creates a unique registry record for each SFA interface
701
702 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
703 - undo broken attempt for python-2.7
704
705 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
706 - SMs avoid duplicates for when call graph has dags;
707 - just based on network's name, when a duplicate occurs, one is just dropped
708 - does not try to merge/aggregate 2 networks
709 - also reviewed logging with the hope to fix the sfa startup msg:
710 - TypeError: not all arguments converted during string formatting
711
712 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
713 - verify credentials against xsd schema
714 - Fix SM to SM communication
715 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
716 - new setting session_key_path
717
718 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
719 - fix registry credential regeneration and handle expiration
720 - support for setting slice tags (min_role=user)
721 - client can display its own version: sfi.py version --local
722 - GetVersion to provide urn in addition to hrn
723 - more code uses plxrn vs previous helper functions
724 - import replaces '+' in email addresses with '_'
725
726 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
727 - fix GetVersion code_tag and add code_url
728
729 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
730 - extend GetVersion towards minimum federation introspection, and expose local tag
731
732 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
733 - fixed some legacy issues (list vs List)
734 - deprecated sfa.util.namespace for xrn and plxrn
735 - unit tests ship as the sfa-tests rpm
736
737 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
738 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
739 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
740 - hrn-urn translations tweaked
741 - fixed 'service sfa status'
742 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
743 - started to repair sfadump - although not usable yet
744 - trust objects now have dump_string method that dump() actually prints
745 - unit tests under review
746 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
747 - binaries now support -v or -vv to increase loglevel
748 - trashed obsolete sfa.util.client
749
750 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
751 - various bugfixes and cleanup, improved/harmonized logging
752
753 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
754 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
755   to avoid returning a PLCAPI exception that might confuse users.
756 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
757 - fix build errors.  
758
759 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
760 - (Architecture) Credential format changed to match ProtoGENI xml format
761 - (Architecture) All interfaces export a new set of methods that are compatible
762    with the ProtoGeni Aggregate spec. These new methods are considered a 
763    replacement  for the pervious methods exported by the interfaces. All 
764    previous methods are still exported and work as normal, but they are 
765    considered deprecated and will not be supported in future releases.  
766 - (Architecture) SFI has been updated to use the new interface methods.
767 - (Architecture) Changed keyconvet implementation from c to python.
768 - (Architecture) Slice Manager now attempts looks for a delegated credential
769   provided by the client before using its own server credential.
770 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
771   This cache now exists only in memory and is cleared when service is restarted
772   or cache lifetime is exceeded.  
773 - (Performance) SliceManager sends request to Aggregates in parallel instead 
774   of sequentially.
775 - (Bug fix) SFA tickets now support the new rspec format.
776 - (Bug fix) SFI only uses cahced credential if they aren't expired.
777 - (Bug fix) Cerdential delegation modified to work with new credential format.
778 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
779   Aggregate instead of relaying through the Slice Manager.
780 - (Enhancement) Simplified caching. Accociated a global cache instance with
781   the api handler on every new server request, making it easier to access the 
782   cache and use in more general ways.     
783
784 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
785 - SfaServer now uses a pool of threads to handle requests concurrently
786 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
787 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
788 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
789 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
790 - Component manager does not install gid files if slice already has them  
791 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
792 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
793 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
794      
795 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
796 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
797 - - sfa-config-tty now has the same features like plc-config-tty
798 - - Contains code to support both urn and hrn
799 - - Cleaned up request_hash related stuff
800 - - SM, AM and Registry code is organized under respective managers
801 - - Site and Slice synchronization across federated aggregates
802 - - Script to generate sfa_component_config
803
804 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
805 - sfa-config-tty now has the same features like plc-config-tty
806 - Contains code to support both urn and hrn
807 - Cleaned up request_hash related stuff
808 - SM, AM and Registry code is organized under respective managers
809 - Slice synchronization across federated aggregates
810 - some bugs are fixed
811
812 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
813 - checkpoint with fewer mentions of geni
814
815 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
816 - checkpointing
817 - this is believed to pass the tests; among other things:
818 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
819
820 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
821 - This tag includes:
822 - - Sfatables
823 - - Preliminary version of hash based authentication
824 - - Initial code for Component Manager
825 - - Authority structure is moved to /var/lib/sfa/
826 - - some bug-fixes
827
828 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
829 - Create_slice and get_resources methods are connected to sfatables.
830 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
831
832 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
833 - Bug fix on update and remove_peer_object methods
834 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
835
836 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
837 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
838
839 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
840 - compatibility with RefreshPeer
841 - incremental mechanism for importing PLC records into SFA tables
842 - unified single database (still inside the underlying PLC db postgresql server)
843 - includes/improves call traceability and logging features
844 - several bug fixes
845
846 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
847 - added libxslt-python dependency
848
849 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
850 - unified single SFA database in the PLC-DB
851 - upcalls from  PLCAPI to SFA methods
852 - SFA call traceability and logging features
853 - many bug fixes
854 - includes first/rough version of sfatables for policy implementation
855
856 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
857 - snapshot after the GEC5 demo
858 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
859
860 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
861 - snapshot july 15 - has gone through superficial manual testing
862 - hopefully a good basis for gec5 demo
863 - multi-dir sfi client tested as well
864
865 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
866 - rename geniwrapper.spec into sfa.spec
867
868 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
869 - clean up in xmlrpc/soap, --protocol option to chose between both
870 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
871 - hopefully more helpful context in case of crashes when importing
872 - bugfixes for using only /etc/sfa for site-dep files
873 - bugfixes in wsdl generation
874
875 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
876 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
877 - config variables in sfa_config now start with SFA_ and not GENI_
878 - config.py can be loaded even with no config present
879
880 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
881 - first step for cleanup and reorganization
882 - mass-renaming from geni to sfa (some are still needed)
883 - sfa/trust implements the security architecture
884
885 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
886 - snapshot for reproducible builds
887
888 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
889 - snapshot for the convenience of alpha users
890
891 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
892 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
893
894 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
895 - ongoing work - snapshot for 4.3-rc9
896
897 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
898 - various fixes
899
900 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
901 - bugfixes - still a work in progress
902
903 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
904 - initial package
905
906
907 %define module_current_branch 0.2