Setting tag sfa-2.1-24
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 24
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package senslab
83 Summary: the SFA layer around SensLab
84 Group: Applications/System
85 Requires: sfa
86
87 %package dummy
88 Summary: the SFA layer around a Dummy Testbed 
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa-common
106
107 %description 
108 This package provides the registry, aggregate manager and slice
109 managers for SFA.  In most cases it is advisable to install additional
110 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
111
112 %description common
113 This package contains the python libraries for SFA both client and server-side.
114
115 %description client
116 This package provides the client side of the SFA API, in particular
117 sfi.py, together with other utilities.
118
119 %description plc
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description federica
127 The SFA driver for FEDERICA.
128
129 %description nitos
130 The SFA driver for NITOS.
131
132 %description senslab
133 The SFA driver for SensLab.
134
135 %description dummy
136 The SFA driver for a Dummy Testbed.
137
138 %description sfatables
139 sfatables is a tool for defining access and admission control policies
140 in an SFA network, in much the same way as iptables is for ip
141 networks. This is the command line interface to manage sfatables
142
143 %description xmlbuilder
144 This package contains the xmlbuilder python library, packaged for
145 convenience as it is not supported by fedora
146
147 %description tests
148 Provides some binary unit tests in /usr/share/sfa/tests
149
150 %prep
151 %setup -q
152
153 %build
154 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 /usr/share/sfa/migrations
175 /usr/share/sfa/examples
176 /var/www/html/wsdl/*.wsdl
177
178 %files common
179 %{python_sitelib}/sfa/__init__.py*
180 %{python_sitelib}/sfa/trust
181 %{python_sitelib}/sfa/storage
182 %{python_sitelib}/sfa/util
183 %{python_sitelib}/sfa/server
184 %{python_sitelib}/sfa/methods
185 %{python_sitelib}/sfa/generic
186 %{python_sitelib}/sfa/managers
187 %{python_sitelib}/sfa/importer
188 %{python_sitelib}/sfa/rspecs
189 %{python_sitelib}/sfa/client
190
191 %files client
192 %config (noreplace) /etc/sfa/sfi_config
193 %{_bindir}/sfi*.py*
194 %{_bindir}/sfi
195 %{_bindir}/get*.py*
196 %{_bindir}/setRecord.py*
197 %{_bindir}/sfascan.py*
198 %{_bindir}/sfascan
199 %{_bindir}/sfadump.py*
200
201 %files plc
202 %defattr(-,root,root)
203 %{python_sitelib}/sfa/planetlab
204 %{python_sitelib}/sfa/openstack
205 /etc/sfa/pl.rng
206 /etc/sfa/credential.xsd
207 /etc/sfa/top.xsd
208 /etc/sfa/sig.xsd
209 /etc/sfa/xml.xsd
210 /etc/sfa/protogeni-rspec-common.xsd
211 /etc/sfa/topology
212
213 %files flashpolicy
214 %{_bindir}/sfa_flashpolicy.py*
215 /etc/sfa/sfa_flashpolicy_config.xml
216
217 %files federica
218 %{python_sitelib}/sfa/federica
219
220 %files nitos
221 %{python_sitelib}/sfa/nitos
222
223 %files senslab
224 %{python_sitelib}/sfa/senslab
225
226 %files dummy
227 %{python_sitelib}/sfa/dummy
228
229 %files sfatables
230 /etc/sfatables/*
231 %{_bindir}/sfatables
232 %{python_sitelib}/sfatables
233
234 %files xmlbuilder
235 %{python_sitelib}/xmlbuilder
236
237 %files tests
238 %{_datadir}/sfa/tests
239
240 ### sfa installs the 'sfa' service
241 %post 
242 chkconfig --add sfa
243
244 %preun 
245 if [ "$1" = 0 ] ; then
246   /sbin/service sfa stop || :
247   /sbin/chkconfig --del sfa || :
248 fi
249
250 %postun
251 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
252
253 #### sfa-cm installs the 'sfa-cm' service
254 #%post cm
255 #chkconfig --add sfa-cm
256 #
257 #%preun cm
258 #if [ "$1" = 0 ] ; then
259 #   /sbin/service sfa-cm stop || :
260 #   /sbin/chkconfig --del sfa-cm || :
261 #fi
262 #
263 #%postun cm
264 #[ "$1" -ge "1" ] && service sfa-cm restart || :
265
266 %changelog
267 * Tue Jan 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-24
268 - merged the senslab driver from git.f-lab.fr
269 - merged the teagle flavour
270 - debian packaging should work much better
271 - added debug messsages for when db connection fails
272
273 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
274 - minor fix in registry
275 - fix for sfi gid, use clientbootstrap
276 - support for debians and ubuntus (packaging and initscript)
277 - deprecated cm package altogether
278 - pl flavour, minor fix for tags
279 - various fixes for the dummy flavour
280
281 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
282 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
283 - tweaks in nitos importer
284 - improvements to sfaadmin check-gid
285
286 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
287 - PL importer: minor fixes for corner cases
288 - PL importer: also handles last_updated more accurately
289 - sfi update can be used to select a key among several in PL
290 - sfi add/update usage message fixes (no more record)
291 - new feature sfaadmin registry check_gid [-a]
292
293 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
294 - fix 2 major bugs in PL importer
295 - esp. wrt GID management against PLC key
296
297 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
298 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
299
300 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
301 - support fordelegation in sfaclientlib
302 - sfi delegate fixed
303 - other delegation-related sfi option trashed
304 - new config (based on ini format)
305 - new dummy driver and related package
306 - pl importer has more explicit error messages
307 - credential dump shows expiration
308
309 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
310 - bugfix in forwarding Resolve requests
311 - various fixes in the nitos driver wrt keys and users
312
313 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
314 - various tweaks for the nitos driver
315
316 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
317 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
318 - deeper cleanup of the data-dependencies between SFA and the testbed
319 - in particular, sfi create issues Resolve(details=False)
320 - for that purpose, Resolve exposes reg-* keys for SFA builtins
321 - which in turn allows sfi list to show PIs, slice members and keys
322 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
323 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
324
325 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
326 - configurable data-dir (/var/lib/sfa)
327 - no more dependent on myplc-config
328 - some support for hrns with _ instead of \.
329 - fix for PL importing in presence of gpg keys
330 - DeleteSliver returns True instead of 1 in case of success
331 - Various improvements on the openstack/nova side
332 - new package sfa-nitos
333
334 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
335 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
336 - sfi to remove expired credentials
337
338 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
339 - Update Openstack driver to support Essex release/
340 - Fix authority xrn bug.
341   
342
343 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
344 - review packaging - site-packages/planetlab now come with sfa-plc
345 - new package sfa-federica
346 - clientbin moved one step upwards
347
348 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
349 - fix bug in sfi update()
350
351 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
352 - fix broken sfa.util.xrn class for lowercase
353
354 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
355 - new 'void' generic_flavour for running in registry-only mode
356 - first shot at refactoring importers - probably needs more work
357 - openstack: various enhancements
358 - sfi interface to registry not based on xml files anymore
359 - sfi show sorts result on record key
360 - bugfix in sfa update on users with a pl-backed registry
361
362 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
363 - renamed sfa/plc into sfa/planetlab
364 - plxrn moved in sfa/planetlab as well
365 - bugfix for sfaadmin reg update --pi <>
366
367 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
368 - native data model now has a authority x user (PI) relationship
369 - no call to 'augment_records_with_testbed_info' for GetCredential
370 - which means, registry can now be used without an underlying testbed
371 - reviewed code about relationships b/w objects and related in pl driver
372 - reviewed PL import wrt roles and pis
373 - removed mentions to is_enabled in driver
374 - small changes in update_relation* in driver interface
375 - sfaadmin: can create authorities and attach pi users to them
376 - sfaadmin: categories can be abbreviated
377 - sfi list and sfaadmin list have a new -r/--recursive option
378 - this means that List now supports an (optional) 'options' argument
379 - sfi config can display config vars
380 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
381
382 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
383 - make sync now supports vserver or lxc.
384 - Added slice expiration and login info to SliverStatus response. 
385 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
386   the 'component_name' attribute.
387 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
388   
389 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
390 - Introduced new administrative command line script, sfaadmin.py. Removed various single
391  purpose scripts and migrated their functionality into sfaadmin.py.
392 - Refactored Registry import scripts.
393 - Removed SQLAlchemy dependency from sfi.py.
394 - Fixed bugs in sfi.py
395 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
396
397 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
398 - slice x researcher rel. in database,
399 - plimporter to maintain that, as well as user.email, and more robust
400 - ongoing draft for sfaadmin tool
401 - support for a federica driver
402 - support for a nova/euca driver
403 - no more sfa-clean-peer-records script
404
405 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
406 - registry database has user's keys and mail (known as v0 for migrate)
407 - pl importer properly maintains user's keys and mail
408 - pl driver now to handle 'role' when adding person record (exp.)
409 - first draft of federica driver with config section
410 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
411 - plus, from master as of tag merged-in-sfa-2.1-2:
412 - disk_image revisited
413 - new nova_shell nova_driver & various tweaks for openstack
414
415 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
416 - uses sqlalchemy and related migrate
417 - thorough migration and upgrade scheme
418 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
419 - trashed dbinfo stuff in auth hierarchy
420 - data model still has little more than plain records
421 - checkpoint tag, not yet intended for release
422
423 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
424 - client: added -R --raw sfi cmdline option that displays raw server response.
425 - client: request GENI RSpec by default. 
426 - server: remove database dependencies from sfa.server.sfaapi.
427 - server: increased default credential lifetime to 31 days.
428 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
429 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
430 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
431  
432 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
433 - bugfix: 'geni_api' should be in the top level struct, not the code struct
434 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
435           output returned by the Aggregate Manager.
436 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
437 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
438 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
439           there is extra whitespace in the schemaLocation field.
440 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
441           advertisement rspecs.
442 - bugfix: <login> RSpec element should contain the 'username' attribute.
443 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
444  
445 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
446 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
447   exit when it encountered a user with an invalid public key.
448 - server: imporved logging in sfa-import-plc.py
449  
450 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
451 - bugfix: Fixed appending public keys in CreateSliver
452 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
453 - client: -c --current option allows users to request the current/uncached rspec.
454 - server: Added 'geni_api_versions' field to GetVersion() output.
455 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
456    
457 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
458 - bugfix: sfi was not sending call_id with ListResources to v2 servers
459 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
460 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
461
462 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
463 - client: sfi -a / -p deprecated (use -s instead)
464 - client: sfi cleaned up
465 - client: sfi has backward support for APIv1 aggregates again
466 - server: only APIv2 is supported and should be rather strict
467 - server: settings for turning on/off caching in sm or am
468 - server: plc-dependant code has moved from aggregate to pldriver
469 - server: driver interface extended accordingly
470
471 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
472 - screwed up previous tag
473
474 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
475 - client side revisited with a bootstrap library
476 - client side has a new source layout
477 - various (nasty) bug fixes wrt options and call_id
478
479 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
480 - various fixes in rspecs for sfav1&slice tags
481 - uses 'geni_rspec_version' and not just 'rspec_version'
482 - example flavour for the max testbed
483 - embryo for an sfa client library
484 - topology.py moved into plc
485 - sql: table is named records; record_types are enforced
486 - sql: table creation cleaned up
487
488 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
489 - cleaned up all references to SFA_*_TYPE in config
490 - enable cache at the aggregate by default
491 - registry now uses the driver in a sensible way (see managers/driver.py)
492 - slice manager supports sfav1/pgv2 neighbours
493 - get_key renamed into get_key_from_incoming_ip
494 - new sfa.storage module for record/table and all db-related stuff
495 - db schema in sfa.storage.sfa.sql
496 - init.d and cron.d move one step up
497 - cleaned up rspec/ directory
498 - add deps to pyopenssl and myplc-config
499 - start support for new API (return value)
500 - plc.remoteshell removed, use plshell instead
501 - plshell uses a 'capability' auth method whenever possible
502 - various tweaks in rspec elements
503 - made dependency on sfatables softer
504
505 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
506 - sfa should now be started *before* the initial import
507 - sfa to use its own database (default sfa) - can run without myplc
508 - server calls support optional 'options'
509 - client sends options in argument when needed
510 - fix infinite getattr recursion in elements/element.py
511 - error codes in line with geni
512
513 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
514 - fixed links and attributes in rspecs
515 - minor cleanup in the API methods, and more consistent names in manager methods
516
517 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
518 - ongoing refoactoring towards more genericity
519 - passes tests again although known issues remain with attributes/tags
520
521 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
522 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
523 - improvements in the pgv2 rspecs
524 - driver separated from api
525 - code starts moving around where it belongs
526 - sfascan caches getversion across invokations
527 - vini topology extracted as a config file
528
529 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
530 - first support for protogeni rspecs is working
531 - vini no longer needs a specific manager
532 - refactoring underway towards more flexible/generic architecture
533
534 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
535 - Unicode-friendliness for user names with accents/special chars.
536 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
537 - CreaetSliver no longer fails for users that have a capital letter in their URN.
538 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
539 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
540 - Fix bugs and missing imports     
541  
542
543 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
544 - new method record.get_field for sface
545
546 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
547 - new option -c to sfa-nuke-plc.py
548 - CreateSliver fixed for admin-only slice tags
549
550 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
551 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
552 - Fixed holes in certificate verification logic.
553 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
554 - Added 'boot_state' as an attribute of the node element in SFA rspec.
555 - Non authority certificates are marked as CA:FALSE.
556
557 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
558 - fix typo in sfa-1.0-31 tag.
559 - added CreateGid() Registry interface method.
560
561 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
562 - fix typo in sfa-1.0-30 tag
563
564 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
565 - Declare namespace and schema location in the credential.
566 - Fix bug that prevetend connections from timing out.
567 - Fix slice delegation.
568 - Add statistics to slicemaanger listresources/createsliver rspec.
569 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
570   of days a user can extend their slice expiration.
571 - CA certs are only issued to objects of type authority
572    
573 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
574 - tag 1.0-28 was broken due to typo in the changelog
575 - new class sfa/util/httpsProtocol.py that supports timeouts
576
577 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
578 - Resolved issue that caused sfa hold onto idle db connections.
579 - Fix bug that caused the registry to use the wrong type of credential.
580 - Support authority+sm type.
581 - Fix rspec merging bugs.
582 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
583 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
584  planetlab hosted initscripts using the <planetlab:initscript> tag  
585 - Can now handle extraneous whitespace in the rspec without failing.   
586  
587 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
588 - ProtoGENI v2 RSpec updates.
589 - Convert expiration timestamps with timezone info in credentials to utc.
590 - Fixed redundant logging issue. 
591 - Improved SliceManager and SFI client logging.
592 - Support aggregates that don't support the optional 'call_id' argument. 
593 - Only call get_trusted_certs() at aggreage interfaces that support the call.
594 - CreateSliver() now handles MyPLC slice attributes/tags.
595 - Cache now supports persistence.
596 - Hide whitelisted nodes.
597
598 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
599 - fixed issues with sup authority signing
600 - fixed bugs in remove_slivers and SliverStatus
601
602 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
603 - fix typo that prevented aggregates from operating properly
604
605 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
606 - load trusted certs into ssl context prior to handshake
607 - client's logfile lives in ~/.sfi/sfi.log
608
609 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
610 - includes a change on passphrases that was intended in 1.0-22
611
612 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
613 - Added support for ProtoGENI RSpec v2
614  
615 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
616 - stable sfascan
617 - fix in initscript, *ENABLED tags in config now taken into account
618
619 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
620 - some commits had not been pushed in tag 19
621
622 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
623 - GetVersion should now report full URLs with path
624 - scansfa has nicer output and new syntax (entry URLs as args and not options)
625 - dos2unix'ed flash policy pill
626
627 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
628 - fix packaging again for f8
629
630 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
631 - fix packaging (apparently broken in 1.0-16)
632 - first working version of sfascan
633 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
634 - deprecated the sfa_geni_aggregate config category
635
636 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
637 - Fix build problem
638 - First version of SFA scanner
639
640 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
641 - Add support for Flash clients using flashpolicy
642 - Fix problems with tag handling in RSpec
643
644 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
645 - Modifications to the Eucalyptus Aggregate Manager
646 - Fixes for VINI RSpec
647 - Fix tag handling for PL RSpec
648 - Fix XML Schema ordering for <urn> element
649
650 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
651 - just set x509 version to 2
652
653 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
654 - added urn to the node area in rspecs
655 - conversion to urn now exports fqdn
656 - sfa-import-plc.py now creates a unique registry record for each SFA interface
657
658 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
659 - undo broken attempt for python-2.7
660
661 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
662 - SMs avoid duplicates for when call graph has dags;
663 - just based on network's name, when a duplicate occurs, one is just dropped
664 - does not try to merge/aggregate 2 networks
665 - also reviewed logging with the hope to fix the sfa startup msg:
666 - TypeError: not all arguments converted during string formatting
667
668 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
669 - verify credentials against xsd schema
670 - Fix SM to SM communication
671 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
672 - new setting session_key_path
673
674 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
675 - fix registry credential regeneration and handle expiration
676 - support for setting slice tags (min_role=user)
677 - client can display its own version: sfi.py version --local
678 - GetVersion to provide urn in addition to hrn
679 - more code uses plxrn vs previous helper functions
680 - import replaces '+' in email addresses with '_'
681
682 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
683 - fix GetVersion code_tag and add code_url
684
685 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
686 - extend GetVersion towards minimum federation introspection, and expose local tag
687
688 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
689 - fixed some legacy issues (list vs List)
690 - deprecated sfa.util.namespace for xrn and plxrn
691 - unit tests ship as the sfa-tests rpm
692
693 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
694 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
695 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
696 - hrn-urn translations tweaked
697 - fixed 'service sfa status'
698 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
699 - started to repair sfadump - although not usable yet
700 - trust objects now have dump_string method that dump() actually prints
701 - unit tests under review
702 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
703 - binaries now support -v or -vv to increase loglevel
704 - trashed obsolete sfa.util.client
705
706 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
707 - various bugfixes and cleanup, improved/harmonized logging
708
709 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
710 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
711   to avoid returning a PLCAPI exception that might confuse users.
712 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
713 - fix build errors.  
714
715 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
716 - (Architecture) Credential format changed to match ProtoGENI xml format
717 - (Architecture) All interfaces export a new set of methods that are compatible
718    with the ProtoGeni Aggregate spec. These new methods are considered a 
719    replacement  for the pervious methods exported by the interfaces. All 
720    previous methods are still exported and work as normal, but they are 
721    considered deprecated and will not be supported in future releases.  
722 - (Architecture) SFI has been updated to use the new interface methods.
723 - (Architecture) Changed keyconvet implementation from c to python.
724 - (Architecture) Slice Manager now attempts looks for a delegated credential
725   provided by the client before using its own server credential.
726 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
727   This cache now exists only in memory and is cleared when service is restarted
728   or cache lifetime is exceeded.  
729 - (Performance) SliceManager sends request to Aggregates in parallel instead 
730   of sequentially.
731 - (Bug fix) SFA tickets now support the new rspec format.
732 - (Bug fix) SFI only uses cahced credential if they aren't expired.
733 - (Bug fix) Cerdential delegation modified to work with new credential format.
734 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
735   Aggregate instead of relaying through the Slice Manager.
736 - (Enhancement) Simplified caching. Accociated a global cache instance with
737   the api handler on every new server request, making it easier to access the 
738   cache and use in more general ways.     
739
740 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
741 - SfaServer now uses a pool of threads to handle requests concurrently
742 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
743 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
744 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
745 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
746 - Component manager does not install gid files if slice already has them  
747 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
748 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
749 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
750      
751 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
752 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
753 - - sfa-config-tty now has the same features like plc-config-tty
754 - - Contains code to support both urn and hrn
755 - - Cleaned up request_hash related stuff
756 - - SM, AM and Registry code is organized under respective managers
757 - - Site and Slice synchronization across federated aggregates
758 - - Script to generate sfa_component_config
759
760 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
761 - sfa-config-tty now has the same features like plc-config-tty
762 - Contains code to support both urn and hrn
763 - Cleaned up request_hash related stuff
764 - SM, AM and Registry code is organized under respective managers
765 - Slice synchronization across federated aggregates
766 - some bugs are fixed
767
768 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
769 - checkpoint with fewer mentions of geni
770
771 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
772 - checkpointing
773 - this is believed to pass the tests; among other things:
774 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
775
776 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
777 - This tag includes:
778 - - Sfatables
779 - - Preliminary version of hash based authentication
780 - - Initial code for Component Manager
781 - - Authority structure is moved to /var/lib/sfa/
782 - - some bug-fixes
783
784 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
785 - Create_slice and get_resources methods are connected to sfatables.
786 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
787
788 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
789 - Bug fix on update and remove_peer_object methods
790 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
791
792 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
793 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
794
795 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
796 - compatibility with RefreshPeer
797 - incremental mechanism for importing PLC records into SFA tables
798 - unified single database (still inside the underlying PLC db postgresql server)
799 - includes/improves call traceability and logging features
800 - several bug fixes
801
802 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
803 - added libxslt-python dependency
804
805 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
806 - unified single SFA database in the PLC-DB
807 - upcalls from  PLCAPI to SFA methods
808 - SFA call traceability and logging features
809 - many bug fixes
810 - includes first/rough version of sfatables for policy implementation
811
812 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
813 - snapshot after the GEC5 demo
814 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
815
816 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
817 - snapshot july 15 - has gone through superficial manual testing
818 - hopefully a good basis for gec5 demo
819 - multi-dir sfi client tested as well
820
821 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
822 - rename geniwrapper.spec into sfa.spec
823
824 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
825 - clean up in xmlrpc/soap, --protocol option to chose between both
826 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
827 - hopefully more helpful context in case of crashes when importing
828 - bugfixes for using only /etc/sfa for site-dep files
829 - bugfixes in wsdl generation
830
831 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
832 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
833 - config variables in sfa_config now start with SFA_ and not GENI_
834 - config.py can be loaded even with no config present
835
836 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
837 - first step for cleanup and reorganization
838 - mass-renaming from geni to sfa (some are still needed)
839 - sfa/trust implements the security architecture
840
841 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
842 - snapshot for reproducible builds
843
844 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
845 - snapshot for the convenience of alpha users
846
847 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
848 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
849
850 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
851 - ongoing work - snapshot for 4.3-rc9
852
853 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
854 - various fixes
855
856 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
857 - bugfixes - still a work in progress
858
859 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
860 - initial package
861
862
863 %define module_current_branch 0.2