pagkage /etc/sfa/api_versions.xml
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 24
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package senslab
83 Summary: the SFA layer around SensLab
84 Group: Applications/System
85 Requires: sfa
86
87 %package dummy
88 Summary: the SFA layer around a Dummy Testbed 
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa-common
106
107 %description 
108 This package provides the registry, aggregate manager and slice
109 managers for SFA.  In most cases it is advisable to install additional
110 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
111
112 %description common
113 This package contains the python libraries for SFA both client and server-side.
114
115 %description client
116 This package provides the client side of the SFA API, in particular
117 sfi.py, together with other utilities.
118
119 %description plc
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description federica
127 The SFA driver for FEDERICA.
128
129 %description nitos
130 The SFA driver for NITOS.
131
132 %description senslab
133 The SFA driver for SensLab.
134
135 %description dummy
136 The SFA driver for a Dummy Testbed.
137
138 %description sfatables
139 sfatables is a tool for defining access and admission control policies
140 in an SFA network, in much the same way as iptables is for ip
141 networks. This is the command line interface to manage sfatables
142
143 %description xmlbuilder
144 This package contains the xmlbuilder python library, packaged for
145 convenience as it is not supported by fedora
146
147 %description tests
148 Provides some binary unit tests in /usr/share/sfa/tests
149
150 %prep
151 %setup -q
152
153 %build
154 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 %config (noreplace) /etc/sfa/api_versions.xml
175 /usr/share/sfa/migrations
176 /usr/share/sfa/examples
177 /var/www/html/wsdl/*.wsdl
178
179 %files common
180 %{python_sitelib}/sfa/__init__.py*
181 %{python_sitelib}/sfa/trust
182 %{python_sitelib}/sfa/storage
183 %{python_sitelib}/sfa/util
184 %{python_sitelib}/sfa/server
185 %{python_sitelib}/sfa/methods
186 %{python_sitelib}/sfa/generic
187 %{python_sitelib}/sfa/managers
188 %{python_sitelib}/sfa/importer
189 %{python_sitelib}/sfa/rspecs
190 %{python_sitelib}/sfa/client
191
192 %files client
193 %config (noreplace) /etc/sfa/sfi_config
194 %{_bindir}/sfi*.py*
195 %{_bindir}/sfi
196 %{_bindir}/get*.py*
197 %{_bindir}/setRecord.py*
198 %{_bindir}/sfascan.py*
199 %{_bindir}/sfascan
200 %{_bindir}/sfadump.py*
201
202 %files plc
203 %defattr(-,root,root)
204 %{python_sitelib}/sfa/planetlab
205 %{python_sitelib}/sfa/openstack
206 /etc/sfa/pl.rng
207 /etc/sfa/credential.xsd
208 /etc/sfa/top.xsd
209 /etc/sfa/sig.xsd
210 /etc/sfa/xml.xsd
211 /etc/sfa/protogeni-rspec-common.xsd
212 /etc/sfa/topology
213
214 %files flashpolicy
215 %{_bindir}/sfa_flashpolicy.py*
216 /etc/sfa/sfa_flashpolicy_config.xml
217
218 %files federica
219 %{python_sitelib}/sfa/federica
220
221 %files nitos
222 %{python_sitelib}/sfa/nitos
223
224 %files senslab
225 %{python_sitelib}/sfa/senslab
226
227 %files dummy
228 %{python_sitelib}/sfa/dummy
229
230 %files sfatables
231 /etc/sfatables/*
232 %{_bindir}/sfatables
233 %{python_sitelib}/sfatables
234
235 %files xmlbuilder
236 %{python_sitelib}/xmlbuilder
237
238 %files tests
239 %{_datadir}/sfa/tests
240
241 ### sfa installs the 'sfa' service
242 %post 
243 chkconfig --add sfa
244
245 %preun 
246 if [ "$1" = 0 ] ; then
247   /sbin/service sfa stop || :
248   /sbin/chkconfig --del sfa || :
249 fi
250
251 %postun
252 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
253
254 #### sfa-cm installs the 'sfa-cm' service
255 #%post cm
256 #chkconfig --add sfa-cm
257 #
258 #%preun cm
259 #if [ "$1" = 0 ] ; then
260 #   /sbin/service sfa-cm stop || :
261 #   /sbin/chkconfig --del sfa-cm || :
262 #fi
263 #
264 #%postun cm
265 #[ "$1" -ge "1" ] && service sfa-cm restart || :
266
267 %changelog
268 * Tue Jan 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-24
269 - merged the senslab driver from git.f-lab.fr
270 - merged the teagle flavour
271 - debian packaging should work much better
272 - added debug messsages for when db connection fails
273
274 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
275 - minor fix in registry
276 - fix for sfi gid, use clientbootstrap
277 - support for debians and ubuntus (packaging and initscript)
278 - deprecated cm package altogether
279 - pl flavour, minor fix for tags
280 - various fixes for the dummy flavour
281
282 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
283 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
284 - tweaks in nitos importer
285 - improvements to sfaadmin check-gid
286
287 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
288 - PL importer: minor fixes for corner cases
289 - PL importer: also handles last_updated more accurately
290 - sfi update can be used to select a key among several in PL
291 - sfi add/update usage message fixes (no more record)
292 - new feature sfaadmin registry check_gid [-a]
293
294 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
295 - fix 2 major bugs in PL importer
296 - esp. wrt GID management against PLC key
297
298 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
299 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
300
301 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
302 - support fordelegation in sfaclientlib
303 - sfi delegate fixed
304 - other delegation-related sfi option trashed
305 - new config (based on ini format)
306 - new dummy driver and related package
307 - pl importer has more explicit error messages
308 - credential dump shows expiration
309
310 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
311 - bugfix in forwarding Resolve requests
312 - various fixes in the nitos driver wrt keys and users
313
314 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
315 - various tweaks for the nitos driver
316
317 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
318 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
319 - deeper cleanup of the data-dependencies between SFA and the testbed
320 - in particular, sfi create issues Resolve(details=False)
321 - for that purpose, Resolve exposes reg-* keys for SFA builtins
322 - which in turn allows sfi list to show PIs, slice members and keys
323 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
324 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
325
326 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
327 - configurable data-dir (/var/lib/sfa)
328 - no more dependent on myplc-config
329 - some support for hrns with _ instead of \.
330 - fix for PL importing in presence of gpg keys
331 - DeleteSliver returns True instead of 1 in case of success
332 - Various improvements on the openstack/nova side
333 - new package sfa-nitos
334
335 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
336 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
337 - sfi to remove expired credentials
338
339 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
340 - Update Openstack driver to support Essex release/
341 - Fix authority xrn bug.
342   
343
344 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
345 - review packaging - site-packages/planetlab now come with sfa-plc
346 - new package sfa-federica
347 - clientbin moved one step upwards
348
349 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
350 - fix bug in sfi update()
351
352 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
353 - fix broken sfa.util.xrn class for lowercase
354
355 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
356 - new 'void' generic_flavour for running in registry-only mode
357 - first shot at refactoring importers - probably needs more work
358 - openstack: various enhancements
359 - sfi interface to registry not based on xml files anymore
360 - sfi show sorts result on record key
361 - bugfix in sfa update on users with a pl-backed registry
362
363 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
364 - renamed sfa/plc into sfa/planetlab
365 - plxrn moved in sfa/planetlab as well
366 - bugfix for sfaadmin reg update --pi <>
367
368 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
369 - native data model now has a authority x user (PI) relationship
370 - no call to 'augment_records_with_testbed_info' for GetCredential
371 - which means, registry can now be used without an underlying testbed
372 - reviewed code about relationships b/w objects and related in pl driver
373 - reviewed PL import wrt roles and pis
374 - removed mentions to is_enabled in driver
375 - small changes in update_relation* in driver interface
376 - sfaadmin: can create authorities and attach pi users to them
377 - sfaadmin: categories can be abbreviated
378 - sfi list and sfaadmin list have a new -r/--recursive option
379 - this means that List now supports an (optional) 'options' argument
380 - sfi config can display config vars
381 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
382
383 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
384 - make sync now supports vserver or lxc.
385 - Added slice expiration and login info to SliverStatus response. 
386 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
387   the 'component_name' attribute.
388 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
389   
390 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
391 - Introduced new administrative command line script, sfaadmin.py. Removed various single
392  purpose scripts and migrated their functionality into sfaadmin.py.
393 - Refactored Registry import scripts.
394 - Removed SQLAlchemy dependency from sfi.py.
395 - Fixed bugs in sfi.py
396 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
397
398 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
399 - slice x researcher rel. in database,
400 - plimporter to maintain that, as well as user.email, and more robust
401 - ongoing draft for sfaadmin tool
402 - support for a federica driver
403 - support for a nova/euca driver
404 - no more sfa-clean-peer-records script
405
406 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
407 - registry database has user's keys and mail (known as v0 for migrate)
408 - pl importer properly maintains user's keys and mail
409 - pl driver now to handle 'role' when adding person record (exp.)
410 - first draft of federica driver with config section
411 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
412 - plus, from master as of tag merged-in-sfa-2.1-2:
413 - disk_image revisited
414 - new nova_shell nova_driver & various tweaks for openstack
415
416 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
417 - uses sqlalchemy and related migrate
418 - thorough migration and upgrade scheme
419 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
420 - trashed dbinfo stuff in auth hierarchy
421 - data model still has little more than plain records
422 - checkpoint tag, not yet intended for release
423
424 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
425 - client: added -R --raw sfi cmdline option that displays raw server response.
426 - client: request GENI RSpec by default. 
427 - server: remove database dependencies from sfa.server.sfaapi.
428 - server: increased default credential lifetime to 31 days.
429 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
430 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
431 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
432  
433 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
434 - bugfix: 'geni_api' should be in the top level struct, not the code struct
435 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
436           output returned by the Aggregate Manager.
437 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
438 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
439 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
440           there is extra whitespace in the schemaLocation field.
441 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
442           advertisement rspecs.
443 - bugfix: <login> RSpec element should contain the 'username' attribute.
444 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
445  
446 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
447 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
448   exit when it encountered a user with an invalid public key.
449 - server: imporved logging in sfa-import-plc.py
450  
451 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
452 - bugfix: Fixed appending public keys in CreateSliver
453 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
454 - client: -c --current option allows users to request the current/uncached rspec.
455 - server: Added 'geni_api_versions' field to GetVersion() output.
456 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
457    
458 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
459 - bugfix: sfi was not sending call_id with ListResources to v2 servers
460 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
461 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
462
463 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
464 - client: sfi -a / -p deprecated (use -s instead)
465 - client: sfi cleaned up
466 - client: sfi has backward support for APIv1 aggregates again
467 - server: only APIv2 is supported and should be rather strict
468 - server: settings for turning on/off caching in sm or am
469 - server: plc-dependant code has moved from aggregate to pldriver
470 - server: driver interface extended accordingly
471
472 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
473 - screwed up previous tag
474
475 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
476 - client side revisited with a bootstrap library
477 - client side has a new source layout
478 - various (nasty) bug fixes wrt options and call_id
479
480 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
481 - various fixes in rspecs for sfav1&slice tags
482 - uses 'geni_rspec_version' and not just 'rspec_version'
483 - example flavour for the max testbed
484 - embryo for an sfa client library
485 - topology.py moved into plc
486 - sql: table is named records; record_types are enforced
487 - sql: table creation cleaned up
488
489 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
490 - cleaned up all references to SFA_*_TYPE in config
491 - enable cache at the aggregate by default
492 - registry now uses the driver in a sensible way (see managers/driver.py)
493 - slice manager supports sfav1/pgv2 neighbours
494 - get_key renamed into get_key_from_incoming_ip
495 - new sfa.storage module for record/table and all db-related stuff
496 - db schema in sfa.storage.sfa.sql
497 - init.d and cron.d move one step up
498 - cleaned up rspec/ directory
499 - add deps to pyopenssl and myplc-config
500 - start support for new API (return value)
501 - plc.remoteshell removed, use plshell instead
502 - plshell uses a 'capability' auth method whenever possible
503 - various tweaks in rspec elements
504 - made dependency on sfatables softer
505
506 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
507 - sfa should now be started *before* the initial import
508 - sfa to use its own database (default sfa) - can run without myplc
509 - server calls support optional 'options'
510 - client sends options in argument when needed
511 - fix infinite getattr recursion in elements/element.py
512 - error codes in line with geni
513
514 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
515 - fixed links and attributes in rspecs
516 - minor cleanup in the API methods, and more consistent names in manager methods
517
518 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
519 - ongoing refoactoring towards more genericity
520 - passes tests again although known issues remain with attributes/tags
521
522 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
523 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
524 - improvements in the pgv2 rspecs
525 - driver separated from api
526 - code starts moving around where it belongs
527 - sfascan caches getversion across invokations
528 - vini topology extracted as a config file
529
530 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
531 - first support for protogeni rspecs is working
532 - vini no longer needs a specific manager
533 - refactoring underway towards more flexible/generic architecture
534
535 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
536 - Unicode-friendliness for user names with accents/special chars.
537 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
538 - CreaetSliver no longer fails for users that have a capital letter in their URN.
539 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
540 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
541 - Fix bugs and missing imports     
542  
543
544 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
545 - new method record.get_field for sface
546
547 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
548 - new option -c to sfa-nuke-plc.py
549 - CreateSliver fixed for admin-only slice tags
550
551 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
552 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
553 - Fixed holes in certificate verification logic.
554 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
555 - Added 'boot_state' as an attribute of the node element in SFA rspec.
556 - Non authority certificates are marked as CA:FALSE.
557
558 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
559 - fix typo in sfa-1.0-31 tag.
560 - added CreateGid() Registry interface method.
561
562 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
563 - fix typo in sfa-1.0-30 tag
564
565 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
566 - Declare namespace and schema location in the credential.
567 - Fix bug that prevetend connections from timing out.
568 - Fix slice delegation.
569 - Add statistics to slicemaanger listresources/createsliver rspec.
570 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
571   of days a user can extend their slice expiration.
572 - CA certs are only issued to objects of type authority
573    
574 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
575 - tag 1.0-28 was broken due to typo in the changelog
576 - new class sfa/util/httpsProtocol.py that supports timeouts
577
578 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
579 - Resolved issue that caused sfa hold onto idle db connections.
580 - Fix bug that caused the registry to use the wrong type of credential.
581 - Support authority+sm type.
582 - Fix rspec merging bugs.
583 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
584 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
585  planetlab hosted initscripts using the <planetlab:initscript> tag  
586 - Can now handle extraneous whitespace in the rspec without failing.   
587  
588 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
589 - ProtoGENI v2 RSpec updates.
590 - Convert expiration timestamps with timezone info in credentials to utc.
591 - Fixed redundant logging issue. 
592 - Improved SliceManager and SFI client logging.
593 - Support aggregates that don't support the optional 'call_id' argument. 
594 - Only call get_trusted_certs() at aggreage interfaces that support the call.
595 - CreateSliver() now handles MyPLC slice attributes/tags.
596 - Cache now supports persistence.
597 - Hide whitelisted nodes.
598
599 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
600 - fixed issues with sup authority signing
601 - fixed bugs in remove_slivers and SliverStatus
602
603 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
604 - fix typo that prevented aggregates from operating properly
605
606 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
607 - load trusted certs into ssl context prior to handshake
608 - client's logfile lives in ~/.sfi/sfi.log
609
610 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
611 - includes a change on passphrases that was intended in 1.0-22
612
613 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
614 - Added support for ProtoGENI RSpec v2
615  
616 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
617 - stable sfascan
618 - fix in initscript, *ENABLED tags in config now taken into account
619
620 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
621 - some commits had not been pushed in tag 19
622
623 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
624 - GetVersion should now report full URLs with path
625 - scansfa has nicer output and new syntax (entry URLs as args and not options)
626 - dos2unix'ed flash policy pill
627
628 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
629 - fix packaging again for f8
630
631 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
632 - fix packaging (apparently broken in 1.0-16)
633 - first working version of sfascan
634 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
635 - deprecated the sfa_geni_aggregate config category
636
637 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
638 - Fix build problem
639 - First version of SFA scanner
640
641 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
642 - Add support for Flash clients using flashpolicy
643 - Fix problems with tag handling in RSpec
644
645 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
646 - Modifications to the Eucalyptus Aggregate Manager
647 - Fixes for VINI RSpec
648 - Fix tag handling for PL RSpec
649 - Fix XML Schema ordering for <urn> element
650
651 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
652 - just set x509 version to 2
653
654 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
655 - added urn to the node area in rspecs
656 - conversion to urn now exports fqdn
657 - sfa-import-plc.py now creates a unique registry record for each SFA interface
658
659 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
660 - undo broken attempt for python-2.7
661
662 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
663 - SMs avoid duplicates for when call graph has dags;
664 - just based on network's name, when a duplicate occurs, one is just dropped
665 - does not try to merge/aggregate 2 networks
666 - also reviewed logging with the hope to fix the sfa startup msg:
667 - TypeError: not all arguments converted during string formatting
668
669 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
670 - verify credentials against xsd schema
671 - Fix SM to SM communication
672 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
673 - new setting session_key_path
674
675 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
676 - fix registry credential regeneration and handle expiration
677 - support for setting slice tags (min_role=user)
678 - client can display its own version: sfi.py version --local
679 - GetVersion to provide urn in addition to hrn
680 - more code uses plxrn vs previous helper functions
681 - import replaces '+' in email addresses with '_'
682
683 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
684 - fix GetVersion code_tag and add code_url
685
686 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
687 - extend GetVersion towards minimum federation introspection, and expose local tag
688
689 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
690 - fixed some legacy issues (list vs List)
691 - deprecated sfa.util.namespace for xrn and plxrn
692 - unit tests ship as the sfa-tests rpm
693
694 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
695 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
696 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
697 - hrn-urn translations tweaked
698 - fixed 'service sfa status'
699 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
700 - started to repair sfadump - although not usable yet
701 - trust objects now have dump_string method that dump() actually prints
702 - unit tests under review
703 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
704 - binaries now support -v or -vv to increase loglevel
705 - trashed obsolete sfa.util.client
706
707 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
708 - various bugfixes and cleanup, improved/harmonized logging
709
710 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
711 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
712   to avoid returning a PLCAPI exception that might confuse users.
713 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
714 - fix build errors.  
715
716 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
717 - (Architecture) Credential format changed to match ProtoGENI xml format
718 - (Architecture) All interfaces export a new set of methods that are compatible
719    with the ProtoGeni Aggregate spec. These new methods are considered a 
720    replacement  for the pervious methods exported by the interfaces. All 
721    previous methods are still exported and work as normal, but they are 
722    considered deprecated and will not be supported in future releases.  
723 - (Architecture) SFI has been updated to use the new interface methods.
724 - (Architecture) Changed keyconvet implementation from c to python.
725 - (Architecture) Slice Manager now attempts looks for a delegated credential
726   provided by the client before using its own server credential.
727 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
728   This cache now exists only in memory and is cleared when service is restarted
729   or cache lifetime is exceeded.  
730 - (Performance) SliceManager sends request to Aggregates in parallel instead 
731   of sequentially.
732 - (Bug fix) SFA tickets now support the new rspec format.
733 - (Bug fix) SFI only uses cahced credential if they aren't expired.
734 - (Bug fix) Cerdential delegation modified to work with new credential format.
735 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
736   Aggregate instead of relaying through the Slice Manager.
737 - (Enhancement) Simplified caching. Accociated a global cache instance with
738   the api handler on every new server request, making it easier to access the 
739   cache and use in more general ways.     
740
741 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
742 - SfaServer now uses a pool of threads to handle requests concurrently
743 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
744 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
745 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
746 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
747 - Component manager does not install gid files if slice already has them  
748 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
749 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
750 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
751      
752 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
753 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
754 - - sfa-config-tty now has the same features like plc-config-tty
755 - - Contains code to support both urn and hrn
756 - - Cleaned up request_hash related stuff
757 - - SM, AM and Registry code is organized under respective managers
758 - - Site and Slice synchronization across federated aggregates
759 - - Script to generate sfa_component_config
760
761 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
762 - sfa-config-tty now has the same features like plc-config-tty
763 - Contains code to support both urn and hrn
764 - Cleaned up request_hash related stuff
765 - SM, AM and Registry code is organized under respective managers
766 - Slice synchronization across federated aggregates
767 - some bugs are fixed
768
769 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
770 - checkpoint with fewer mentions of geni
771
772 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
773 - checkpointing
774 - this is believed to pass the tests; among other things:
775 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
776
777 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
778 - This tag includes:
779 - - Sfatables
780 - - Preliminary version of hash based authentication
781 - - Initial code for Component Manager
782 - - Authority structure is moved to /var/lib/sfa/
783 - - some bug-fixes
784
785 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
786 - Create_slice and get_resources methods are connected to sfatables.
787 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
788
789 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
790 - Bug fix on update and remove_peer_object methods
791 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
792
793 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
794 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
795
796 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
797 - compatibility with RefreshPeer
798 - incremental mechanism for importing PLC records into SFA tables
799 - unified single database (still inside the underlying PLC db postgresql server)
800 - includes/improves call traceability and logging features
801 - several bug fixes
802
803 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
804 - added libxslt-python dependency
805
806 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
807 - unified single SFA database in the PLC-DB
808 - upcalls from  PLCAPI to SFA methods
809 - SFA call traceability and logging features
810 - many bug fixes
811 - includes first/rough version of sfatables for policy implementation
812
813 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
814 - snapshot after the GEC5 demo
815 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
816
817 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
818 - snapshot july 15 - has gone through superficial manual testing
819 - hopefully a good basis for gec5 demo
820 - multi-dir sfi client tested as well
821
822 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
823 - rename geniwrapper.spec into sfa.spec
824
825 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
826 - clean up in xmlrpc/soap, --protocol option to chose between both
827 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
828 - hopefully more helpful context in case of crashes when importing
829 - bugfixes for using only /etc/sfa for site-dep files
830 - bugfixes in wsdl generation
831
832 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
833 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
834 - config variables in sfa_config now start with SFA_ and not GENI_
835 - config.py can be loaded even with no config present
836
837 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
838 - first step for cleanup and reorganization
839 - mass-renaming from geni to sfa (some are still needed)
840 - sfa/trust implements the security architecture
841
842 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
843 - snapshot for reproducible builds
844
845 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
846 - snapshot for the convenience of alpha users
847
848 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
849 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
850
851 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
852 - ongoing work - snapshot for 4.3-rc9
853
854 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
855 - various fixes
856
857 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
858 - bugfixes - still a work in progress
859
860 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
861 - initial package
862
863
864 %define module_current_branch 0.2