Merge branch 'upstreammaster'
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 23
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package dummy
83 Summary: the SFA layer around a Dummy Testbed 
84 Group: Applications/System
85 Requires: sfa
86
87 %package sfatables
88 Summary: sfatables policy tool for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %package xmlbuilder
93 Summary: third-party xmlbuilder tool
94 Group: Applications/System
95 Provides: python-xmlbuilder
96
97 %package tests
98 Summary: unit tests suite for SFA
99 Group: Applications/System
100 Requires: sfa-common
101
102 %description 
103 This package provides the registry, aggregate manager and slice
104 managers for SFA.  In most cases it is advisable to install additional
105 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
106
107 %description common
108 This package contains the python libraries for SFA both client and server-side.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description plc
115 This package implements the SFA interface which serves as a layer
116 between the existing PlanetLab interfaces and the SFA API.
117
118 %description flashpolicy
119 This package provides support for adobe flash client applications.  
120
121 %description federica
122 The SFA driver for FEDERICA.
123
124 %description nitos
125 The SFA driver for NITOS.
126
127 %description dummy
128 The SFA driver for a Dummy Testbed.
129
130 %description sfatables
131 sfatables is a tool for defining access and admission control policies
132 in an SFA network, in much the same way as iptables is for ip
133 networks. This is the command line interface to manage sfatables
134
135 %description xmlbuilder
136 This package contains the xmlbuilder python library, packaged for
137 convenience as it is not supported by fedora
138
139 %description tests
140 Provides some binary unit tests in /usr/share/sfa/tests
141
142 %prep
143 %setup -q
144
145 %build
146 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files
156 /etc/init.d/sfa
157 %{_bindir}/sfa-start.py*
158 %{_bindir}/sfaadmin.py*
159 %{_bindir}/sfaadmin
160 %{_bindir}/keyconvert.py*
161 %{_bindir}/sfa-config-tty
162 %{_bindir}/sfa-config
163 %config /etc/sfa/default_config.xml
164 %config (noreplace) /etc/sfa/aggregates.xml
165 %config (noreplace) /etc/sfa/registries.xml
166 /usr/share/sfa/migrations
167 /usr/share/sfa/examples
168 /var/www/html/wsdl/*.wsdl
169
170 %files common
171 %{python_sitelib}/sfa/__init__.py*
172 %{python_sitelib}/sfa/trust
173 %{python_sitelib}/sfa/storage
174 %{python_sitelib}/sfa/util
175 %{python_sitelib}/sfa/server
176 %{python_sitelib}/sfa/methods
177 %{python_sitelib}/sfa/generic
178 %{python_sitelib}/sfa/managers
179 %{python_sitelib}/sfa/importer
180 %{python_sitelib}/sfa/rspecs
181 %{python_sitelib}/sfa/client
182
183 %files client
184 %config (noreplace) /etc/sfa/sfi_config
185 %{_bindir}/sfi*.py*
186 %{_bindir}/sfi
187 %{_bindir}/get*.py*
188 %{_bindir}/setRecord.py*
189 %{_bindir}/sfascan.py*
190 %{_bindir}/sfascan
191 %{_bindir}/sfadump.py*
192
193 %files plc
194 %defattr(-,root,root)
195 %{python_sitelib}/sfa/planetlab
196 %{python_sitelib}/sfa/openstack
197 /etc/sfa/pl.rng
198 /etc/sfa/credential.xsd
199 /etc/sfa/top.xsd
200 /etc/sfa/sig.xsd
201 /etc/sfa/xml.xsd
202 /etc/sfa/protogeni-rspec-common.xsd
203 /etc/sfa/topology
204
205 %files flashpolicy
206 %{_bindir}/sfa_flashpolicy.py*
207 /etc/sfa/sfa_flashpolicy_config.xml
208
209 %files federica
210 %{python_sitelib}/sfa/federica
211
212 %files nitos
213 %{python_sitelib}/sfa/nitos
214
215 %files dummy
216 %{python_sitelib}/sfa/dummy
217
218 %files sfatables
219 /etc/sfatables/*
220 %{_bindir}/sfatables
221 %{python_sitelib}/sfatables
222
223 %files xmlbuilder
224 %{python_sitelib}/xmlbuilder
225
226 %files tests
227 %{_datadir}/sfa/tests
228
229 ### sfa installs the 'sfa' service
230 %post 
231 chkconfig --add sfa
232
233 %preun 
234 if [ "$1" = 0 ] ; then
235   /sbin/service sfa stop || :
236   /sbin/chkconfig --del sfa || :
237 fi
238
239 %postun
240 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
241
242 #### sfa-cm installs the 'sfa-cm' service
243 #%post cm
244 #chkconfig --add sfa-cm
245 #
246 #%preun cm
247 #if [ "$1" = 0 ] ; then
248 #   /sbin/service sfa-cm stop || :
249 #   /sbin/chkconfig --del sfa-cm || :
250 #fi
251 #
252 #%postun cm
253 #[ "$1" -ge "1" ] && service sfa-cm restart || :
254
255 %changelog
256 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
257 - minor fix in registry
258 - fix for sfi gid, use clientbootstrap
259 - support for debians and ubuntus (packaging and initscript)
260 - deprecated cm package altogether
261 - pl flavour, minor fix for tags
262 - various fixes for the dummy flavour
263
264 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
265 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
266 - tweaks in nitos importer
267 - improvements to sfaadmin check-gid
268
269 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
270 - PL importer: minor fixes for corner cases
271 - PL importer: also handles last_updated more accurately
272 - sfi update can be used to select a key among several in PL
273 - sfi add/update usage message fixes (no more record)
274 - new feature sfaadmin registry check_gid [-a]
275
276 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
277 - fix 2 major bugs in PL importer
278 - esp. wrt GID management against PLC key
279
280 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
281 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
282
283 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
284 - support fordelegation in sfaclientlib
285 - sfi delegate fixed
286 - other delegation-related sfi option trashed
287 - new config (based on ini format)
288 - new dummy driver and related package
289 - pl importer has more explicit error messages
290 - credential dump shows expiration
291
292 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
293 - bugfix in forwarding Resolve requests
294 - various fixes in the nitos driver wrt keys and users
295
296 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
297 - various tweaks for the nitos driver
298
299 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
300 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
301 - deeper cleanup of the data-dependencies between SFA and the testbed
302 - in particular, sfi create issues Resolve(details=False)
303 - for that purpose, Resolve exposes reg-* keys for SFA builtins
304 - which in turn allows sfi list to show PIs, slice members and keys
305 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
306 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
307
308 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
309 - configurable data-dir (/var/lib/sfa)
310 - no more dependent on myplc-config
311 - some support for hrns with _ instead of \.
312 - fix for PL importing in presence of gpg keys
313 - DeleteSliver returns True instead of 1 in case of success
314 - Various improvements on the openstack/nova side
315 - new package sfa-nitos
316
317 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
318 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
319 - sfi to remove expired credentials
320
321 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
322 - Update Openstack driver to support Essex release/
323 - Fix authority xrn bug.
324   
325
326 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
327 - review packaging - site-packages/planetlab now come with sfa-plc
328 - new package sfa-federica
329 - clientbin moved one step upwards
330
331 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
332 - fix bug in sfi update()
333
334 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
335 - fix broken sfa.util.xrn class for lowercase
336
337 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
338 - new 'void' generic_flavour for running in registry-only mode
339 - first shot at refactoring importers - probably needs more work
340 - openstack: various enhancements
341 - sfi interface to registry not based on xml files anymore
342 - sfi show sorts result on record key
343 - bugfix in sfa update on users with a pl-backed registry
344
345 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
346 - renamed sfa/plc into sfa/planetlab
347 - plxrn moved in sfa/planetlab as well
348 - bugfix for sfaadmin reg update --pi <>
349
350 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
351 - native data model now has a authority x user (PI) relationship
352 - no call to 'augment_records_with_testbed_info' for GetCredential
353 - which means, registry can now be used without an underlying testbed
354 - reviewed code about relationships b/w objects and related in pl driver
355 - reviewed PL import wrt roles and pis
356 - removed mentions to is_enabled in driver
357 - small changes in update_relation* in driver interface
358 - sfaadmin: can create authorities and attach pi users to them
359 - sfaadmin: categories can be abbreviated
360 - sfi list and sfaadmin list have a new -r/--recursive option
361 - this means that List now supports an (optional) 'options' argument
362 - sfi config can display config vars
363 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
364
365 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
366 - make sync now supports vserver or lxc.
367 - Added slice expiration and login info to SliverStatus response. 
368 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
369   the 'component_name' attribute.
370 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
371   
372 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
373 - Introduced new administrative command line script, sfaadmin.py. Removed various single
374  purpose scripts and migrated their functionality into sfaadmin.py.
375 - Refactored Registry import scripts.
376 - Removed SQLAlchemy dependency from sfi.py.
377 - Fixed bugs in sfi.py
378 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
379
380 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
381 - slice x researcher rel. in database,
382 - plimporter to maintain that, as well as user.email, and more robust
383 - ongoing draft for sfaadmin tool
384 - support for a federica driver
385 - support for a nova/euca driver
386 - no more sfa-clean-peer-records script
387
388 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
389 - registry database has user's keys and mail (known as v0 for migrate)
390 - pl importer properly maintains user's keys and mail
391 - pl driver now to handle 'role' when adding person record (exp.)
392 - first draft of federica driver with config section
393 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
394 - plus, from master as of tag merged-in-sfa-2.1-2:
395 - disk_image revisited
396 - new nova_shell nova_driver & various tweaks for openstack
397
398 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
399 - uses sqlalchemy and related migrate
400 - thorough migration and upgrade scheme
401 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
402 - trashed dbinfo stuff in auth hierarchy
403 - data model still has little more than plain records
404 - checkpoint tag, not yet intended for release
405
406 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
407 - client: added -R --raw sfi cmdline option that displays raw server response.
408 - client: request GENI RSpec by default. 
409 - server: remove database dependencies from sfa.server.sfaapi.
410 - server: increased default credential lifetime to 31 days.
411 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
412 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
413 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
414  
415 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
416 - bugfix: 'geni_api' should be in the top level struct, not the code struct
417 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
418           output returned by the Aggregate Manager.
419 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
420 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
421 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
422           there is extra whitespace in the schemaLocation field.
423 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
424           advertisement rspecs.
425 - bugfix: <login> RSpec element should contain the 'username' attribute.
426 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
427  
428 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
429 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
430   exit when it encountered a user with an invalid public key.
431 - server: imporved logging in sfa-import-plc.py
432  
433 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
434 - bugfix: Fixed appending public keys in CreateSliver
435 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
436 - client: -c --current option allows users to request the current/uncached rspec.
437 - server: Added 'geni_api_versions' field to GetVersion() output.
438 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
439    
440 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
441 - bugfix: sfi was not sending call_id with ListResources to v2 servers
442 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
443 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
444
445 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
446 - client: sfi -a / -p deprecated (use -s instead)
447 - client: sfi cleaned up
448 - client: sfi has backward support for APIv1 aggregates again
449 - server: only APIv2 is supported and should be rather strict
450 - server: settings for turning on/off caching in sm or am
451 - server: plc-dependant code has moved from aggregate to pldriver
452 - server: driver interface extended accordingly
453
454 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
455 - screwed up previous tag
456
457 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
458 - client side revisited with a bootstrap library
459 - client side has a new source layout
460 - various (nasty) bug fixes wrt options and call_id
461
462 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
463 - various fixes in rspecs for sfav1&slice tags
464 - uses 'geni_rspec_version' and not just 'rspec_version'
465 - example flavour for the max testbed
466 - embryo for an sfa client library
467 - topology.py moved into plc
468 - sql: table is named records; record_types are enforced
469 - sql: table creation cleaned up
470
471 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
472 - cleaned up all references to SFA_*_TYPE in config
473 - enable cache at the aggregate by default
474 - registry now uses the driver in a sensible way (see managers/driver.py)
475 - slice manager supports sfav1/pgv2 neighbours
476 - get_key renamed into get_key_from_incoming_ip
477 - new sfa.storage module for record/table and all db-related stuff
478 - db schema in sfa.storage.sfa.sql
479 - init.d and cron.d move one step up
480 - cleaned up rspec/ directory
481 - add deps to pyopenssl and myplc-config
482 - start support for new API (return value)
483 - plc.remoteshell removed, use plshell instead
484 - plshell uses a 'capability' auth method whenever possible
485 - various tweaks in rspec elements
486 - made dependency on sfatables softer
487
488 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
489 - sfa should now be started *before* the initial import
490 - sfa to use its own database (default sfa) - can run without myplc
491 - server calls support optional 'options'
492 - client sends options in argument when needed
493 - fix infinite getattr recursion in elements/element.py
494 - error codes in line with geni
495
496 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
497 - fixed links and attributes in rspecs
498 - minor cleanup in the API methods, and more consistent names in manager methods
499
500 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
501 - ongoing refoactoring towards more genericity
502 - passes tests again although known issues remain with attributes/tags
503
504 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
505 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
506 - improvements in the pgv2 rspecs
507 - driver separated from api
508 - code starts moving around where it belongs
509 - sfascan caches getversion across invokations
510 - vini topology extracted as a config file
511
512 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
513 - first support for protogeni rspecs is working
514 - vini no longer needs a specific manager
515 - refactoring underway towards more flexible/generic architecture
516
517 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
518 - Unicode-friendliness for user names with accents/special chars.
519 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
520 - CreaetSliver no longer fails for users that have a capital letter in their URN.
521 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
522 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
523 - Fix bugs and missing imports     
524  
525
526 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
527 - new method record.get_field for sface
528
529 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
530 - new option -c to sfa-nuke-plc.py
531 - CreateSliver fixed for admin-only slice tags
532
533 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
534 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
535 - Fixed holes in certificate verification logic.
536 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
537 - Added 'boot_state' as an attribute of the node element in SFA rspec.
538 - Non authority certificates are marked as CA:FALSE.
539
540 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
541 - fix typo in sfa-1.0-31 tag.
542 - added CreateGid() Registry interface method.
543
544 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
545 - fix typo in sfa-1.0-30 tag
546
547 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
548 - Declare namespace and schema location in the credential.
549 - Fix bug that prevetend connections from timing out.
550 - Fix slice delegation.
551 - Add statistics to slicemaanger listresources/createsliver rspec.
552 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
553   of days a user can extend their slice expiration.
554 - CA certs are only issued to objects of type authority
555    
556 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
557 - tag 1.0-28 was broken due to typo in the changelog
558 - new class sfa/util/httpsProtocol.py that supports timeouts
559
560 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
561 - Resolved issue that caused sfa hold onto idle db connections.
562 - Fix bug that caused the registry to use the wrong type of credential.
563 - Support authority+sm type.
564 - Fix rspec merging bugs.
565 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
566 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
567  planetlab hosted initscripts using the <planetlab:initscript> tag  
568 - Can now handle extraneous whitespace in the rspec without failing.   
569  
570 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
571 - ProtoGENI v2 RSpec updates.
572 - Convert expiration timestamps with timezone info in credentials to utc.
573 - Fixed redundant logging issue. 
574 - Improved SliceManager and SFI client logging.
575 - Support aggregates that don't support the optional 'call_id' argument. 
576 - Only call get_trusted_certs() at aggreage interfaces that support the call.
577 - CreateSliver() now handles MyPLC slice attributes/tags.
578 - Cache now supports persistence.
579 - Hide whitelisted nodes.
580
581 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
582 - fixed issues with sup authority signing
583 - fixed bugs in remove_slivers and SliverStatus
584
585 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
586 - fix typo that prevented aggregates from operating properly
587
588 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
589 - load trusted certs into ssl context prior to handshake
590 - client's logfile lives in ~/.sfi/sfi.log
591
592 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
593 - includes a change on passphrases that was intended in 1.0-22
594
595 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
596 - Added support for ProtoGENI RSpec v2
597  
598 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
599 - stable sfascan
600 - fix in initscript, *ENABLED tags in config now taken into account
601
602 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
603 - some commits had not been pushed in tag 19
604
605 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
606 - GetVersion should now report full URLs with path
607 - scansfa has nicer output and new syntax (entry URLs as args and not options)
608 - dos2unix'ed flash policy pill
609
610 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
611 - fix packaging again for f8
612
613 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
614 - fix packaging (apparently broken in 1.0-16)
615 - first working version of sfascan
616 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
617 - deprecated the sfa_geni_aggregate config category
618
619 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
620 - Fix build problem
621 - First version of SFA scanner
622
623 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
624 - Add support for Flash clients using flashpolicy
625 - Fix problems with tag handling in RSpec
626
627 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
628 - Modifications to the Eucalyptus Aggregate Manager
629 - Fixes for VINI RSpec
630 - Fix tag handling for PL RSpec
631 - Fix XML Schema ordering for <urn> element
632
633 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
634 - just set x509 version to 2
635
636 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
637 - added urn to the node area in rspecs
638 - conversion to urn now exports fqdn
639 - sfa-import-plc.py now creates a unique registry record for each SFA interface
640
641 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
642 - undo broken attempt for python-2.7
643
644 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
645 - SMs avoid duplicates for when call graph has dags;
646 - just based on network's name, when a duplicate occurs, one is just dropped
647 - does not try to merge/aggregate 2 networks
648 - also reviewed logging with the hope to fix the sfa startup msg:
649 - TypeError: not all arguments converted during string formatting
650
651 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
652 - verify credentials against xsd schema
653 - Fix SM to SM communication
654 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
655 - new setting session_key_path
656
657 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
658 - fix registry credential regeneration and handle expiration
659 - support for setting slice tags (min_role=user)
660 - client can display its own version: sfi.py version --local
661 - GetVersion to provide urn in addition to hrn
662 - more code uses plxrn vs previous helper functions
663 - import replaces '+' in email addresses with '_'
664
665 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
666 - fix GetVersion code_tag and add code_url
667
668 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
669 - extend GetVersion towards minimum federation introspection, and expose local tag
670
671 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
672 - fixed some legacy issues (list vs List)
673 - deprecated sfa.util.namespace for xrn and plxrn
674 - unit tests ship as the sfa-tests rpm
675
676 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
677 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
678 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
679 - hrn-urn translations tweaked
680 - fixed 'service sfa status'
681 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
682 - started to repair sfadump - although not usable yet
683 - trust objects now have dump_string method that dump() actually prints
684 - unit tests under review
685 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
686 - binaries now support -v or -vv to increase loglevel
687 - trashed obsolete sfa.util.client
688
689 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
690 - various bugfixes and cleanup, improved/harmonized logging
691
692 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
693 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
694   to avoid returning a PLCAPI exception that might confuse users.
695 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
696 - fix build errors.  
697
698 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
699 - (Architecture) Credential format changed to match ProtoGENI xml format
700 - (Architecture) All interfaces export a new set of methods that are compatible
701    with the ProtoGeni Aggregate spec. These new methods are considered a 
702    replacement  for the pervious methods exported by the interfaces. All 
703    previous methods are still exported and work as normal, but they are 
704    considered deprecated and will not be supported in future releases.  
705 - (Architecture) SFI has been updated to use the new interface methods.
706 - (Architecture) Changed keyconvet implementation from c to python.
707 - (Architecture) Slice Manager now attempts looks for a delegated credential
708   provided by the client before using its own server credential.
709 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
710   This cache now exists only in memory and is cleared when service is restarted
711   or cache lifetime is exceeded.  
712 - (Performance) SliceManager sends request to Aggregates in parallel instead 
713   of sequentially.
714 - (Bug fix) SFA tickets now support the new rspec format.
715 - (Bug fix) SFI only uses cahced credential if they aren't expired.
716 - (Bug fix) Cerdential delegation modified to work with new credential format.
717 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
718   Aggregate instead of relaying through the Slice Manager.
719 - (Enhancement) Simplified caching. Accociated a global cache instance with
720   the api handler on every new server request, making it easier to access the 
721   cache and use in more general ways.     
722
723 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
724 - SfaServer now uses a pool of threads to handle requests concurrently
725 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
726 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
727 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
728 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
729 - Component manager does not install gid files if slice already has them  
730 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
731 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
732 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
733      
734 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
735 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
736 - - sfa-config-tty now has the same features like plc-config-tty
737 - - Contains code to support both urn and hrn
738 - - Cleaned up request_hash related stuff
739 - - SM, AM and Registry code is organized under respective managers
740 - - Site and Slice synchronization across federated aggregates
741 - - Script to generate sfa_component_config
742
743 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
744 - sfa-config-tty now has the same features like plc-config-tty
745 - Contains code to support both urn and hrn
746 - Cleaned up request_hash related stuff
747 - SM, AM and Registry code is organized under respective managers
748 - Slice synchronization across federated aggregates
749 - some bugs are fixed
750
751 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
752 - checkpoint with fewer mentions of geni
753
754 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
755 - checkpointing
756 - this is believed to pass the tests; among other things:
757 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
758
759 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
760 - This tag includes:
761 - - Sfatables
762 - - Preliminary version of hash based authentication
763 - - Initial code for Component Manager
764 - - Authority structure is moved to /var/lib/sfa/
765 - - some bug-fixes
766
767 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
768 - Create_slice and get_resources methods are connected to sfatables.
769 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
770
771 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
772 - Bug fix on update and remove_peer_object methods
773 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
774
775 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
776 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
777
778 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
779 - compatibility with RefreshPeer
780 - incremental mechanism for importing PLC records into SFA tables
781 - unified single database (still inside the underlying PLC db postgresql server)
782 - includes/improves call traceability and logging features
783 - several bug fixes
784
785 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
786 - added libxslt-python dependency
787
788 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
789 - unified single SFA database in the PLC-DB
790 - upcalls from  PLCAPI to SFA methods
791 - SFA call traceability and logging features
792 - many bug fixes
793 - includes first/rough version of sfatables for policy implementation
794
795 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
796 - snapshot after the GEC5 demo
797 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
798
799 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
800 - snapshot july 15 - has gone through superficial manual testing
801 - hopefully a good basis for gec5 demo
802 - multi-dir sfi client tested as well
803
804 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
805 - rename geniwrapper.spec into sfa.spec
806
807 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
808 - clean up in xmlrpc/soap, --protocol option to chose between both
809 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
810 - hopefully more helpful context in case of crashes when importing
811 - bugfixes for using only /etc/sfa for site-dep files
812 - bugfixes in wsdl generation
813
814 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
815 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
816 - config variables in sfa_config now start with SFA_ and not GENI_
817 - config.py can be loaded even with no config present
818
819 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
820 - first step for cleanup and reorganization
821 - mass-renaming from geni to sfa (some are still needed)
822 - sfa/trust implements the security architecture
823
824 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
825 - snapshot for reproducible builds
826
827 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
828 - snapshot for the convenience of alpha users
829
830 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
831 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
832
833 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
834 - ongoing work - snapshot for 4.3-rc9
835
836 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
837 - various fixes
838
839 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
840 - bugfixes - still a work in progress
841
842 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
843 - initial package
844
845
846 %define module_current_branch 0.2