Merge branch 'master' into senslab2
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 22
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package nitos
92 Summary: the SFA layer around NITOS
93 Group: Applications/System
94 Requires: sfa
95
96 %package dummy
97 Summary: the SFA layer around a Dummy Testbed 
98 Group: Applications/System
99 Requires: sfa
100
101 %package sfatables
102 Summary: sfatables policy tool for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %package xmlbuilder
107 Summary: third-party xmlbuilder tool
108 Group: Applications/System
109 Provides: python-xmlbuilder
110
111 %package tests
112 Summary: unit tests suite for SFA
113 Group: Applications/System
114 Requires: sfa
115
116 %description
117 This package provides the python libraries for the PlanetLab implementation of SFA
118
119 %description flashpolicy
120 This package provides support for adobe flash client applications.  
121
122 %description client
123 This package provides the client side of the SFA API, in particular
124 sfi.py, together with other utilities.
125
126 %description plc
127 This package implements the SFA interface which serves as a layer
128 between the existing PlanetLab interfaces and the SFA API.
129
130 %description cm
131 This package implements the SFA interface which serves as a layer
132 between the existing PlanetLab NodeManager interfaces and the SFA API.
133
134 %description federica
135 The SFA driver for FEDERICA.
136
137 %description nitos
138 The SFA driver for NITOS.
139
140 %description dummy
141 The SFA driver for a Dummy Testbed.
142
143 %description sfatables
144 sfatables is a tool for defining access and admission control policies
145 in an SFA network, in much the same way as iptables is for ip
146 networks. This is the command line interface to manage sfatables
147
148 %description xmlbuilder
149 This package contains the xmlbuilder python library, packaged for
150 convenience as it is not supported by fedora
151
152 %description tests
153 Provides some binary unit tests in /usr/share/sfa/tests
154
155 %prep
156 %setup -q
157
158 %build
159 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %{python_sitelib}/sfa/__init__.py*
170 %{python_sitelib}/sfa/trust
171 %{python_sitelib}/sfa/storage
172 %{python_sitelib}/sfa/util
173 %{python_sitelib}/sfa/server
174 %{python_sitelib}/sfa/methods
175 %{python_sitelib}/sfa/generic
176 %{python_sitelib}/sfa/managers
177 %{python_sitelib}/sfa/importer
178 %{python_sitelib}/sfa/rspecs
179 %{python_sitelib}/sfa/client
180 /etc/init.d/sfa
181 %{_bindir}/sfa-start.py*
182 %{_bindir}/sfaadmin.py*
183 %{_bindir}/sfaadmin
184 %{_bindir}/keyconvert.py*
185 %{_bindir}/sfa-config-tty
186 %{_bindir}/sfa-config
187 %config /etc/sfa/default_config.xml
188 %config (noreplace) /etc/sfa/aggregates.xml
189 %config (noreplace) /etc/sfa/registries.xml
190 /usr/share/sfa/migrations
191 /usr/share/sfa/examples
192 /var/www/html/wsdl/*.wsdl
193
194 %files flashpolicy
195 %{_bindir}/sfa_flashpolicy.py*
196 /etc/sfa/sfa_flashpolicy_config.xml
197
198 %files client
199 %config (noreplace) /etc/sfa/sfi_config
200 %{_bindir}/sfi*.py*
201 %{_bindir}/sfi
202 %{_bindir}/get*.py*
203 %{_bindir}/setRecord.py*
204 %{_bindir}/sfascan.py*
205 %{_bindir}/sfascan
206 %{_bindir}/sfadump.py*
207
208 %files plc
209 %defattr(-,root,root)
210 %{python_sitelib}/sfa/planetlab
211 %{python_sitelib}/sfa/openstack
212 /etc/sfa/pl.rng
213 /etc/sfa/credential.xsd
214 /etc/sfa/top.xsd
215 /etc/sfa/sig.xsd
216 /etc/sfa/xml.xsd
217 /etc/sfa/protogeni-rspec-common.xsd
218 /etc/sfa/topology
219 %{_bindir}/gen-sfa-cm-config.py*
220
221 %files cm
222 /etc/init.d/sfa-cm
223 %{_bindir}/sfa_component_setup.py*
224 # cron jobs here 
225
226 %files federica
227 %{python_sitelib}/sfa/federica
228
229 %files nitos
230 %{python_sitelib}/sfa/nitos
231
232 %files dummy
233 %{python_sitelib}/sfa/dummy
234
235 %files sfatables
236 /etc/sfatables/*
237 %{_bindir}/sfatables
238 %{python_sitelib}/sfatables
239
240 %files xmlbuilder
241 %{python_sitelib}/xmlbuilder
242
243 %files tests
244 %{_datadir}/sfa/tests
245
246 ### sfa installs the 'sfa' service
247 %post 
248 chkconfig --add sfa
249
250 %preun 
251 if [ "$1" = 0 ] ; then
252   /sbin/service sfa stop || :
253   /sbin/chkconfig --del sfa || :
254 fi
255
256 %postun
257 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
258
259 ### sfa-cm installs the 'sfa-cm' service
260 %post cm
261 chkconfig --add sfa-cm
262
263 %preun cm
264 if [ "$1" = 0 ] ; then
265    /sbin/service sfa-cm stop || :
266    /sbin/chkconfig --del sfa-cm || :
267 fi
268
269 %postun cm
270 [ "$1" -ge "1" ] && service sfa-cm restart || :
271
272 %changelog
273 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
274 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
275 - tweaks in nitos importer
276 - improvements to sfaadmin check-gid
277
278 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
279 - PL importer: minor fixes for corner cases
280 - PL importer: also handles last_updated more accurately
281 - sfi update can be used to select a key among several in PL
282 - sfi add/update usage message fixes (no more record)
283 - new feature sfaadmin registry check_gid [-a]
284
285 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
286 - fix 2 major bugs in PL importer
287 - esp. wrt GID management against PLC key
288
289 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
290 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
291
292 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
293 - support fordelegation in sfaclientlib
294 - sfi delegate fixed
295 - other delegation-related sfi option trashed
296 - new config (based on ini format)
297 - new dummy driver and related package
298 - pl importer has more explicit error messages
299 - credential dump shows expiration
300
301 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
302 - bugfix in forwarding Resolve requests
303 - various fixes in the nitos driver wrt keys and users
304
305 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
306 - various tweaks for the nitos driver
307
308 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
309 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
310 - deeper cleanup of the data-dependencies between SFA and the testbed
311 - in particular, sfi create issues Resolve(details=False)
312 - for that purpose, Resolve exposes reg-* keys for SFA builtins
313 - which in turn allows sfi list to show PIs, slice members and keys
314 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
315 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
316
317 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
318 - configurable data-dir (/var/lib/sfa)
319 - no more dependent on myplc-config
320 - some support for hrns with _ instead of \.
321 - fix for PL importing in presence of gpg keys
322 - DeleteSliver returns True instead of 1 in case of success
323 - Various improvements on the openstack/nova side
324 - new package sfa-nitos
325
326 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
327 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
328 - sfi to remove expired credentials
329
330 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
331 - Update Openstack driver to support Essex release/
332 - Fix authority xrn bug.
333   
334
335 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
336 - review packaging - site-packages/planetlab now come with sfa-plc
337 - new package sfa-federica
338 - clientbin moved one step upwards
339
340 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
341 - fix bug in sfi update()
342
343 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
344 - fix broken sfa.util.xrn class for lowercase
345
346 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
347 - new 'void' generic_flavour for running in registry-only mode
348 - first shot at refactoring importers - probably needs more work
349 - openstack: various enhancements
350 - sfi interface to registry not based on xml files anymore
351 - sfi show sorts result on record key
352 - bugfix in sfa update on users with a pl-backed registry
353
354 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
355 - renamed sfa/plc into sfa/planetlab
356 - plxrn moved in sfa/planetlab as well
357 - bugfix for sfaadmin reg update --pi <>
358
359 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
360 - native data model now has a authority x user (PI) relationship
361 - no call to 'augment_records_with_testbed_info' for GetCredential
362 - which means, registry can now be used without an underlying testbed
363 - reviewed code about relationships b/w objects and related in pl driver
364 - reviewed PL import wrt roles and pis
365 - removed mentions to is_enabled in driver
366 - small changes in update_relation* in driver interface
367 - sfaadmin: can create authorities and attach pi users to them
368 - sfaadmin: categories can be abbreviated
369 - sfi list and sfaadmin list have a new -r/--recursive option
370 - this means that List now supports an (optional) 'options' argument
371 - sfi config can display config vars
372 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
373
374 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
375 - make sync now supports vserver or lxc.
376 - Added slice expiration and login info to SliverStatus response. 
377 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
378   the 'component_name' attribute.
379 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
380   
381 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
382 - Introduced new administrative command line script, sfaadmin.py. Removed various single
383  purpose scripts and migrated their functionality into sfaadmin.py.
384 - Refactored Registry import scripts.
385 - Removed SQLAlchemy dependency from sfi.py.
386 - Fixed bugs in sfi.py
387 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
388
389 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
390 - slice x researcher rel. in database,
391 - plimporter to maintain that, as well as user.email, and more robust
392 - ongoing draft for sfaadmin tool
393 - support for a federica driver
394 - support for a nova/euca driver
395 - no more sfa-clean-peer-records script
396
397 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
398 - registry database has user's keys and mail (known as v0 for migrate)
399 - pl importer properly maintains user's keys and mail
400 - pl driver now to handle 'role' when adding person record (exp.)
401 - first draft of federica driver with config section
402 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
403 - plus, from master as of tag merged-in-sfa-2.1-2:
404 - disk_image revisited
405 - new nova_shell nova_driver & various tweaks for openstack
406
407 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
408 - uses sqlalchemy and related migrate
409 - thorough migration and upgrade scheme
410 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
411 - trashed dbinfo stuff in auth hierarchy
412 - data model still has little more than plain records
413 - checkpoint tag, not yet intended for release
414
415 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
416 - client: added -R --raw sfi cmdline option that displays raw server response.
417 - client: request GENI RSpec by default. 
418 - server: remove database dependencies from sfa.server.sfaapi.
419 - server: increased default credential lifetime to 31 days.
420 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
421 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
422 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
423  
424 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
425 - bugfix: 'geni_api' should be in the top level struct, not the code struct
426 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
427           output returned by the Aggregate Manager.
428 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
429 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
430 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
431           there is extra whitespace in the schemaLocation field.
432 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
433           advertisement rspecs.
434 - bugfix: <login> RSpec element should contain the 'username' attribute.
435 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
436  
437 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
438 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
439   exit when it encountered a user with an invalid public key.
440 - server: imporved logging in sfa-import-plc.py
441  
442 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
443 - bugfix: Fixed appending public keys in CreateSliver
444 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
445 - client: -c --current option allows users to request the current/uncached rspec.
446 - server: Added 'geni_api_versions' field to GetVersion() output.
447 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
448    
449 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
450 - bugfix: sfi was not sending call_id with ListResources to v2 servers
451 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
452 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
453
454 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
455 - client: sfi -a / -p deprecated (use -s instead)
456 - client: sfi cleaned up
457 - client: sfi has backward support for APIv1 aggregates again
458 - server: only APIv2 is supported and should be rather strict
459 - server: settings for turning on/off caching in sm or am
460 - server: plc-dependant code has moved from aggregate to pldriver
461 - server: driver interface extended accordingly
462
463 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
464 - screwed up previous tag
465
466 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
467 - client side revisited with a bootstrap library
468 - client side has a new source layout
469 - various (nasty) bug fixes wrt options and call_id
470
471 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
472 - various fixes in rspecs for sfav1&slice tags
473 - uses 'geni_rspec_version' and not just 'rspec_version'
474 - example flavour for the max testbed
475 - embryo for an sfa client library
476 - topology.py moved into plc
477 - sql: table is named records; record_types are enforced
478 - sql: table creation cleaned up
479
480 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
481 - cleaned up all references to SFA_*_TYPE in config
482 - enable cache at the aggregate by default
483 - registry now uses the driver in a sensible way (see managers/driver.py)
484 - slice manager supports sfav1/pgv2 neighbours
485 - get_key renamed into get_key_from_incoming_ip
486 - new sfa.storage module for record/table and all db-related stuff
487 - db schema in sfa.storage.sfa.sql
488 - init.d and cron.d move one step up
489 - cleaned up rspec/ directory
490 - add deps to pyopenssl and myplc-config
491 - start support for new API (return value)
492 - plc.remoteshell removed, use plshell instead
493 - plshell uses a 'capability' auth method whenever possible
494 - various tweaks in rspec elements
495 - made dependency on sfatables softer
496
497 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
498 - sfa should now be started *before* the initial import
499 - sfa to use its own database (default sfa) - can run without myplc
500 - server calls support optional 'options'
501 - client sends options in argument when needed
502 - fix infinite getattr recursion in elements/element.py
503 - error codes in line with geni
504
505 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
506 - fixed links and attributes in rspecs
507 - minor cleanup in the API methods, and more consistent names in manager methods
508
509 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
510 - ongoing refoactoring towards more genericity
511 - passes tests again although known issues remain with attributes/tags
512
513 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
514 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
515 - improvements in the pgv2 rspecs
516 - driver separated from api
517 - code starts moving around where it belongs
518 - sfascan caches getversion across invokations
519 - vini topology extracted as a config file
520
521 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
522 - first support for protogeni rspecs is working
523 - vini no longer needs a specific manager
524 - refactoring underway towards more flexible/generic architecture
525
526 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
527 - Unicode-friendliness for user names with accents/special chars.
528 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
529 - CreaetSliver no longer fails for users that have a capital letter in their URN.
530 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
531 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
532 - Fix bugs and missing imports     
533  
534
535 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
536 - new method record.get_field for sface
537
538 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
539 - new option -c to sfa-nuke-plc.py
540 - CreateSliver fixed for admin-only slice tags
541
542 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
543 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
544 - Fixed holes in certificate verification logic.
545 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
546 - Added 'boot_state' as an attribute of the node element in SFA rspec.
547 - Non authority certificates are marked as CA:FALSE.
548
549 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
550 - fix typo in sfa-1.0-31 tag.
551 - added CreateGid() Registry interface method.
552
553 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
554 - fix typo in sfa-1.0-30 tag
555
556 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
557 - Declare namespace and schema location in the credential.
558 - Fix bug that prevetend connections from timing out.
559 - Fix slice delegation.
560 - Add statistics to slicemaanger listresources/createsliver rspec.
561 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
562   of days a user can extend their slice expiration.
563 - CA certs are only issued to objects of type authority
564    
565 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
566 - tag 1.0-28 was broken due to typo in the changelog
567 - new class sfa/util/httpsProtocol.py that supports timeouts
568
569 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
570 - Resolved issue that caused sfa hold onto idle db connections.
571 - Fix bug that caused the registry to use the wrong type of credential.
572 - Support authority+sm type.
573 - Fix rspec merging bugs.
574 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
575 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
576  planetlab hosted initscripts using the <planetlab:initscript> tag  
577 - Can now handle extraneous whitespace in the rspec without failing.   
578  
579 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
580 - ProtoGENI v2 RSpec updates.
581 - Convert expiration timestamps with timezone info in credentials to utc.
582 - Fixed redundant logging issue. 
583 - Improved SliceManager and SFI client logging.
584 - Support aggregates that don't support the optional 'call_id' argument. 
585 - Only call get_trusted_certs() at aggreage interfaces that support the call.
586 - CreateSliver() now handles MyPLC slice attributes/tags.
587 - Cache now supports persistence.
588 - Hide whitelisted nodes.
589
590 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
591 - fixed issues with sup authority signing
592 - fixed bugs in remove_slivers and SliverStatus
593
594 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
595 - fix typo that prevented aggregates from operating properly
596
597 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
598 - load trusted certs into ssl context prior to handshake
599 - client's logfile lives in ~/.sfi/sfi.log
600
601 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
602 - includes a change on passphrases that was intended in 1.0-22
603
604 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
605 - Added support for ProtoGENI RSpec v2
606  
607 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
608 - stable sfascan
609 - fix in initscript, *ENABLED tags in config now taken into account
610
611 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
612 - some commits had not been pushed in tag 19
613
614 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
615 - GetVersion should now report full URLs with path
616 - scansfa has nicer output and new syntax (entry URLs as args and not options)
617 - dos2unix'ed flash policy pill
618
619 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
620 - fix packaging again for f8
621
622 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
623 - fix packaging (apparently broken in 1.0-16)
624 - first working version of sfascan
625 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
626 - deprecated the sfa_geni_aggregate config category
627
628 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
629 - Fix build problem
630 - First version of SFA scanner
631
632 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
633 - Add support for Flash clients using flashpolicy
634 - Fix problems with tag handling in RSpec
635
636 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
637 - Modifications to the Eucalyptus Aggregate Manager
638 - Fixes for VINI RSpec
639 - Fix tag handling for PL RSpec
640 - Fix XML Schema ordering for <urn> element
641
642 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
643 - just set x509 version to 2
644
645 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
646 - added urn to the node area in rspecs
647 - conversion to urn now exports fqdn
648 - sfa-import-plc.py now creates a unique registry record for each SFA interface
649
650 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
651 - undo broken attempt for python-2.7
652
653 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
654 - SMs avoid duplicates for when call graph has dags;
655 - just based on network's name, when a duplicate occurs, one is just dropped
656 - does not try to merge/aggregate 2 networks
657 - also reviewed logging with the hope to fix the sfa startup msg:
658 - TypeError: not all arguments converted during string formatting
659
660 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
661 - verify credentials against xsd schema
662 - Fix SM to SM communication
663 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
664 - new setting session_key_path
665
666 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
667 - fix registry credential regeneration and handle expiration
668 - support for setting slice tags (min_role=user)
669 - client can display its own version: sfi.py version --local
670 - GetVersion to provide urn in addition to hrn
671 - more code uses plxrn vs previous helper functions
672 - import replaces '+' in email addresses with '_'
673
674 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
675 - fix GetVersion code_tag and add code_url
676
677 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
678 - extend GetVersion towards minimum federation introspection, and expose local tag
679
680 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
681 - fixed some legacy issues (list vs List)
682 - deprecated sfa.util.namespace for xrn and plxrn
683 - unit tests ship as the sfa-tests rpm
684
685 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
686 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
687 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
688 - hrn-urn translations tweaked
689 - fixed 'service sfa status'
690 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
691 - started to repair sfadump - although not usable yet
692 - trust objects now have dump_string method that dump() actually prints
693 - unit tests under review
694 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
695 - binaries now support -v or -vv to increase loglevel
696 - trashed obsolete sfa.util.client
697
698 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
699 - various bugfixes and cleanup, improved/harmonized logging
700
701 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
702 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
703   to avoid returning a PLCAPI exception that might confuse users.
704 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
705 - fix build errors.  
706
707 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
708 - (Architecture) Credential format changed to match ProtoGENI xml format
709 - (Architecture) All interfaces export a new set of methods that are compatible
710    with the ProtoGeni Aggregate spec. These new methods are considered a 
711    replacement  for the pervious methods exported by the interfaces. All 
712    previous methods are still exported and work as normal, but they are 
713    considered deprecated and will not be supported in future releases.  
714 - (Architecture) SFI has been updated to use the new interface methods.
715 - (Architecture) Changed keyconvet implementation from c to python.
716 - (Architecture) Slice Manager now attempts looks for a delegated credential
717   provided by the client before using its own server credential.
718 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
719   This cache now exists only in memory and is cleared when service is restarted
720   or cache lifetime is exceeded.  
721 - (Performance) SliceManager sends request to Aggregates in parallel instead 
722   of sequentially.
723 - (Bug fix) SFA tickets now support the new rspec format.
724 - (Bug fix) SFI only uses cahced credential if they aren't expired.
725 - (Bug fix) Cerdential delegation modified to work with new credential format.
726 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
727   Aggregate instead of relaying through the Slice Manager.
728 - (Enhancement) Simplified caching. Accociated a global cache instance with
729   the api handler on every new server request, making it easier to access the 
730   cache and use in more general ways.     
731
732 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
733 - SfaServer now uses a pool of threads to handle requests concurrently
734 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
735 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
736 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
737 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
738 - Component manager does not install gid files if slice already has them  
739 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
740 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
741 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
742      
743 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
744 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
745 - - sfa-config-tty now has the same features like plc-config-tty
746 - - Contains code to support both urn and hrn
747 - - Cleaned up request_hash related stuff
748 - - SM, AM and Registry code is organized under respective managers
749 - - Site and Slice synchronization across federated aggregates
750 - - Script to generate sfa_component_config
751
752 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
753 - sfa-config-tty now has the same features like plc-config-tty
754 - Contains code to support both urn and hrn
755 - Cleaned up request_hash related stuff
756 - SM, AM and Registry code is organized under respective managers
757 - Slice synchronization across federated aggregates
758 - some bugs are fixed
759
760 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
761 - checkpoint with fewer mentions of geni
762
763 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
764 - checkpointing
765 - this is believed to pass the tests; among other things:
766 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
767
768 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
769 - This tag includes:
770 - - Sfatables
771 - - Preliminary version of hash based authentication
772 - - Initial code for Component Manager
773 - - Authority structure is moved to /var/lib/sfa/
774 - - some bug-fixes
775
776 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
777 - Create_slice and get_resources methods are connected to sfatables.
778 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
779
780 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
781 - Bug fix on update and remove_peer_object methods
782 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
783
784 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
785 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
786
787 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
788 - compatibility with RefreshPeer
789 - incremental mechanism for importing PLC records into SFA tables
790 - unified single database (still inside the underlying PLC db postgresql server)
791 - includes/improves call traceability and logging features
792 - several bug fixes
793
794 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
795 - added libxslt-python dependency
796
797 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
798 - unified single SFA database in the PLC-DB
799 - upcalls from  PLCAPI to SFA methods
800 - SFA call traceability and logging features
801 - many bug fixes
802 - includes first/rough version of sfatables for policy implementation
803
804 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
805 - snapshot after the GEC5 demo
806 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
807
808 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
809 - snapshot july 15 - has gone through superficial manual testing
810 - hopefully a good basis for gec5 demo
811 - multi-dir sfi client tested as well
812
813 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
814 - rename geniwrapper.spec into sfa.spec
815
816 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
817 - clean up in xmlrpc/soap, --protocol option to chose between both
818 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
819 - hopefully more helpful context in case of crashes when importing
820 - bugfixes for using only /etc/sfa for site-dep files
821 - bugfixes in wsdl generation
822
823 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
824 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
825 - config variables in sfa_config now start with SFA_ and not GENI_
826 - config.py can be loaded even with no config present
827
828 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
829 - first step for cleanup and reorganization
830 - mass-renaming from geni to sfa (some are still needed)
831 - sfa/trust implements the security architecture
832
833 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
834 - snapshot for reproducible builds
835
836 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
837 - snapshot for the convenience of alpha users
838
839 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
840 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
841
842 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
843 - ongoing work - snapshot for 4.3-rc9
844
845 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
846 - various fixes
847
848 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
849 - bugfixes - still a work in progress
850
851 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
852 - initial package
853
854
855 %define module_current_branch 0.2