pagkage /etc/sfa/api_versions.xml
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: python >= 2.5
29 Requires: pyOpenSSL >= 0.7
30 Requires: m2crypto
31 Requires: xmlsec1-openssl-devel
32 Requires: libxslt-python
33 Requires: python-ZSI
34 # for uuidgen - used in db password generation
35 # on f8 this actually comes with e2fsprogs, go figure
36 Requires: util-linux-ng
37 # xmlbuilder depends on lxml
38 Requires: python-lxml
39 Requires: python-setuptools
40 Requires: python-dateutil
41 # for the registry
42 Requires: postgresql >= 8.2, postgresql-server >= 8.2
43 Requires: postgresql-python
44 Requires: python-psycopg2
45 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
46 Requires: python-sqlalchemy
47 Requires: python-migrate
48 # the eucalyptus aggregate uses this module
49 Requires: python-xmlbuilder
50  
51 # python 2.5 has uuid module added, for python 2.4 we still need it.
52 # we can't really check for if we can load uuid as a python module,
53 # it'll be installed by "devel.pkgs". we have the epel repository so
54 # python-uuid will be provided. but we can test for the python
55 # version.
56 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
57 # %if %has_py24
58 #
59 # this also didn't work very well. I'll just check for distroname - baris
60 #%if %{distroname} == "centos5"
61 #Requires: python-uuid
62 #%endif
63
64 %package flashpolicy
65 Summary: SFA support for flash clients
66 Group: Applications/System
67 Requires: sfa
68
69 %package client
70 Summary: the SFA experimenter-side CLI
71 Group: Applications/System
72 Requires: sfa
73 Requires: pyOpenSSL >= 0.7
74
75 %package plc
76 Summary: the SFA layer around MyPLC
77 Group: Applications/System
78 Requires: sfa
79
80 %package cm
81 Summary: the SFA layer around MyPLC NodeManager
82 Group: Applications/System
83 Requires: sfa
84 Requires: pyOpenSSL >= 0.6
85
86 %package federica
87 Summary: the SFA layer around Federica
88 Group: Applications/System
89 Requires: sfa
90
91 %package sfatables
92 Summary: sfatables policy tool for SFA
93 Group: Applications/System
94 Requires: sfa
95
96 %package xmlbuilder
97 Summary: third-party xmlbuilder tool
98 Group: Applications/System
99 Provides: python-xmlbuilder
100
101 %package tests
102 Summary: unit tests suite for SFA
103 Group: Applications/System
104 Requires: sfa
105
106 %description
107 This package provides the python libraries for the PlanetLab implementation of SFA
108
109 %description flashpolicy
110 This package provides support for adobe flash client applications.  
111
112 %description client
113 This package provides the client side of the SFA API, in particular
114 sfi.py, together with other utilities.
115
116 %description plc
117 This package implements the SFA interface which serves as a layer
118 between the existing PlanetLab interfaces and the SFA API.
119
120 %description cm
121 This package implements the SFA interface which serves as a layer
122 between the existing PlanetLab NodeManager interfaces and the SFA API.
123
124 %description federica
125 The SFA driver for FEDERICA.
126
127 %description sfatables
128 sfatables is a tool for defining access and admission control policies
129 in an SFA network, in much the same way as iptables is for ip
130 networks. This is the command line interface to manage sfatables
131
132 %description xmlbuilder
133 This package contains the xmlbuilder python library, packaged for
134 convenience as it is not supported by fedora
135
136 %description tests
137 Provides some binary unit tests in /usr/share/sfa/tests
138
139 %prep
140 %setup -q
141
142 %build
143 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %{python_sitelib}/sfa/__init__.py*
154 %{python_sitelib}/sfa/trust
155 %{python_sitelib}/sfa/storage
156 %{python_sitelib}/sfa/util
157 %{python_sitelib}/sfa/server
158 %{python_sitelib}/sfa/methods
159 %{python_sitelib}/sfa/generic
160 %{python_sitelib}/sfa/managers
161 %{python_sitelib}/sfa/importer
162 %{python_sitelib}/sfa/rspecs
163 %{python_sitelib}/sfa/client
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 %config (noreplace) /etc/sfa/api_versions.xml
175 /usr/share/sfa/migrations
176 /usr/share/sfa/examples
177 /var/www/html/wsdl/*.wsdl
178
179 %files flashpolicy
180 %{_bindir}/sfa_flashpolicy.py*
181 /etc/sfa/sfa_flashpolicy_config.xml
182
183 %files client
184 %config (noreplace) /etc/sfa/sfi_config
185 %{_bindir}/sfi*.py*
186 %{_bindir}/sfi
187 %{_bindir}/get*.py*
188 %{_bindir}/setRecord.py*
189 %{_bindir}/sfascan.py*
190 %{_bindir}/sfascan
191 %{_bindir}/sfadump.py*
192
193 %files plc
194 %defattr(-,root,root)
195 %{python_sitelib}/sfa/planetlab
196 %{python_sitelib}/sfa/openstack
197 /etc/sfa/pl.rng
198 /etc/sfa/credential.xsd
199 /etc/sfa/top.xsd
200 /etc/sfa/sig.xsd
201 /etc/sfa/xml.xsd
202 /etc/sfa/protogeni-rspec-common.xsd
203 /etc/sfa/topology
204 %{_bindir}/gen-sfa-cm-config.py*
205
206 %files cm
207 /etc/init.d/sfa-cm
208 %{_bindir}/sfa_component_setup.py*
209 # cron jobs here 
210
211 %files federica
212 %{python_sitelib}/sfa/federica
213
214 %files sfatables
215 /etc/sfatables/*
216 %{_bindir}/sfatables
217 %{python_sitelib}/sfatables
218
219 %files xmlbuilder
220 %{python_sitelib}/xmlbuilder
221
222 %files tests
223 %{_datadir}/sfa/tests
224
225 ### sfa installs the 'sfa' service
226 %post 
227 chkconfig --add sfa
228
229 %preun 
230 if [ "$1" = 0 ] ; then
231   /sbin/service sfa stop || :
232   /sbin/chkconfig --del sfa || :
233 fi
234
235 %postun
236 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
237
238 ### sfa-cm installs the 'sfa-cm' service
239 %post cm
240 chkconfig --add sfa-cm
241
242 %preun cm
243 if [ "$1" = 0 ] ; then
244    /sbin/service sfa-cm stop || :
245    /sbin/chkconfig --del sfa-cm || :
246 fi
247
248 %postun cm
249 [ "$1" -ge "1" ] && service sfa-cm restart || :
250
251 %changelog
252 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
253 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
254 - sfi to remove expired credentials
255
256 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
257 - Update Openstack driver to support Essex release/
258 - Fix authority xrn bug.
259   
260
261 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
262 - review packaging - site-packages/planetlab now come with sfa-plc
263 - new package sfa-federica
264 - clientbin moved one step upwards
265
266 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
267 - fix bug in sfi update()
268
269 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
270 - fix broken sfa.util.xrn class for lowercase
271
272 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
273 - new 'void' generic_flavour for running in registry-only mode
274 - first shot at refactoring importers - probably needs more work
275 - openstack: various enhancements
276 - sfi interface to registry not based on xml files anymore
277 - sfi show sorts result on record key
278 - bugfix in sfa update on users with a pl-backed registry
279
280 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
281 - renamed sfa/plc into sfa/planetlab
282 - plxrn moved in sfa/planetlab as well
283 - bugfix for sfaadmin reg update --pi <>
284
285 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
286 - native data model now has a authority x user (PI) relationship
287 - no call to 'augment_records_with_testbed_info' for GetCredential
288 - which means, registry can now be used without an underlying testbed
289 - reviewed code about relationships b/w objects and related in pl driver
290 - reviewed PL import wrt roles and pis
291 - removed mentions to is_enabled in driver
292 - small changes in update_relation* in driver interface
293 - sfaadmin: can create authorities and attach pi users to them
294 - sfaadmin: categories can be abbreviated
295 - sfi list and sfaadmin list have a new -r/--recursive option
296 - this means that List now supports an (optional) 'options' argument
297 - sfi config can display config vars
298 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
299
300 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
301 - make sync now supports vserver or lxc.
302 - Added slice expiration and login info to SliverStatus response. 
303 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
304   the 'component_name' attribute.
305 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
306   
307 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
308 - Introduced new administrative command line script, sfaadmin.py. Removed various single
309  purpose scripts and migrated their functionality into sfaadmin.py.
310 - Refactored Registry import scripts.
311 - Removed SQLAlchemy dependency from sfi.py.
312 - Fixed bugs in sfi.py
313 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
314
315 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
316 - slice x researcher rel. in database,
317 - plimporter to maintain that, as well as user.email, and more robust
318 - ongoing draft for sfaadmin tool
319 - support for a federica driver
320 - support for a nova/euca driver
321 - no more sfa-clean-peer-records script
322
323 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
324 - registry database has user's keys and mail (known as v0 for migrate)
325 - pl importer properly maintains user's keys and mail
326 - pl driver now to handle 'role' when adding person record (exp.)
327 - first draft of federica driver with config section
328 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
329 - plus, from master as of tag merged-in-sfa-2.1-2:
330 - disk_image revisited
331 - new nova_shell nova_driver & various tweaks for openstack
332
333 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
334 - uses sqlalchemy and related migrate
335 - thorough migration and upgrade scheme
336 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
337 - trashed dbinfo stuff in auth hierarchy
338 - data model still has little more than plain records
339 - checkpoint tag, not yet intended for release
340
341 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
342 - client: added -R --raw sfi cmdline option that displays raw server response.
343 - client: request GENI RSpec by default. 
344 - server: remove database dependencies from sfa.server.sfaapi.
345 - server: increased default credential lifetime to 31 days.
346 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
347 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
348 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
349  
350 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
351 - bugfix: 'geni_api' should be in the top level struct, not the code struct
352 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
353           output returned by the Aggregate Manager.
354 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
355 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
356 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
357           there is extra whitespace in the schemaLocation field.
358 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
359           advertisement rspecs.
360 - bugfix: <login> RSpec element should contain the 'username' attribute.
361 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
362  
363 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
364 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
365   exit when it encountered a user with an invalid public key.
366 - server: imporved logging in sfa-import-plc.py
367  
368 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
369 - bugfix: Fixed appending public keys in CreateSliver
370 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
371 - client: -c --current option allows users to request the current/uncached rspec.
372 - server: Added 'geni_api_versions' field to GetVersion() output.
373 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
374    
375 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
376 - bugfix: sfi was not sending call_id with ListResources to v2 servers
377 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
378 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
379
380 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
381 - client: sfi -a / -p deprecated (use -s instead)
382 - client: sfi cleaned up
383 - client: sfi has backward support for APIv1 aggregates again
384 - server: only APIv2 is supported and should be rather strict
385 - server: settings for turning on/off caching in sm or am
386 - server: plc-dependant code has moved from aggregate to pldriver
387 - server: driver interface extended accordingly
388
389 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
390 - screwed up previous tag
391
392 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
393 - client side revisited with a bootstrap library
394 - client side has a new source layout
395 - various (nasty) bug fixes wrt options and call_id
396
397 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
398 - various fixes in rspecs for sfav1&slice tags
399 - uses 'geni_rspec_version' and not just 'rspec_version'
400 - example flavour for the max testbed
401 - embryo for an sfa client library
402 - topology.py moved into plc
403 - sql: table is named records; record_types are enforced
404 - sql: table creation cleaned up
405
406 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
407 - cleaned up all references to SFA_*_TYPE in config
408 - enable cache at the aggregate by default
409 - registry now uses the driver in a sensible way (see managers/driver.py)
410 - slice manager supports sfav1/pgv2 neighbours
411 - get_key renamed into get_key_from_incoming_ip
412 - new sfa.storage module for record/table and all db-related stuff
413 - db schema in sfa.storage.sfa.sql
414 - init.d and cron.d move one step up
415 - cleaned up rspec/ directory
416 - add deps to pyopenssl and myplc-config
417 - start support for new API (return value)
418 - plc.remoteshell removed, use plshell instead
419 - plshell uses a 'capability' auth method whenever possible
420 - various tweaks in rspec elements
421 - made dependency on sfatables softer
422
423 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
424 - sfa should now be started *before* the initial import
425 - sfa to use its own database (default sfa) - can run without myplc
426 - server calls support optional 'options'
427 - client sends options in argument when needed
428 - fix infinite getattr recursion in elements/element.py
429 - error codes in line with geni
430
431 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
432 - fixed links and attributes in rspecs
433 - minor cleanup in the API methods, and more consistent names in manager methods
434
435 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
436 - ongoing refoactoring towards more genericity
437 - passes tests again although known issues remain with attributes/tags
438
439 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
440 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
441 - improvements in the pgv2 rspecs
442 - driver separated from api
443 - code starts moving around where it belongs
444 - sfascan caches getversion across invokations
445 - vini topology extracted as a config file
446
447 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
448 - first support for protogeni rspecs is working
449 - vini no longer needs a specific manager
450 - refactoring underway towards more flexible/generic architecture
451
452 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
453 - Unicode-friendliness for user names with accents/special chars.
454 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
455 - CreaetSliver no longer fails for users that have a capital letter in their URN.
456 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
457 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
458 - Fix bugs and missing imports     
459  
460
461 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
462 - new method record.get_field for sface
463
464 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
465 - new option -c to sfa-nuke-plc.py
466 - CreateSliver fixed for admin-only slice tags
467
468 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
469 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
470 - Fixed holes in certificate verification logic.
471 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
472 - Added 'boot_state' as an attribute of the node element in SFA rspec.
473 - Non authority certificates are marked as CA:FALSE.
474
475 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
476 - fix typo in sfa-1.0-31 tag.
477 - added CreateGid() Registry interface method.
478
479 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
480 - fix typo in sfa-1.0-30 tag
481
482 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
483 - Declare namespace and schema location in the credential.
484 - Fix bug that prevetend connections from timing out.
485 - Fix slice delegation.
486 - Add statistics to slicemaanger listresources/createsliver rspec.
487 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
488   of days a user can extend their slice expiration.
489 - CA certs are only issued to objects of type authority
490    
491 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
492 - tag 1.0-28 was broken due to typo in the changelog
493 - new class sfa/util/httpsProtocol.py that supports timeouts
494
495 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
496 - Resolved issue that caused sfa hold onto idle db connections.
497 - Fix bug that caused the registry to use the wrong type of credential.
498 - Support authority+sm type.
499 - Fix rspec merging bugs.
500 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
501 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
502  planetlab hosted initscripts using the <planetlab:initscript> tag  
503 - Can now handle extraneous whitespace in the rspec without failing.   
504  
505 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
506 - ProtoGENI v2 RSpec updates.
507 - Convert expiration timestamps with timezone info in credentials to utc.
508 - Fixed redundant logging issue. 
509 - Improved SliceManager and SFI client logging.
510 - Support aggregates that don't support the optional 'call_id' argument. 
511 - Only call get_trusted_certs() at aggreage interfaces that support the call.
512 - CreateSliver() now handles MyPLC slice attributes/tags.
513 - Cache now supports persistence.
514 - Hide whitelisted nodes.
515
516 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
517 - fixed issues with sup authority signing
518 - fixed bugs in remove_slivers and SliverStatus
519
520 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
521 - fix typo that prevented aggregates from operating properly
522
523 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
524 - load trusted certs into ssl context prior to handshake
525 - client's logfile lives in ~/.sfi/sfi.log
526
527 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
528 - includes a change on passphrases that was intended in 1.0-22
529
530 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
531 - Added support for ProtoGENI RSpec v2
532  
533 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
534 - stable sfascan
535 - fix in initscript, *ENABLED tags in config now taken into account
536
537 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
538 - some commits had not been pushed in tag 19
539
540 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
541 - GetVersion should now report full URLs with path
542 - scansfa has nicer output and new syntax (entry URLs as args and not options)
543 - dos2unix'ed flash policy pill
544
545 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
546 - fix packaging again for f8
547
548 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
549 - fix packaging (apparently broken in 1.0-16)
550 - first working version of sfascan
551 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
552 - deprecated the sfa_geni_aggregate config category
553
554 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
555 - Fix build problem
556 - First version of SFA scanner
557
558 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
559 - Add support for Flash clients using flashpolicy
560 - Fix problems with tag handling in RSpec
561
562 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
563 - Modifications to the Eucalyptus Aggregate Manager
564 - Fixes for VINI RSpec
565 - Fix tag handling for PL RSpec
566 - Fix XML Schema ordering for <urn> element
567
568 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
569 - just set x509 version to 2
570
571 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
572 - added urn to the node area in rspecs
573 - conversion to urn now exports fqdn
574 - sfa-import-plc.py now creates a unique registry record for each SFA interface
575
576 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
577 - undo broken attempt for python-2.7
578
579 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
580 - SMs avoid duplicates for when call graph has dags;
581 - just based on network's name, when a duplicate occurs, one is just dropped
582 - does not try to merge/aggregate 2 networks
583 - also reviewed logging with the hope to fix the sfa startup msg:
584 - TypeError: not all arguments converted during string formatting
585
586 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
587 - verify credentials against xsd schema
588 - Fix SM to SM communication
589 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
590 - new setting session_key_path
591
592 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
593 - fix registry credential regeneration and handle expiration
594 - support for setting slice tags (min_role=user)
595 - client can display its own version: sfi.py version --local
596 - GetVersion to provide urn in addition to hrn
597 - more code uses plxrn vs previous helper functions
598 - import replaces '+' in email addresses with '_'
599
600 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
601 - fix GetVersion code_tag and add code_url
602
603 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
604 - extend GetVersion towards minimum federation introspection, and expose local tag
605
606 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
607 - fixed some legacy issues (list vs List)
608 - deprecated sfa.util.namespace for xrn and plxrn
609 - unit tests ship as the sfa-tests rpm
610
611 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
612 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
613 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
614 - hrn-urn translations tweaked
615 - fixed 'service sfa status'
616 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
617 - started to repair sfadump - although not usable yet
618 - trust objects now have dump_string method that dump() actually prints
619 - unit tests under review
620 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
621 - binaries now support -v or -vv to increase loglevel
622 - trashed obsolete sfa.util.client
623
624 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
625 - various bugfixes and cleanup, improved/harmonized logging
626
627 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
628 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
629   to avoid returning a PLCAPI exception that might confuse users.
630 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
631 - fix build errors.  
632
633 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
634 - (Architecture) Credential format changed to match ProtoGENI xml format
635 - (Architecture) All interfaces export a new set of methods that are compatible
636    with the ProtoGeni Aggregate spec. These new methods are considered a 
637    replacement  for the pervious methods exported by the interfaces. All 
638    previous methods are still exported and work as normal, but they are 
639    considered deprecated and will not be supported in future releases.  
640 - (Architecture) SFI has been updated to use the new interface methods.
641 - (Architecture) Changed keyconvet implementation from c to python.
642 - (Architecture) Slice Manager now attempts looks for a delegated credential
643   provided by the client before using its own server credential.
644 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
645   This cache now exists only in memory and is cleared when service is restarted
646   or cache lifetime is exceeded.  
647 - (Performance) SliceManager sends request to Aggregates in parallel instead 
648   of sequentially.
649 - (Bug fix) SFA tickets now support the new rspec format.
650 - (Bug fix) SFI only uses cahced credential if they aren't expired.
651 - (Bug fix) Cerdential delegation modified to work with new credential format.
652 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
653   Aggregate instead of relaying through the Slice Manager.
654 - (Enhancement) Simplified caching. Accociated a global cache instance with
655   the api handler on every new server request, making it easier to access the 
656   cache and use in more general ways.     
657
658 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
659 - SfaServer now uses a pool of threads to handle requests concurrently
660 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
661 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
662 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
663 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
664 - Component manager does not install gid files if slice already has them  
665 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
666 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
667 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
668      
669 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
670 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
671 - - sfa-config-tty now has the same features like plc-config-tty
672 - - Contains code to support both urn and hrn
673 - - Cleaned up request_hash related stuff
674 - - SM, AM and Registry code is organized under respective managers
675 - - Site and Slice synchronization across federated aggregates
676 - - Script to generate sfa_component_config
677
678 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
679 - sfa-config-tty now has the same features like plc-config-tty
680 - Contains code to support both urn and hrn
681 - Cleaned up request_hash related stuff
682 - SM, AM and Registry code is organized under respective managers
683 - Slice synchronization across federated aggregates
684 - some bugs are fixed
685
686 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
687 - checkpoint with fewer mentions of geni
688
689 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
690 - checkpointing
691 - this is believed to pass the tests; among other things:
692 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
693
694 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
695 - This tag includes:
696 - - Sfatables
697 - - Preliminary version of hash based authentication
698 - - Initial code for Component Manager
699 - - Authority structure is moved to /var/lib/sfa/
700 - - some bug-fixes
701
702 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
703 - Create_slice and get_resources methods are connected to sfatables.
704 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
705
706 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
707 - Bug fix on update and remove_peer_object methods
708 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
709
710 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
711 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
712
713 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
714 - compatibility with RefreshPeer
715 - incremental mechanism for importing PLC records into SFA tables
716 - unified single database (still inside the underlying PLC db postgresql server)
717 - includes/improves call traceability and logging features
718 - several bug fixes
719
720 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
721 - added libxslt-python dependency
722
723 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
724 - unified single SFA database in the PLC-DB
725 - upcalls from  PLCAPI to SFA methods
726 - SFA call traceability and logging features
727 - many bug fixes
728 - includes first/rough version of sfatables for policy implementation
729
730 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
731 - snapshot after the GEC5 demo
732 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
733
734 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
735 - snapshot july 15 - has gone through superficial manual testing
736 - hopefully a good basis for gec5 demo
737 - multi-dir sfi client tested as well
738
739 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
740 - rename geniwrapper.spec into sfa.spec
741
742 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
743 - clean up in xmlrpc/soap, --protocol option to chose between both
744 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
745 - hopefully more helpful context in case of crashes when importing
746 - bugfixes for using only /etc/sfa for site-dep files
747 - bugfixes in wsdl generation
748
749 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
750 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
751 - config variables in sfa_config now start with SFA_ and not GENI_
752 - config.py can be loaded even with no config present
753
754 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
755 - first step for cleanup and reorganization
756 - mass-renaming from geni to sfa (some are still needed)
757 - sfa/trust implements the security architecture
758
759 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
760 - snapshot for reproducible builds
761
762 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
763 - snapshot for the convenience of alpha users
764
765 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
766 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
767
768 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
769 - ongoing work - snapshot for 4.3-rc9
770
771 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
772 - various fixes
773
774 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
775 - bugfixes - still a work in progress
776
777 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
778 - initial package
779
780
781 %define module_current_branch 0.2