Setting tag sfa-2.1-25
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 25
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: Server-side for SFA, generic implementation derived from PlanetLab 
25 Group: Applications/System
26 BuildRequires: make
27 BuildRequires: python-setuptools
28
29 # for the registry
30 Requires: postgresql >= 8.2, postgresql-server >= 8.2
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
34 Requires: python-sqlalchemy
35 Requires: python-migrate
36 # the eucalyptus aggregate uses this module
37 Requires: python-xmlbuilder
38 # for uuidgen - used in db password generation
39 # on f8 this actually comes with e2fsprogs, go figure
40 Requires: util-linux-ng
41 # and the SFA libraries of course
42 Requires: sfa-common
43  
44 %package common
45 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
46 Group: Applications/System
47 Requires: python >= 2.7
48 Requires: pyOpenSSL >= 0.7
49 Requires: m2crypto
50 Requires: python-dateutil
51 Requires: python-lxml
52 Requires: libxslt-python
53 Requires: python-ZSI
54 Requires: xmlsec1-openssl-devel
55
56 %package client
57 Summary: sfi, the SFA experimenter-side CLI
58 Group: Applications/System
59 Requires: sfa-common
60 Requires: pyOpenSSL >= 0.7
61
62 %package plc
63 Summary: the SFA layer around MyPLC
64 Group: Applications/System
65 Requires: sfa
66
67 %package flashpolicy
68 Summary: SFA support for flash clients
69 Group: Applications/System
70 Requires: sfa
71
72 %package federica
73 Summary: the SFA layer around Federica
74 Group: Applications/System
75 Requires: sfa
76
77 %package nitos
78 Summary: the SFA layer around NITOS
79 Group: Applications/System
80 Requires: sfa
81
82 %package senslab
83 Summary: the SFA layer around SensLab
84 Group: Applications/System
85 Requires: sfa
86
87 %package dummy
88 Summary: the SFA layer around a Dummy Testbed 
89 Group: Applications/System
90 Requires: sfa
91
92 %package sfatables
93 Summary: sfatables policy tool for SFA
94 Group: Applications/System
95 Requires: sfa
96
97 %package xmlbuilder
98 Summary: third-party xmlbuilder tool
99 Group: Applications/System
100 Provides: python-xmlbuilder
101
102 %package tests
103 Summary: unit tests suite for SFA
104 Group: Applications/System
105 Requires: sfa-common
106
107 %description 
108 This package provides the registry, aggregate manager and slice
109 managers for SFA.  In most cases it is advisable to install additional
110 package for a given testbed, like e.g. sfa-plc for a PlanetLab tesbed.
111
112 %description common
113 This package contains the python libraries for SFA both client and server-side.
114
115 %description client
116 This package provides the client side of the SFA API, in particular
117 sfi.py, together with other utilities.
118
119 %description plc
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description federica
127 The SFA driver for FEDERICA.
128
129 %description nitos
130 The SFA driver for NITOS.
131
132 %description senslab
133 The SFA driver for SensLab.
134
135 %description dummy
136 The SFA driver for a Dummy Testbed.
137
138 %description sfatables
139 sfatables is a tool for defining access and admission control policies
140 in an SFA network, in much the same way as iptables is for ip
141 networks. This is the command line interface to manage sfatables
142
143 %description xmlbuilder
144 This package contains the xmlbuilder python library, packaged for
145 convenience as it is not supported by fedora
146
147 %description tests
148 Provides some binary unit tests in /usr/share/sfa/tests
149
150 %prep
151 %setup -q
152
153 %build
154 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %files
164 /etc/init.d/sfa
165 %{_bindir}/sfa-start.py*
166 %{_bindir}/sfaadmin.py*
167 %{_bindir}/sfaadmin
168 %{_bindir}/keyconvert.py*
169 %{_bindir}/sfa-config-tty
170 %{_bindir}/sfa-config
171 %config /etc/sfa/default_config.xml
172 %config (noreplace) /etc/sfa/aggregates.xml
173 %config (noreplace) /etc/sfa/registries.xml
174 %config (noreplace) /etc/sfa/api_versions.xml
175 /usr/share/sfa/migrations
176 /usr/share/sfa/examples
177 /var/www/html/wsdl/*.wsdl
178
179 %files common
180 %{python_sitelib}/sfa/__init__.py*
181 %{python_sitelib}/sfa/trust
182 %{python_sitelib}/sfa/storage
183 %{python_sitelib}/sfa/util
184 %{python_sitelib}/sfa/server
185 %{python_sitelib}/sfa/methods
186 %{python_sitelib}/sfa/generic
187 %{python_sitelib}/sfa/managers
188 %{python_sitelib}/sfa/importer
189 %{python_sitelib}/sfa/rspecs
190 %{python_sitelib}/sfa/client
191
192 %files client
193 %config (noreplace) /etc/sfa/sfi_config
194 %{_bindir}/sfi*.py*
195 %{_bindir}/sfi
196 %{_bindir}/get*.py*
197 %{_bindir}/setRecord.py*
198 %{_bindir}/sfascan.py*
199 %{_bindir}/sfascan
200 %{_bindir}/sfadump.py*
201
202 %files plc
203 %defattr(-,root,root)
204 %{python_sitelib}/sfa/planetlab
205 %{python_sitelib}/sfa/openstack
206 /etc/sfa/pl.rng
207 /etc/sfa/credential.xsd
208 /etc/sfa/top.xsd
209 /etc/sfa/sig.xsd
210 /etc/sfa/xml.xsd
211 /etc/sfa/protogeni-rspec-common.xsd
212 /etc/sfa/topology
213
214 %files flashpolicy
215 %{_bindir}/sfa_flashpolicy.py*
216 /etc/sfa/sfa_flashpolicy_config.xml
217
218 %files federica
219 %{python_sitelib}/sfa/federica
220
221 %files nitos
222 %{python_sitelib}/sfa/nitos
223
224 %files senslab
225 %{python_sitelib}/sfa/senslab
226
227 %files dummy
228 %{python_sitelib}/sfa/dummy
229
230 %files sfatables
231 /etc/sfatables/*
232 %{_bindir}/sfatables
233 %{python_sitelib}/sfatables
234
235 %files xmlbuilder
236 %{python_sitelib}/xmlbuilder
237
238 %files tests
239 %{_datadir}/sfa/tests
240
241 ### sfa installs the 'sfa' service
242 %post 
243 chkconfig --add sfa
244
245 %preun 
246 if [ "$1" = 0 ] ; then
247   /sbin/service sfa stop || :
248   /sbin/chkconfig --del sfa || :
249 fi
250
251 %postun
252 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
253
254 #### sfa-cm installs the 'sfa-cm' service
255 #%post cm
256 #chkconfig --add sfa-cm
257 #
258 #%preun cm
259 #if [ "$1" = 0 ] ; then
260 #   /sbin/service sfa-cm stop || :
261 #   /sbin/chkconfig --del sfa-cm || :
262 #fi
263 #
264 #%postun cm
265 #[ "$1" -ge "1" ] && service sfa-cm restart || :
266
267 %changelog
268 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-25
269 - sfi and sfaadmin list now share the same display code for related objs
270 - support for advertising alternate api urls - for other API versions - api_versions.xml
271 - cleaned up GID class
272 - senslab: improved importer
273 - senslab: add site to SlabLocation from Location
274 - senslab: new class JsonPage
275 - senslab:  fix debian packaging
276 - federica: fix list_slices
277
278 * Tue Jan 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-24
279 - merged the senslab driver from git.f-lab.fr
280 - merged the teagle flavour
281 - debian packaging should work much better
282 - added debug messsages for when db connection fails
283
284 * Sun Jan 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-23
285 - minor fix in registry
286 - fix for sfi gid, use clientbootstrap
287 - support for debians and ubuntus (packaging and initscript)
288 - deprecated cm package altogether
289 - pl flavour, minor fix for tags
290 - various fixes for the dummy flavour
291
292 * Sun Dec 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-22
293 - suited (and required) to run with plcapi-5.1-5 b/c of changes to AddPerson
294 - tweaks in nitos importer
295 - improvements to sfaadmin check-gid
296
297 * Tue Dec 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-21
298 - PL importer: minor fixes for corner cases
299 - PL importer: also handles last_updated more accurately
300 - sfi update can be used to select a key among several in PL
301 - sfi add/update usage message fixes (no more record)
302 - new feature sfaadmin registry check_gid [-a]
303
304 * Mon Dec 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-20
305 - fix 2 major bugs in PL importer
306 - esp. wrt GID management against PLC key
307
308 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-19
309 - nicer sfi delegate, can handle multiple delegations and for authorities(pi) as well
310
311 * Wed Nov 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-18
312 - support fordelegation in sfaclientlib
313 - sfi delegate fixed
314 - other delegation-related sfi option trashed
315 - new config (based on ini format)
316 - new dummy driver and related package
317 - pl importer has more explicit error messages
318 - credential dump shows expiration
319
320 * Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-17
321 - bugfix in forwarding Resolve requests
322 - various fixes in the nitos driver wrt keys and users
323
324 * Mon Oct 01 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-16
325 - various tweaks for the nitos driver
326
327 * Wed Sep 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-15
328 - first stab at a driver for the NITOS/OMF testbed (sep. pkg)
329 - deeper cleanup of the data-dependencies between SFA and the testbed
330 - in particular, sfi create issues Resolve(details=False)
331 - for that purpose, Resolve exposes reg-* keys for SFA builtins
332 - which in turn allows sfi list to show PIs, slice members and keys
333 - NOTE: sfa-config-tty is known to be broken w/ less frequently used func's
334 - Shows stacktrace when startup fails (DB conn, wrong flavour, etc..)
335
336 * Mon Sep 17 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-14
337 - configurable data-dir (/var/lib/sfa)
338 - no more dependent on myplc-config
339 - some support for hrns with _ instead of \.
340 - fix for PL importing in presence of gpg keys
341 - DeleteSliver returns True instead of 1 in case of success
342 - Various improvements on the openstack/nova side
343 - new package sfa-nitos
344
345 * Wed Jul 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-13
346 - bugfix that prevented to call 'sfi create' - (was broken in sfa-2.1-12)
347 - sfi to remove expired credentials
348
349 * Tue Jul 10 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-12
350 - Update Openstack driver to support Essex release/
351 - Fix authority xrn bug.
352   
353
354 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-11
355 - review packaging - site-packages/planetlab now come with sfa-plc
356 - new package sfa-federica
357 - clientbin moved one step upwards
358
359 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-10
360 - fix bug in sfi update()
361
362 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
363 - fix broken sfa.util.xrn class for lowercase
364
365 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
366 - new 'void' generic_flavour for running in registry-only mode
367 - first shot at refactoring importers - probably needs more work
368 - openstack: various enhancements
369 - sfi interface to registry not based on xml files anymore
370 - sfi show sorts result on record key
371 - bugfix in sfa update on users with a pl-backed registry
372
373 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
374 - renamed sfa/plc into sfa/planetlab
375 - plxrn moved in sfa/planetlab as well
376 - bugfix for sfaadmin reg update --pi <>
377
378 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
379 - native data model now has a authority x user (PI) relationship
380 - no call to 'augment_records_with_testbed_info' for GetCredential
381 - which means, registry can now be used without an underlying testbed
382 - reviewed code about relationships b/w objects and related in pl driver
383 - reviewed PL import wrt roles and pis
384 - removed mentions to is_enabled in driver
385 - small changes in update_relation* in driver interface
386 - sfaadmin: can create authorities and attach pi users to them
387 - sfaadmin: categories can be abbreviated
388 - sfi list and sfaadmin list have a new -r/--recursive option
389 - this means that List now supports an (optional) 'options' argument
390 - sfi config can display config vars
391 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
392
393 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
394 - make sync now supports vserver or lxc.
395 - Added slice expiration and login info to SliverStatus response. 
396 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
397   the 'component_name' attribute.
398 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
399   
400 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
401 - Introduced new administrative command line script, sfaadmin.py. Removed various single
402  purpose scripts and migrated their functionality into sfaadmin.py.
403 - Refactored Registry import scripts.
404 - Removed SQLAlchemy dependency from sfi.py.
405 - Fixed bugs in sfi.py
406 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
407
408 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
409 - slice x researcher rel. in database,
410 - plimporter to maintain that, as well as user.email, and more robust
411 - ongoing draft for sfaadmin tool
412 - support for a federica driver
413 - support for a nova/euca driver
414 - no more sfa-clean-peer-records script
415
416 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
417 - registry database has user's keys and mail (known as v0 for migrate)
418 - pl importer properly maintains user's keys and mail
419 - pl driver now to handle 'role' when adding person record (exp.)
420 - first draft of federica driver with config section
421 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
422 - plus, from master as of tag merged-in-sfa-2.1-2:
423 - disk_image revisited
424 - new nova_shell nova_driver & various tweaks for openstack
425
426 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
427 - uses sqlalchemy and related migrate
428 - thorough migration and upgrade scheme
429 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
430 - trashed dbinfo stuff in auth hierarchy
431 - data model still has little more than plain records
432 - checkpoint tag, not yet intended for release
433
434 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
435 - client: added -R --raw sfi cmdline option that displays raw server response.
436 - client: request GENI RSpec by default. 
437 - server: remove database dependencies from sfa.server.sfaapi.
438 - server: increased default credential lifetime to 31 days.
439 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
440 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
441 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
442  
443 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
444 - bugfix: 'geni_api' should be in the top level struct, not the code struct
445 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
446           output returned by the Aggregate Manager.
447 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
448 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
449 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
450           there is extra whitespace in the schemaLocation field.
451 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
452           advertisement rspecs.
453 - bugfix: <login> RSpec element should contain the 'username' attribute.
454 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
455  
456 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
457 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
458   exit when it encountered a user with an invalid public key.
459 - server: imporved logging in sfa-import-plc.py
460  
461 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
462 - bugfix: Fixed appending public keys in CreateSliver
463 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
464 - client: -c --current option allows users to request the current/uncached rspec.
465 - server: Added 'geni_api_versions' field to GetVersion() output.
466 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
467    
468 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
469 - bugfix: sfi was not sending call_id with ListResources to v2 servers
470 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
471 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
472
473 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
474 - client: sfi -a / -p deprecated (use -s instead)
475 - client: sfi cleaned up
476 - client: sfi has backward support for APIv1 aggregates again
477 - server: only APIv2 is supported and should be rather strict
478 - server: settings for turning on/off caching in sm or am
479 - server: plc-dependant code has moved from aggregate to pldriver
480 - server: driver interface extended accordingly
481
482 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
483 - screwed up previous tag
484
485 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
486 - client side revisited with a bootstrap library
487 - client side has a new source layout
488 - various (nasty) bug fixes wrt options and call_id
489
490 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
491 - various fixes in rspecs for sfav1&slice tags
492 - uses 'geni_rspec_version' and not just 'rspec_version'
493 - example flavour for the max testbed
494 - embryo for an sfa client library
495 - topology.py moved into plc
496 - sql: table is named records; record_types are enforced
497 - sql: table creation cleaned up
498
499 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
500 - cleaned up all references to SFA_*_TYPE in config
501 - enable cache at the aggregate by default
502 - registry now uses the driver in a sensible way (see managers/driver.py)
503 - slice manager supports sfav1/pgv2 neighbours
504 - get_key renamed into get_key_from_incoming_ip
505 - new sfa.storage module for record/table and all db-related stuff
506 - db schema in sfa.storage.sfa.sql
507 - init.d and cron.d move one step up
508 - cleaned up rspec/ directory
509 - add deps to pyopenssl and myplc-config
510 - start support for new API (return value)
511 - plc.remoteshell removed, use plshell instead
512 - plshell uses a 'capability' auth method whenever possible
513 - various tweaks in rspec elements
514 - made dependency on sfatables softer
515
516 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
517 - sfa should now be started *before* the initial import
518 - sfa to use its own database (default sfa) - can run without myplc
519 - server calls support optional 'options'
520 - client sends options in argument when needed
521 - fix infinite getattr recursion in elements/element.py
522 - error codes in line with geni
523
524 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
525 - fixed links and attributes in rspecs
526 - minor cleanup in the API methods, and more consistent names in manager methods
527
528 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
529 - ongoing refoactoring towards more genericity
530 - passes tests again although known issues remain with attributes/tags
531
532 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
533 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
534 - improvements in the pgv2 rspecs
535 - driver separated from api
536 - code starts moving around where it belongs
537 - sfascan caches getversion across invokations
538 - vini topology extracted as a config file
539
540 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
541 - first support for protogeni rspecs is working
542 - vini no longer needs a specific manager
543 - refactoring underway towards more flexible/generic architecture
544
545 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
546 - Unicode-friendliness for user names with accents/special chars.
547 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
548 - CreaetSliver no longer fails for users that have a capital letter in their URN.
549 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
550 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
551 - Fix bugs and missing imports     
552  
553
554 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
555 - new method record.get_field for sface
556
557 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
558 - new option -c to sfa-nuke-plc.py
559 - CreateSliver fixed for admin-only slice tags
560
561 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
562 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
563 - Fixed holes in certificate verification logic.
564 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
565 - Added 'boot_state' as an attribute of the node element in SFA rspec.
566 - Non authority certificates are marked as CA:FALSE.
567
568 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
569 - fix typo in sfa-1.0-31 tag.
570 - added CreateGid() Registry interface method.
571
572 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
573 - fix typo in sfa-1.0-30 tag
574
575 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
576 - Declare namespace and schema location in the credential.
577 - Fix bug that prevetend connections from timing out.
578 - Fix slice delegation.
579 - Add statistics to slicemaanger listresources/createsliver rspec.
580 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
581   of days a user can extend their slice expiration.
582 - CA certs are only issued to objects of type authority
583    
584 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
585 - tag 1.0-28 was broken due to typo in the changelog
586 - new class sfa/util/httpsProtocol.py that supports timeouts
587
588 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
589 - Resolved issue that caused sfa hold onto idle db connections.
590 - Fix bug that caused the registry to use the wrong type of credential.
591 - Support authority+sm type.
592 - Fix rspec merging bugs.
593 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
594 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
595  planetlab hosted initscripts using the <planetlab:initscript> tag  
596 - Can now handle extraneous whitespace in the rspec without failing.   
597  
598 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
599 - ProtoGENI v2 RSpec updates.
600 - Convert expiration timestamps with timezone info in credentials to utc.
601 - Fixed redundant logging issue. 
602 - Improved SliceManager and SFI client logging.
603 - Support aggregates that don't support the optional 'call_id' argument. 
604 - Only call get_trusted_certs() at aggreage interfaces that support the call.
605 - CreateSliver() now handles MyPLC slice attributes/tags.
606 - Cache now supports persistence.
607 - Hide whitelisted nodes.
608
609 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
610 - fixed issues with sup authority signing
611 - fixed bugs in remove_slivers and SliverStatus
612
613 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
614 - fix typo that prevented aggregates from operating properly
615
616 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
617 - load trusted certs into ssl context prior to handshake
618 - client's logfile lives in ~/.sfi/sfi.log
619
620 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
621 - includes a change on passphrases that was intended in 1.0-22
622
623 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
624 - Added support for ProtoGENI RSpec v2
625  
626 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
627 - stable sfascan
628 - fix in initscript, *ENABLED tags in config now taken into account
629
630 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
631 - some commits had not been pushed in tag 19
632
633 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
634 - GetVersion should now report full URLs with path
635 - scansfa has nicer output and new syntax (entry URLs as args and not options)
636 - dos2unix'ed flash policy pill
637
638 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
639 - fix packaging again for f8
640
641 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
642 - fix packaging (apparently broken in 1.0-16)
643 - first working version of sfascan
644 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
645 - deprecated the sfa_geni_aggregate config category
646
647 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
648 - Fix build problem
649 - First version of SFA scanner
650
651 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
652 - Add support for Flash clients using flashpolicy
653 - Fix problems with tag handling in RSpec
654
655 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
656 - Modifications to the Eucalyptus Aggregate Manager
657 - Fixes for VINI RSpec
658 - Fix tag handling for PL RSpec
659 - Fix XML Schema ordering for <urn> element
660
661 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
662 - just set x509 version to 2
663
664 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
665 - added urn to the node area in rspecs
666 - conversion to urn now exports fqdn
667 - sfa-import-plc.py now creates a unique registry record for each SFA interface
668
669 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
670 - undo broken attempt for python-2.7
671
672 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
673 - SMs avoid duplicates for when call graph has dags;
674 - just based on network's name, when a duplicate occurs, one is just dropped
675 - does not try to merge/aggregate 2 networks
676 - also reviewed logging with the hope to fix the sfa startup msg:
677 - TypeError: not all arguments converted during string formatting
678
679 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
680 - verify credentials against xsd schema
681 - Fix SM to SM communication
682 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
683 - new setting session_key_path
684
685 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
686 - fix registry credential regeneration and handle expiration
687 - support for setting slice tags (min_role=user)
688 - client can display its own version: sfi.py version --local
689 - GetVersion to provide urn in addition to hrn
690 - more code uses plxrn vs previous helper functions
691 - import replaces '+' in email addresses with '_'
692
693 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
694 - fix GetVersion code_tag and add code_url
695
696 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
697 - extend GetVersion towards minimum federation introspection, and expose local tag
698
699 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
700 - fixed some legacy issues (list vs List)
701 - deprecated sfa.util.namespace for xrn and plxrn
702 - unit tests ship as the sfa-tests rpm
703
704 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
705 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
706 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
707 - hrn-urn translations tweaked
708 - fixed 'service sfa status'
709 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
710 - started to repair sfadump - although not usable yet
711 - trust objects now have dump_string method that dump() actually prints
712 - unit tests under review
713 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
714 - binaries now support -v or -vv to increase loglevel
715 - trashed obsolete sfa.util.client
716
717 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
718 - various bugfixes and cleanup, improved/harmonized logging
719
720 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
721 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
722   to avoid returning a PLCAPI exception that might confuse users.
723 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
724 - fix build errors.  
725
726 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
727 - (Architecture) Credential format changed to match ProtoGENI xml format
728 - (Architecture) All interfaces export a new set of methods that are compatible
729    with the ProtoGeni Aggregate spec. These new methods are considered a 
730    replacement  for the pervious methods exported by the interfaces. All 
731    previous methods are still exported and work as normal, but they are 
732    considered deprecated and will not be supported in future releases.  
733 - (Architecture) SFI has been updated to use the new interface methods.
734 - (Architecture) Changed keyconvet implementation from c to python.
735 - (Architecture) Slice Manager now attempts looks for a delegated credential
736   provided by the client before using its own server credential.
737 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
738   This cache now exists only in memory and is cleared when service is restarted
739   or cache lifetime is exceeded.  
740 - (Performance) SliceManager sends request to Aggregates in parallel instead 
741   of sequentially.
742 - (Bug fix) SFA tickets now support the new rspec format.
743 - (Bug fix) SFI only uses cahced credential if they aren't expired.
744 - (Bug fix) Cerdential delegation modified to work with new credential format.
745 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
746   Aggregate instead of relaying through the Slice Manager.
747 - (Enhancement) Simplified caching. Accociated a global cache instance with
748   the api handler on every new server request, making it easier to access the 
749   cache and use in more general ways.     
750
751 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
752 - SfaServer now uses a pool of threads to handle requests concurrently
753 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
754 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
755 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
756 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
757 - Component manager does not install gid files if slice already has them  
758 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
759 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
760 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
761      
762 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
763 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
764 - - sfa-config-tty now has the same features like plc-config-tty
765 - - Contains code to support both urn and hrn
766 - - Cleaned up request_hash related stuff
767 - - SM, AM and Registry code is organized under respective managers
768 - - Site and Slice synchronization across federated aggregates
769 - - Script to generate sfa_component_config
770
771 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
772 - sfa-config-tty now has the same features like plc-config-tty
773 - Contains code to support both urn and hrn
774 - Cleaned up request_hash related stuff
775 - SM, AM and Registry code is organized under respective managers
776 - Slice synchronization across federated aggregates
777 - some bugs are fixed
778
779 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
780 - checkpoint with fewer mentions of geni
781
782 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
783 - checkpointing
784 - this is believed to pass the tests; among other things:
785 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
786
787 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
788 - This tag includes:
789 - - Sfatables
790 - - Preliminary version of hash based authentication
791 - - Initial code for Component Manager
792 - - Authority structure is moved to /var/lib/sfa/
793 - - some bug-fixes
794
795 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
796 - Create_slice and get_resources methods are connected to sfatables.
797 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
798
799 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
800 - Bug fix on update and remove_peer_object methods
801 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
802
803 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
804 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
805
806 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
807 - compatibility with RefreshPeer
808 - incremental mechanism for importing PLC records into SFA tables
809 - unified single database (still inside the underlying PLC db postgresql server)
810 - includes/improves call traceability and logging features
811 - several bug fixes
812
813 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
814 - added libxslt-python dependency
815
816 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
817 - unified single SFA database in the PLC-DB
818 - upcalls from  PLCAPI to SFA methods
819 - SFA call traceability and logging features
820 - many bug fixes
821 - includes first/rough version of sfatables for policy implementation
822
823 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
824 - snapshot after the GEC5 demo
825 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
826
827 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
828 - snapshot july 15 - has gone through superficial manual testing
829 - hopefully a good basis for gec5 demo
830 - multi-dir sfi client tested as well
831
832 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
833 - rename geniwrapper.spec into sfa.spec
834
835 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
836 - clean up in xmlrpc/soap, --protocol option to chose between both
837 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
838 - hopefully more helpful context in case of crashes when importing
839 - bugfixes for using only /etc/sfa for site-dep files
840 - bugfixes in wsdl generation
841
842 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
843 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
844 - config variables in sfa_config now start with SFA_ and not GENI_
845 - config.py can be loaded even with no config present
846
847 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
848 - first step for cleanup and reorganization
849 - mass-renaming from geni to sfa (some are still needed)
850 - sfa/trust implements the security architecture
851
852 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
853 - snapshot for reproducible builds
854
855 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
856 - snapshot for the convenience of alpha users
857
858 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
859 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
860
861 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
862 - ongoing work - snapshot for 4.3-rc9
863
864 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
865 - various fixes
866
867 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
868 - bugfixes - still a work in progress
869
870 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
871 - initial package
872
873
874 %define module_current_branch 0.2