specify -t --type option when calling sfi show
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Thu Apr 05 2012 Tony Mack <tmack@cs.princeton.edu> - sface-0.9-6
64 - remove SQLAlchemy dependency
65 - add event for notifying mainscreen of server-side slice changes
66
67 * Mon Mar 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-5
68 - support for legacy sfa lib
69 - json encoding
70
71 * Tue Jan 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-4
72 - fixed crash in slicestatus screen when no slice name is defined
73 - fixed crash in mainwindow then clicking on empty list
74 - fixed failure to delete last sliver in a slice
75 - fixed inability to use config screen without pre-existing .sficonfig
76
77 * Mon Jan 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-3
78 - handle blank rspecs
79
80 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
81 - fix the way sfi.py gets located
82
83 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
84 - minor tag for sfa-2.0-7
85
86 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
87 - fix errors when adding/removing slice attributes
88 - fix references to sfa.util.record
89
90 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
91 - Added batch slice renew feature
92 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
93 - Retrieve available resources and resources bound to slices from independent ListResources calls
94 - Added ability to delete slices
95 - Added SliverStatus screen
96 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
97 - Support for new RSPEC methods in latest SFA code
98
99 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
100 - reporting of server faults to the user
101 - create slice button and dialog
102 - fix bug that caused a crash when adding tags
103 - spacebar can be used instead of double-click when adding nodes or users
104 - support for multiple config directories
105
106 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
107 - usable with a different directory than ~/.sfi
108 - either on the command line, or in the config. screen
109
110 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
111 - new user management screen to allow users to be added and deleted from slices
112 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
113 - reordered columns (new order is hostname, boot state, membership state)
114 - rewrote filtering mechanism to allow separate string search and boot state filter
115 - selection highlights the whole line instead of excluding the hostname part
116
117 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
118 - bugfix in managing subprocess outputs
119
120 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
121 - Fix bug preventing adding nodes to a slice.
122
123 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
124 - slight changes in view creation
125
126 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
127 - dynamically load screens from the screens directory
128
129 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
130 - Added button to renew slice.
131
132 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
133 - fixed the logo area on the mac
134
135 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
136 - show versions of sface and sfa in the configure window
137 - should work both on rpm-based and macos (build-dmg.sh) packages
138
139 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
140 - packaging has support for leopard as well
141 - can use vn as a skeleton for vn+1
142 - config view show SFA version
143
144 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
145 - dmg packaging has support for leopard, and other utility options
146 - cleaned up graphics
147
148 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
149 - fixed dmg packaging
150
151 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
152 - help script to create dmg packaging
153
154 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
155 - Can add and remove slice tags
156 - Numerous tweaks
157 - Simplify item model
158
159 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
160 - minor changes
161
162 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
163 - sface-0.1-3, with improvement on process output.
164
165 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
166 - initial version with rpm packaging
167
168 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
169 - initial package