Setting tag sface-0.9-7
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 7
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sface-0.9-7
64 - specify -t --type option when calling sfi show
65  
66 * Thu Apr 05 2012 Tony Mack <tmack@cs.princeton.edu> - sface-0.9-6
67 - remove SQLAlchemy dependency
68 - add event for notifying mainscreen of server-side slice changes
69
70 * Mon Mar 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-5
71 - support for legacy sfa lib
72 - json encoding
73
74 * Tue Jan 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-4
75 - fixed crash in slicestatus screen when no slice name is defined
76 - fixed crash in mainwindow then clicking on empty list
77 - fixed failure to delete last sliver in a slice
78 - fixed inability to use config screen without pre-existing .sficonfig
79
80 * Mon Jan 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-3
81 - handle blank rspecs
82
83 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
84 - fix the way sfi.py gets located
85
86 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
87 - minor tag for sfa-2.0-7
88
89 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
90 - fix errors when adding/removing slice attributes
91 - fix references to sfa.util.record
92
93 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
94 - Added batch slice renew feature
95 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
96 - Retrieve available resources and resources bound to slices from independent ListResources calls
97 - Added ability to delete slices
98 - Added SliverStatus screen
99 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
100 - Support for new RSPEC methods in latest SFA code
101
102 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
103 - reporting of server faults to the user
104 - create slice button and dialog
105 - fix bug that caused a crash when adding tags
106 - spacebar can be used instead of double-click when adding nodes or users
107 - support for multiple config directories
108
109 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
110 - usable with a different directory than ~/.sfi
111 - either on the command line, or in the config. screen
112
113 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
114 - new user management screen to allow users to be added and deleted from slices
115 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
116 - reordered columns (new order is hostname, boot state, membership state)
117 - rewrote filtering mechanism to allow separate string search and boot state filter
118 - selection highlights the whole line instead of excluding the hostname part
119
120 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
121 - bugfix in managing subprocess outputs
122
123 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
124 - Fix bug preventing adding nodes to a slice.
125
126 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
127 - slight changes in view creation
128
129 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
130 - dynamically load screens from the screens directory
131
132 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
133 - Added button to renew slice.
134
135 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
136 - fixed the logo area on the mac
137
138 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
139 - show versions of sface and sfa in the configure window
140 - should work both on rpm-based and macos (build-dmg.sh) packages
141
142 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
143 - packaging has support for leopard as well
144 - can use vn as a skeleton for vn+1
145 - config view show SFA version
146
147 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
148 - dmg packaging has support for leopard, and other utility options
149 - cleaned up graphics
150
151 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
152 - fixed dmg packaging
153
154 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
155 - help script to create dmg packaging
156
157 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
158 - Can add and remove slice tags
159 - Numerous tweaks
160 - Simplify item model
161
162 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
163 - minor changes
164
165 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
166 - sface-0.1-3, with improvement on process output.
167
168 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
169 - initial version with rpm packaging
170
171 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
172 - initial package