370b131194d98ec8fae2d0e06a42e7fd4cd55d6a
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 1
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
64 - minor tag for sfa-2.0-7
65
66 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
67 - fix errors when adding/removing slice attributes
68 - fix references to sfa.util.record
69
70 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
71 - Added batch slice renew feature
72 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
73 - Retrieve available resources and resources bound to slices from independent ListResources calls
74 - Added ability to delete slices
75 - Added SliverStatus screen
76 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
77 - Support for new RSPEC methods in latest SFA code
78
79 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
80 - reporting of server faults to the user
81 - create slice button and dialog
82 - fix bug that caused a crash when adding tags
83 - spacebar can be used instead of double-click when adding nodes or users
84 - support for multiple config directories
85
86 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
87 - usable with a different directory than ~/.sfi
88 - either on the command line, or in the config. screen
89
90 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
91 - new user management screen to allow users to be added and deleted from slices
92 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
93 - reordered columns (new order is hostname, boot state, membership state)
94 - rewrote filtering mechanism to allow separate string search and boot state filter
95 - selection highlights the whole line instead of excluding the hostname part
96
97 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
98 - bugfix in managing subprocess outputs
99
100 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
101 - Fix bug preventing adding nodes to a slice.
102
103 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
104 - slight changes in view creation
105
106 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
107 - dynamically load screens from the screens directory
108
109 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
110 - Added button to renew slice.
111
112 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
113 - fixed the logo area on the mac
114
115 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
116 - show versions of sface and sfa in the configure window
117 - should work both on rpm-based and macos (build-dmg.sh) packages
118
119 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
120 - packaging has support for leopard as well
121 - can use vn as a skeleton for vn+1
122 - config view show SFA version
123
124 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
125 - dmg packaging has support for leopard, and other utility options
126 - cleaned up graphics
127
128 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
129 - fixed dmg packaging
130
131 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
132 - help script to create dmg packaging
133
134 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
135 - Can add and remove slice tags
136 - Numerous tweaks
137 - Simplify item model
138
139 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
140 - minor changes
141
142 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
143 - sface-0.1-3, with improvement on process output.
144
145 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
146 - initial version with rpm packaging
147
148 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
149 - initial package