call deleteslivers when last sliver deleted
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 3
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Mon Jan 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-3
64 - handle blank rspecs
65
66 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
67 - fix the way sfi.py gets located
68
69 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
70 - minor tag for sfa-2.0-7
71
72 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
73 - fix errors when adding/removing slice attributes
74 - fix references to sfa.util.record
75
76 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
77 - Added batch slice renew feature
78 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
79 - Retrieve available resources and resources bound to slices from independent ListResources calls
80 - Added ability to delete slices
81 - Added SliverStatus screen
82 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
83 - Support for new RSPEC methods in latest SFA code
84
85 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
86 - reporting of server faults to the user
87 - create slice button and dialog
88 - fix bug that caused a crash when adding tags
89 - spacebar can be used instead of double-click when adding nodes or users
90 - support for multiple config directories
91
92 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
93 - usable with a different directory than ~/.sfi
94 - either on the command line, or in the config. screen
95
96 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
97 - new user management screen to allow users to be added and deleted from slices
98 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
99 - reordered columns (new order is hostname, boot state, membership state)
100 - rewrote filtering mechanism to allow separate string search and boot state filter
101 - selection highlights the whole line instead of excluding the hostname part
102
103 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
104 - bugfix in managing subprocess outputs
105
106 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
107 - Fix bug preventing adding nodes to a slice.
108
109 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
110 - slight changes in view creation
111
112 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
113 - dynamically load screens from the screens directory
114
115 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
116 - Added button to renew slice.
117
118 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
119 - fixed the logo area on the mac
120
121 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
122 - show versions of sface and sfa in the configure window
123 - should work both on rpm-based and macos (build-dmg.sh) packages
124
125 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
126 - packaging has support for leopard as well
127 - can use vn as a skeleton for vn+1
128 - config view show SFA version
129
130 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
131 - dmg packaging has support for leopard, and other utility options
132 - cleaned up graphics
133
134 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
135 - fixed dmg packaging
136
137 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
138 - help script to create dmg packaging
139
140 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
141 - Can add and remove slice tags
142 - Numerous tweaks
143 - Simplify item model
144
145 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
146 - minor changes
147
148 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
149 - sface-0.1-3, with improvement on process output.
150
151 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
152 - initial version with rpm packaging
153
154 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
155 - initial package