Merge branch 'master' of ssh://bakers@git.planet-lab.org/git/sface
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.1
10 %define taglevel 20
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
64 - Added batch slice renew feature
65 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
66 - Retrieve available resources and resources bound to slices from independent ListResources calls
67 - Added ability to delete slices
68 - Added SliverStatus screen
69 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
70 - Support for new RSPEC methods in latest SFA code
71
72 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
73 - reporting of server faults to the user
74 - create slice button and dialog
75 - fix bug that caused a crash when adding tags
76 - spacebar can be used instead of double-click when adding nodes or users
77 - support for multiple config directories
78
79 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
80 - usable with a different directory than ~/.sfi
81 - either on the command line, or in the config. screen
82
83 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
84 - new user management screen to allow users to be added and deleted from slices
85 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
86 - reordered columns (new order is hostname, boot state, membership state)
87 - rewrote filtering mechanism to allow separate string search and boot state filter
88 - selection highlights the whole line instead of excluding the hostname part
89
90 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
91 - bugfix in managing subprocess outputs
92
93 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
94 - Fix bug preventing adding nodes to a slice.
95
96 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
97 - slight changes in view creation
98
99 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
100 - dynamically load screens from the screens directory
101
102 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
103 - Added button to renew slice.
104
105 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
106 - fixed the logo area on the mac
107
108 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
109 - show versions of sface and sfa in the configure window
110 - should work both on rpm-based and macos (build-dmg.sh) packages
111
112 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
113 - packaging has support for leopard as well
114 - can use vn as a skeleton for vn+1
115 - config view show SFA version
116
117 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
118 - dmg packaging has support for leopard, and other utility options
119 - cleaned up graphics
120
121 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
122 - fixed dmg packaging
123
124 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
125 - help script to create dmg packaging
126
127 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
128 - Can add and remove slice tags
129 - Numerous tweaks
130 - Simplify item model
131
132 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
133 - minor changes
134
135 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
136 - sface-0.1-3, with improvement on process output.
137
138 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
139 - initial version with rpm packaging
140
141 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
142 - initial package