fix the message for uploading results to the new location with sface-macos
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 8
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Thu Jun 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-8
64 - no change, but macos packaging was broken (could not spot sfi)
65
66 * Wed Jun 6 2012 Tony Mack <tmack@cs.princeton.edu> - sface-0.9-7
67 - specify -t --type option when calling sfi show
68  
69 * Thu Apr 05 2012 Tony Mack <tmack@cs.princeton.edu> - sface-0.9-6
70 - remove SQLAlchemy dependency
71 - add event for notifying mainscreen of server-side slice changes
72
73 * Mon Mar 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-5
74 - support for legacy sfa lib
75 - json encoding
76
77 * Tue Jan 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-4
78 - fixed crash in slicestatus screen when no slice name is defined
79 - fixed crash in mainwindow then clicking on empty list
80 - fixed failure to delete last sliver in a slice
81 - fixed inability to use config screen without pre-existing .sficonfig
82
83 * Mon Jan 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-3
84 - handle blank rspecs
85
86 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
87 - fix the way sfi.py gets located
88
89 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
90 - minor tag for sfa-2.0-7
91
92 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
93 - fix errors when adding/removing slice attributes
94 - fix references to sfa.util.record
95
96 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
97 - Added batch slice renew feature
98 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
99 - Retrieve available resources and resources bound to slices from independent ListResources calls
100 - Added ability to delete slices
101 - Added SliverStatus screen
102 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
103 - Support for new RSPEC methods in latest SFA code
104
105 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
106 - reporting of server faults to the user
107 - create slice button and dialog
108 - fix bug that caused a crash when adding tags
109 - spacebar can be used instead of double-click when adding nodes or users
110 - support for multiple config directories
111
112 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
113 - usable with a different directory than ~/.sfi
114 - either on the command line, or in the config. screen
115
116 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
117 - new user management screen to allow users to be added and deleted from slices
118 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
119 - reordered columns (new order is hostname, boot state, membership state)
120 - rewrote filtering mechanism to allow separate string search and boot state filter
121 - selection highlights the whole line instead of excluding the hostname part
122
123 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
124 - bugfix in managing subprocess outputs
125
126 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
127 - Fix bug preventing adding nodes to a slice.
128
129 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
130 - slight changes in view creation
131
132 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
133 - dynamically load screens from the screens directory
134
135 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
136 - Added button to renew slice.
137
138 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
139 - fixed the logo area on the mac
140
141 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
142 - show versions of sface and sfa in the configure window
143 - should work both on rpm-based and macos (build-dmg.sh) packages
144
145 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
146 - packaging has support for leopard as well
147 - can use vn as a skeleton for vn+1
148 - config view show SFA version
149
150 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
151 - dmg packaging has support for leopard, and other utility options
152 - cleaned up graphics
153
154 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
155 - fixed dmg packaging
156
157 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
158 - help script to create dmg packaging
159
160 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
161 - Can add and remove slice tags
162 - Numerous tweaks
163 - Simplify item model
164
165 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
166 - minor changes
167
168 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
169 - sface-0.1-3, with improvement on process output.
170
171 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
172 - initial version with rpm packaging
173
174 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
175 - initial package