no more unversioned obsolete
[sliceimage.git] / sliceimage.spec
index 20e8d7d..89abe0d 100644 (file)
@@ -1,7 +1,7 @@
 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
 
 # historically there was one dummy 'sliceimage' package, and 
-# then 2 subpackages with %{slicefamily} and system-%{slicefamily}
+# then 2 subpackages with {slicefamily} and system-{slicefamily}
 # however the python spec2make that we need to use on f>=15 is dumb
 # it cannot detect it's an empty/dummy package, and thus includes it
 # in e.g. noderepo, which fails
@@ -9,10 +9,9 @@
 
 %define name sliceimage
 %define version 5.1
-%define taglevel 8
+%define taglevel 12
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 
 %define __os_install_post %{nil}
 %define debug_package %{nil}
 
+# this is needed as of f27 to prevent rpmbuild from inserting a huge
+# /usr/lib/.build-id area, that not only is not helping:
+# it comes in the way when creating the node image
+%global _build_id_links none
+
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
@@ -38,7 +42,7 @@ License: GPL
 Group: Applications/System
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 # in 5.0, this package was named vserver-<>
-Obsoletes: vserver-%{slicefamily}
+# Obsoletes: vserver-{slicefamily}
 # this would not be right
 #BuildArch: noarch
 AutoReqProv: no
@@ -106,13 +110,26 @@ fi
 # remove explicit reference to vserver, find out all relevant scripts
 initScripts=`find /etc/init.d/ -name '*sliceimage*'`
 if [ "$initScripts" != "" ] ; then
-   for initscript in $initScripts ; do $initscript start ; done
+   for initscript in $initScripts ; do $initscript force ; done
 fi
 
 
 #%define vcached_pid /var/run/vcached.pid
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - sliceimage-5.1-12
+- fix for optimizing build on fedora27
+
+* Tue Jan 19 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliceimage-5.1-11
+- make cronjob hourly instead of daily
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliceimage-5.1-10
+- fixed taglevel in specfile
+
+* Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - sliceimage-5.1-9
+- Post-install fix: exit instead of return
+- Post-install fix: only call init script when there are init scripts
+
 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sliceimage-5.1-8
 - use systemd unit files to initialize lxc-sliceimage instead of a sysv script