rename bbn into bbn_80211 and normalize specfiles for module-tools
[spectools.git] / spectools.spec
1 # SPEC file for spectools
2 #
3 #
4 # Source: http://www.kismetwireless.net/code/spectools-2009-06-R1.tar.gz
5 # Version 2009-06-R1 is not compatible with RPM, so rename the tar
6 #  with version 2009_06_R1
7 #
8 %define name spectools
9 %define version 2009_06_R1 
10 %define release 1
11 %define actual_name %{name}-%{version}
12
13 # for module-tools
14 %define module_taglevel_varname release
15
16 Name: %{name}
17 Summary: Spectools utilities for Wi-Spy
18 Version: %{version}
19 Release: %{release}
20 License: GPL
21 URL: http://www.kismetwireless.net/spectools/
22 Group: Kismet
23 Source: %{actual_name}.tar.gz
24 BuildRoot: %{_tmppath}/%{actual_name}
25
26
27 BuildRequires:  libusb-devel gtk2-devel ncurses-devel gcc make
28
29 Requires:  libusb gtk2 ncurses
30
31 %description
32 Spectrum-Tools is a set of utilities for using the 
33 Wi-Spy USB spectrum analyzer hardware from Metageek LLC.
34
35 %prep
36 %setup -q -n %{actual_name}
37
38
39 %build
40 ./configure --prefix=/usr
41 make
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 mkdir $RPM_BUILD_ROOT
46 make DESTDIR=$RPM_BUILD_ROOT install
47
48
49 %post
50
51 %postun
52
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57
58 %files -n %{name}
59 %defattr(-,root,root,0755)
60 %{_bindir}/spectool_curses
61 %{_bindir}/spectool_gtk
62 %{_bindir}/spectool_net
63 %{_bindir}/spectool_raw
64 %doc README GPL 99-wispy.rules
65
66
67
68
69
70 %changelog -n spectools
71 * Fri Oct 2 2009 Thierry Turletti <turletti@sophia.inria.fr> - 1.0
72 - first version
73
74
75
76