Setting tag util-vserver-pl-0.4-9
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers` 
82 do 
83         echo "persistent,lback_allow" > $i/nflags 
84         /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
85         
86         mkdir -p $i/sysctl/0 
87         echo net.ipv4.ip_forward > $i/sysctl/0/setting
88         echo 1 > $i/sysctl/0/value
89         
90         echo -e "persistent\n~info_init" > $i/cflags
91         /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
92 done
93 popd
94
95 %postun
96 # 0 = erase, 1 = upgrade
97 if [ "$1" = 0 ] ; then
98         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
99 fi
100
101
102 %clean
103 rm -fr %{buildroot}
104
105
106 %files -f %name-python.list
107 %defattr(-,root,root,-)
108 %{_sbindir}/bwlimit
109 %{_sbindir}/disklimit
110 %{_sbindir}/vuseradd
111 %{_sbindir}/vuserdel
112 %{python_sitearch}/vserverimpl.so
113 %{_sbindir}/vip6-autod
114 %{_sysconfdir}/init.d/vip6-autod
115
116 %attr(4755,root,root) %{_sbindir}/vsh
117 /bin/vsh
118 %{_mandir}/man8/vsh.8*
119
120 %changelog
121 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
122 - change flags without restarting the vservers
123
124 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
125 - Migrate old style vservers to new style
126
127 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
128 - chroot_call fix
129
130 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
131 - fix initscript issues
132
133 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
134
135 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
136 - merged trellis branch to trunk
137
138 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
139 - Need to print the exception string as part of the self.log, or else we
140 - get a wrong number of argument error.
141
142 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
143 - This is outputted for some reason.
144
145 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
146 - Don't set bwlimits if they're disabled.
147 - Don't cleanup /var of running slivers.
148
149 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
150 - - openfd -> nofile
151
152 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
153 - call bwlimit init in postinstall.
154
155 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
156 - move the HTB tree one level down for DRL
157
158 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
159 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
160
161 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
162 - Log the error as well.
163
164 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
165 - Set ulimits for NM too.
166
167 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
168 - bwlimit.set() now accepts the device and don't assume that it's eth0
169
170 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
171 - Fix runlevel clean up after reboot.
172 - Fix runlevel setup to reflect proper runlevel.
173
174 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
175 - supports disabling htbs.
176
177 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
178 - added in support for rlimit MEM_LOCK
179 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
180 - reduced compilation warnings
181
182 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
183 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
184 - as centos does not have any of these, do build vip6-autod on fedora only
185
186 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
187 - Remove current bw limit checks before issuing tc.
188
189 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
190 - libnl 1.1 fixups.
191
192 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
193 - reads /etc/vservers/<name>/personality and behaves accordingly
194 - nicer formatting for byte rates
195
196 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
197 - FUSE support.
198
199 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
200 - Check running values before issuing set or on.  If same, disregard to save on forks.
201
202 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
203 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
204
205 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
206 - Init exempt flows into "mangle" table.
207
208 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
209 - Optimized the case where it's already running.
210
211 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
212 - Ignore ESRCH for setname.
213 - Always create the home directory, regardless of configuration settings.
214
215 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
216
217
218 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
219 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
220 - Adding a tag to include in the 4.2rc2
221
222
223 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
224
225 - * Can write vcVHI_CONTEXT
226 - * CAP_NET_BIND_SERVICE is special, in all cases. 
227 - * Check if already mounted before mounting fs in vserver
228 - * Optimized 0.0.0.0 case
229 - * Removed vcached.  DEPRECATED
230
231
232 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
233 - Initial release
234
235 %define module_current_branch 0.3