Setting tag util-vserver-pl-0.4-20
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 20
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers` 
82 do 
83         # set nflags
84         echo "persistent,lback_allow" > $i/nflags 
85         /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
86
87         # set cflags
88         echo -e "persistent\n~info_init" > $i/cflags
89         /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
90
91         # remove 16mb tmp restrictions
92         sed -i -e '/tmpfs\tsize=16m/d' $i/fstab
93
94         # enable mount namespaces
95         rm $i/nonamespace
96         
97         # enable IP forwarding
98         mkdir -p $i/sysctl/0 
99         echo net.ipv4.ip_forward > $i/sysctl/0/setting
100         echo 1 > $i/sysctl/0/value
101
102         # create missing interface files/directories
103         mkdir -p $i/interfaces/0 
104         hostname -i > $i/interfaces/0/ip
105         touch $i/interfaces/0/nodev 
106
107         mkdir -p $i/interfaces/1
108         echo -e "127.0.0.1" > $i/interfaces/1/ip
109         touch $i/interfaces/1/nodev
110 done
111 popd
112
113 %postun
114 # 0 = erase, 1 = upgrade
115 if [ "$1" = 0 ] ; then
116         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
117 fi
118
119
120 %clean
121 rm -fr %{buildroot}
122
123
124 %files -f %name-python.list
125 %defattr(-,root,root,-)
126 %{_sbindir}/bwlimit
127 %{_sbindir}/disklimit
128 %{_sbindir}/vuseradd
129 %{_sbindir}/vuserdel
130 %{python_sitearch}/vserverimpl.so
131 %{_sbindir}/vip6-autod
132 %{_sysconfdir}/init.d/vip6-autod
133
134 %attr(4755,root,root) %{_sbindir}/vsh
135 /bin/vsh
136 %{_mandir}/man8/vsh.8*
137
138 %changelog
139 * Tue Oct 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-20
140 - Fix the segfault caused by existing TUN device
141
142 * Fri Aug 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-19
143 - Fix syntax error
144
145 * Mon Aug 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-18
146 - migrate old style interface files to new style
147
148 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-17
149 - Some dead code removed from repository
150
151 * Mon Jul 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-16
152 - * use system-wide umask
153 - * enable set_ipaddresses_config function
154 - * set more default values
155
156 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-15
157 - new constant VC_LIM_INFINITY
158
159 * Tue Jul 06 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-14
160 - fix setting cpu_share for slices
161
162 * Thu Jun 24 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-13
163 - start to use mount namespaces
164
165 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-12
166 - initscripts are ignored - handled by nodemanager and triggered by rc
167
168 * Thu Jun 17 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-11
169 - sliver name as the last argument to initscript
170
171 * Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-10
172 - remove tmpfs mounted /tmp
173
174 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
175 - change flags without restarting the vservers
176
177 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
178 - Migrate old style vservers to new style
179
180 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
181 - chroot_call fix
182
183 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
184 - fix initscript issues
185
186 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
187
188 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
189 - merged trellis branch to trunk
190
191 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
192 - Need to print the exception string as part of the self.log, or else we
193 - get a wrong number of argument error.
194
195 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
196 - This is outputted for some reason.
197
198 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
199 - Don't set bwlimits if they're disabled.
200 - Don't cleanup /var of running slivers.
201
202 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
203 - - openfd -> nofile
204
205 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
206 - call bwlimit init in postinstall.
207
208 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
209 - move the HTB tree one level down for DRL
210
211 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
212 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
213
214 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
215 - Log the error as well.
216
217 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
218 - Set ulimits for NM too.
219
220 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
221 - bwlimit.set() now accepts the device and don't assume that it's eth0
222
223 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
224 - Fix runlevel clean up after reboot.
225 - Fix runlevel setup to reflect proper runlevel.
226
227 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
228 - supports disabling htbs.
229
230 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
231 - added in support for rlimit MEM_LOCK
232 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
233 - reduced compilation warnings
234
235 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
236 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
237 - as centos does not have any of these, do build vip6-autod on fedora only
238
239 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
240 - Remove current bw limit checks before issuing tc.
241
242 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
243 - libnl 1.1 fixups.
244
245 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
246 - reads /etc/vservers/<name>/personality and behaves accordingly
247 - nicer formatting for byte rates
248
249 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
250 - FUSE support.
251
252 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
253 - Check running values before issuing set or on.  If same, disregard to save on forks.
254
255 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
256 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
257
258 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
259 - Init exempt flows into "mangle" table.
260
261 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
262 - Optimized the case where it's already running.
263
264 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
265 - Ignore ESRCH for setname.
266 - Always create the home directory, regardless of configuration settings.
267
268 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
269
270
271 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
272 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
273 - Adding a tag to include in the 4.2rc2
274
275
276 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
277
278 - * Can write vcVHI_CONTEXT
279 - * CAP_NET_BIND_SERVICE is special, in all cases. 
280 - * Check if already mounted before mounting fs in vserver
281 - * Optimized 0.0.0.0 case
282 - * Removed vcached.  DEPRECATED
283
284
285 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
286 - Initial release
287
288 %define module_current_branch 0.3