Setting tag util-vserver-pl-0.3-17
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.3
8 %define taglevel 17
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77
78 %postun
79 # 0 = erase, 1 = upgrade
80 if [ "$1" = 0 ] ; then
81         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
82 fi
83
84
85 %clean
86 rm -fr %{buildroot}
87
88
89 %files -f %name-python.list
90 %defattr(-,root,root,-)
91 %{_sbindir}/bwlimit
92 %{_sbindir}/disklimit
93 %{_sbindir}/vuseradd
94 %{_sbindir}/vuserdel
95 %{python_sitearch}/vserverimpl.so
96 %{_sbindir}/vip6-autod
97 %{_sysconfdir}/init.d/vip6-autod
98
99 %attr(4755,root,root) %{_sbindir}/vsh
100 /bin/vsh
101 %{_mandir}/man8/vsh.8*
102
103 %changelog
104 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
105 - Fix runlevel clean up after reboot.
106 - Fix runlevel setup to reflect proper runlevel.
107
108 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
109 - supports disabling htbs.
110
111 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
112 - added in support for rlimit MEM_LOCK
113 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
114 - reduced compilation warnings
115
116 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
117 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
118 - as centos does not have any of these, do build vip6-autod on fedora only
119
120 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
121 - Remove current bw limit checks before issuing tc.
122
123 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
124 - libnl 1.1 fixups.
125
126 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
127 - reads /etc/vservers/<name>/personality and behaves accordingly
128 - nicer formatting for byte rates
129
130 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
131 - FUSE support.
132
133 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
134 - Check running values before issuing set or on.  If same, disregard to save on forks.
135
136 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
137 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
138
139 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
140 - Init exempt flows into "mangle" table.
141
142 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
143 - Optimized the case where it's already running.
144
145 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
146 - Ignore ESRCH for setname.
147 - Always create the home directory, regardless of configuration settings.
148
149 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
150
151
152 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
153 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
154 - Adding a tag to include in the 4.2rc2
155
156
157 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
158
159 - * Can write vcVHI_CONTEXT
160 - * CAP_NET_BIND_SERVICE is special, in all cases. 
161 - * Check if already mounted before mounting fs in vserver
162 - * Optimized 0.0.0.0 case
163 - * Removed vcached.  DEPRECATED
164
165
166 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
167 - Initial release