Setting tag util-vserver-pl-0.4-16
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 16
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers` 
82 do 
83         echo "persistent,lback_allow" > $i/nflags 
84         /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
85
86         sed -i -e '/tmpfs\tsize=16m/d' $i/fstab
87         rm $i/nonamespace
88         
89         mkdir -p $i/sysctl/0 
90         echo net.ipv4.ip_forward > $i/sysctl/0/setting
91         echo 1 > $i/sysctl/0/value
92         
93         echo -e "persistent\n~info_init" > $i/cflags
94         /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
95 done
96 popd
97
98 %postun
99 # 0 = erase, 1 = upgrade
100 if [ "$1" = 0 ] ; then
101         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
102 fi
103
104
105 %clean
106 rm -fr %{buildroot}
107
108
109 %files -f %name-python.list
110 %defattr(-,root,root,-)
111 %{_sbindir}/bwlimit
112 %{_sbindir}/disklimit
113 %{_sbindir}/vuseradd
114 %{_sbindir}/vuserdel
115 %{python_sitearch}/vserverimpl.so
116 %{_sbindir}/vip6-autod
117 %{_sysconfdir}/init.d/vip6-autod
118
119 %attr(4755,root,root) %{_sbindir}/vsh
120 /bin/vsh
121 %{_mandir}/man8/vsh.8*
122
123 %changelog
124 * Mon Jul 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-16
125 - * use system-wide umask
126 - * enable set_ipaddresses_config function
127 - * set more default values
128
129 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-15
130 - new constant VC_LIM_INFINITY
131
132 * Tue Jul 06 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-14
133 - fix setting cpu_share for slices
134
135 * Thu Jun 24 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-13
136 - start to use mount namespaces
137
138 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-12
139 - initscripts are ignored - handled by nodemanager and triggered by rc
140
141 * Thu Jun 17 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-11
142 - sliver name as the last argument to initscript
143
144 * Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-10
145 - remove tmpfs mounted /tmp
146
147 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
148 - change flags without restarting the vservers
149
150 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
151 - Migrate old style vservers to new style
152
153 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
154 - chroot_call fix
155
156 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
157 - fix initscript issues
158
159 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
160
161 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
162 - merged trellis branch to trunk
163
164 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
165 - Need to print the exception string as part of the self.log, or else we
166 - get a wrong number of argument error.
167
168 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
169 - This is outputted for some reason.
170
171 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
172 - Don't set bwlimits if they're disabled.
173 - Don't cleanup /var of running slivers.
174
175 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
176 - - openfd -> nofile
177
178 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
179 - call bwlimit init in postinstall.
180
181 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
182 - move the HTB tree one level down for DRL
183
184 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
185 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
186
187 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
188 - Log the error as well.
189
190 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
191 - Set ulimits for NM too.
192
193 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
194 - bwlimit.set() now accepts the device and don't assume that it's eth0
195
196 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
197 - Fix runlevel clean up after reboot.
198 - Fix runlevel setup to reflect proper runlevel.
199
200 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
201 - supports disabling htbs.
202
203 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
204 - added in support for rlimit MEM_LOCK
205 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
206 - reduced compilation warnings
207
208 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
209 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
210 - as centos does not have any of these, do build vip6-autod on fedora only
211
212 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
213 - Remove current bw limit checks before issuing tc.
214
215 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
216 - libnl 1.1 fixups.
217
218 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
219 - reads /etc/vservers/<name>/personality and behaves accordingly
220 - nicer formatting for byte rates
221
222 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
223 - FUSE support.
224
225 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
226 - Check running values before issuing set or on.  If same, disregard to save on forks.
227
228 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
229 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
230
231 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
232 - Init exempt flows into "mangle" table.
233
234 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
235 - Optimized the case where it's already running.
236
237 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
238 - Ignore ESRCH for setname.
239 - Always create the home directory, regardless of configuration settings.
240
241 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
242
243
244 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
245 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
246 - Adding a tag to include in the 4.2rc2
247
248
249 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
250
251 - * Can write vcVHI_CONTEXT
252 - * CAP_NET_BIND_SERVICE is special, in all cases. 
253 - * Check if already mounted before mounting fs in vserver
254 - * Optimized 0.0.0.0 case
255 - * Removed vcached.  DEPRECATED
256
257
258 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
259 - Initial release
260
261 %define module_current_branch 0.3