Setting tag util-vserver-pl-0.4-8
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers`; do echo "persistent,lback_allow" > $i/nflags; mkdir -p $i/sysctl/0; echo net.ipv4.ip_forward > $i/sysctl/0/setting; echo 1 > $i/sysctl/0/value; echo -e "persistent\n~info_init" > $i/cflags; done
82 popd
83
84 %postun
85 # 0 = erase, 1 = upgrade
86 if [ "$1" = 0 ] ; then
87         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
88 fi
89
90
91 %clean
92 rm -fr %{buildroot}
93
94
95 %files -f %name-python.list
96 %defattr(-,root,root,-)
97 %{_sbindir}/bwlimit
98 %{_sbindir}/disklimit
99 %{_sbindir}/vuseradd
100 %{_sbindir}/vuserdel
101 %{python_sitearch}/vserverimpl.so
102 %{_sbindir}/vip6-autod
103 %{_sysconfdir}/init.d/vip6-autod
104
105 %attr(4755,root,root) %{_sbindir}/vsh
106 /bin/vsh
107 %{_mandir}/man8/vsh.8*
108
109 %changelog
110 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
111 - Migrate old style vservers to new style
112
113 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
114 - chroot_call fix
115
116 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
117 - fix initscript issues
118
119 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
120
121 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
122 - merged trellis branch to trunk
123
124 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
125 - Need to print the exception string as part of the self.log, or else we
126 - get a wrong number of argument error.
127
128 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
129 - This is outputted for some reason.
130
131 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
132 - Don't set bwlimits if they're disabled.
133 - Don't cleanup /var of running slivers.
134
135 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
136 - - openfd -> nofile
137
138 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
139 - call bwlimit init in postinstall.
140
141 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
142 - move the HTB tree one level down for DRL
143
144 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
145 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
146
147 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
148 - Log the error as well.
149
150 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
151 - Set ulimits for NM too.
152
153 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
154 - bwlimit.set() now accepts the device and don't assume that it's eth0
155
156 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
157 - Fix runlevel clean up after reboot.
158 - Fix runlevel setup to reflect proper runlevel.
159
160 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
161 - supports disabling htbs.
162
163 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
164 - added in support for rlimit MEM_LOCK
165 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
166 - reduced compilation warnings
167
168 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
169 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
170 - as centos does not have any of these, do build vip6-autod on fedora only
171
172 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
173 - Remove current bw limit checks before issuing tc.
174
175 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
176 - libnl 1.1 fixups.
177
178 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
179 - reads /etc/vservers/<name>/personality and behaves accordingly
180 - nicer formatting for byte rates
181
182 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
183 - FUSE support.
184
185 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
186 - Check running values before issuing set or on.  If same, disregard to save on forks.
187
188 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
189 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
190
191 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
192 - Init exempt flows into "mangle" table.
193
194 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
195 - Optimized the case where it's already running.
196
197 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
198 - Ignore ESRCH for setname.
199 - Always create the home directory, regardless of configuration settings.
200
201 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
202
203
204 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
205 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
206 - Adding a tag to include in the 4.2rc2
207
208
209 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
210
211 - * Can write vcVHI_CONTEXT
212 - * CAP_NET_BIND_SERVICE is special, in all cases. 
213 - * Check if already mounted before mounting fs in vserver
214 - * Optimized 0.0.0.0 case
215 - * Removed vcached.  DEPRECATED
216
217
218 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
219 - Initial release
220
221 %define module_current_branch 0.3