remove hardcoded nproc.hard limit as it should be setted via GUI, also remove depreca...
[util-vserver-pl.git] / util-vserver-pl.spec
index 5c973a3..22fb97a 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name   util-vserver-pl
 %define version 0.4
-%define taglevel 9
+%define taglevel 22
 
 %define release        %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -80,15 +80,36 @@ fi
 pushd /etc/vservers
 for i in `ls /etc/vservers` 
 do 
+        # set nflags
        echo "persistent,lback_allow" > $i/nflags 
        /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
+
+        # set cflags
+       echo -e "persistent\n~info_init" > $i/cflags
+       /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
+
+       # deprecated
+       rm -f $i/flags
+
+        # remove 16mb tmp restrictions
+       sed -i -e '/tmpfs\tsize=16m/d' $i/fstab
+
+        # enable mount namespaces
+       rm -f $i/nonamespace
        
+        # enable IP forwarding
        mkdir -p $i/sysctl/0 
        echo net.ipv4.ip_forward > $i/sysctl/0/setting
        echo 1 > $i/sysctl/0/value
-       
-       echo -e "persistent\n~info_init" > $i/cflags
-       /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
+
+        # create missing interface files/directories
+        mkdir -p $i/interfaces/0 
+        hostname -i > $i/interfaces/0/ip
+        touch $i/interfaces/0/nodev 
+
+        mkdir -p $i/interfaces/1
+        echo -e "127.0.0.1" > $i/interfaces/1/ip
+        touch $i/interfaces/1/nodev
 done
 popd
 
@@ -118,6 +139,47 @@ rm -fr %{buildroot}
 %{_mandir}/man8/vsh.8*
 
 %changelog
+* Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-22
+- pass device to bwlimit
+
+* Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-21
+- force remove nonamespace
+
+* Tue Oct 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-20
+- Fix the segfault caused by existing TUN device
+
+* Fri Aug 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-19
+- Fix syntax error
+
+* Mon Aug 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-18
+- migrate old style interface files to new style
+
+* Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-17
+- Some dead code removed from repository
+
+* Mon Jul 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-16
+- * use system-wide umask
+- * enable set_ipaddresses_config function
+- * set more default values
+
+* Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-15
+- new constant VC_LIM_INFINITY
+
+* Tue Jul 06 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-14
+- fix setting cpu_share for slices
+
+* Thu Jun 24 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-13
+- start to use mount namespaces
+
+* Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-12
+- initscripts are ignored - handled by nodemanager and triggered by rc
+
+* Thu Jun 17 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-11
+- sliver name as the last argument to initscript
+
+* Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-10
+- remove tmpfs mounted /tmp
+
 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
 - change flags without restarting the vservers