Migrate old style vservers to new style
[util-vserver-pl.git] / util-vserver-pl.spec
index 092d1e8..d886a87 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL$
 
 %define name   util-vserver-pl
-%define version 0.3
-%define taglevel 14
+%define version 0.4
+%define taglevel 7
 
 %define release        %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -74,6 +74,12 @@ if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
        echo /bin/vsh >> /etc/shells
 fi
 
+/usr/sbin/bwlimit init
+
+# Migrate old style vservers to new style
+pushd /etc/vservers
+for i in `ls /etc/vservers`; do echo "persistent,lback_allow" > $i/nflags; mkdir -p $i/sysctl/0; echo net.ipv4.ip_forward > $i/sysctl/0/setting; echo 1 > $i/sysctl/0/value; echo -e "persistent\n~info_init" > $i/cflags; done
+popd
 
 %postun
 # 0 = erase, 1 = upgrade
@@ -101,6 +107,61 @@ rm -fr %{buildroot}
 %{_mandir}/man8/vsh.8*
 
 %changelog
+* Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
+- chroot_call fix
+
+* Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
+- fix initscript issues
+
+* Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
+
+* Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
+- merged trellis branch to trunk
+
+* Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
+- Need to print the exception string as part of the self.log, or else we
+- get a wrong number of argument error.
+
+* Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
+- This is outputted for some reason.
+
+* Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
+- Don't set bwlimits if they're disabled.
+- Don't cleanup /var of running slivers.
+
+* Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
+- - openfd -> nofile
+
+* Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
+- call bwlimit init in postinstall.
+
+* Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
+- move the HTB tree one level down for DRL
+
+* Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
+- logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
+
+* Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
+- Log the error as well.
+
+* Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
+- Set ulimits for NM too.
+
+* Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
+- bwlimit.set() now accepts the device and don't assume that it's eth0
+
+* Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
+- Fix runlevel clean up after reboot.
+- Fix runlevel setup to reflect proper runlevel.
+
+* Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
+- supports disabling htbs.
+
+* Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
+- added in support for rlimit MEM_LOCK
+- fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
+- reduced compilation warnings
+
 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
 - as centos does not have any of these, do build vip6-autod on fedora only
@@ -153,3 +214,5 @@ rm -fr %{buildroot}
 
 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
 - Initial release
+
+%define module_current_branch 0.3