- apparently commenting out Requires: lines is not enough!
[util-vserver.git] / util-vserver.spec
1 # $Id: util-vserver.spec.in,v 1.49 2005/07/15 19:06:58 ensc Exp $
2
3 ## This package understands the following switches:
4 ## --without dietlibc        ...   disable usage of dietlibc
5 ## --without xalan           ...   do not require/use the xalan xslt processor
6
7 %global confdir         %_sysconfdir/vservers
8 %global confdefaultdir  %confdir/.defaults
9 %global pkglibdir       %_libdir/%name
10 %global __chattr        /usr/bin/chattr
11 %global chkconfig       /sbin/chkconfig
12
13 %global _localstatedir  %_var
14
15
16 %{!?release_func:%global release_func() %1%{?dist}}
17
18 %define name util-vserver
19 %define version 0.30.208
20 %define release 10%{?pldistro:.%{pldistro}}%{?date:.%{date}}
21
22 %define _without_dietlibc 1
23 %define _without_xalan 1
24
25 # don't build debuginfo RPM
26 %define debug_package %{nil}
27
28 Vendor: PlanetLab
29 Packager: PlanetLab Central <support@planet-lab.org>
30 Distribution: PlanetLab 3.0
31 URL: http://cvs.planet-lab.org/cvs/util-vserver
32
33 Summary:        Linux virtual server utilities
34 Name:           util-vserver
35 Version:        0.30.208
36 Release:        %{release}
37 License:        GPL
38 Group:          System Environment/Base
39 #URL:           http://savannah.nongnu.org/projects/util-vserver/
40 Source0:        http://savannah.nongnu.org/download/util-vserver/stable.pkg/%version/%name-%version.tar.bz2
41 BuildRoot:      %_tmppath/%name-%version-%release-root
42 Requires:       init(%name)
43 Requires:       %name-core = %version-%release
44 Requires:       %name-lib  = %version-%release
45 Requires:       diffutils mktemp sed
46 Provides:       vserver = %version-%release
47 Obsoletes:      vserver < %version
48 BuildRequires:  mount vconfig gawk iproute iptables
49 BuildRequires:  gcc-c++ wget which diffutils
50 BuildRequires:  e2fsprogs-devel beecrypt-devel
51 BuildRequires:  doxygen tetex-latex
52 Requires(pre):          %pkglibdir
53 Requires(postun):       %pkglibdir
54 %{!?_without_dietlibc:BuildRequires:    dietlibc >= 0:0.25}
55 %{!?_without_xalan:BuildRequires:       xalan-j}
56
57 %package lib
58 Summary:                Dynamic libraries for util-vserver
59 Group:                  System Environment/Libraries
60
61 %package core
62 Summary:                The core-utilities for util-vserver
63 Group:                  Applications/System
64 Requires:               util-linux
65
66 %package build
67 Summary:                Tools which can be used to build vservers
68 Group:                  Applications/System
69 Requires:               rpm wget binutils tar e2fsprogs
70 Requires:               %name = %version-%release
71 Requires(pre):          %confdir
72 Requires(postun):       %confdir
73
74 %package sysv
75 Summary:                SysV-initscripts for vserver
76 Group:                  System Environment/Base
77 Provides:               init(%name) = sysv
78 Requires:               make diffutils
79 Requires:               initscripts
80 Requires:               %name = %version-%release
81 Requires(post):         %chkconfig
82 Requires(preun):        %chkconfig
83 Requires(pre):          %_initrddir %pkglibdir
84 requires(postun):       %_initrddir %pkglibdir
85
86 %package legacy
87 Summary:                Legacy utilities for util-vserver
88 Group:                  Applications/System
89 Requires:               %name = %version-%release
90 Requires(post):         %chkconfig
91 Requires(preun):        %chkconfig
92 Requires(pre):          %_initrddir %pkglibdir
93 requires(postun):       %_initrddir %pkglibdir
94
95 %package devel
96 Summary:                Header-files and libraries needed to develop vserver based applications
97 Group:                  Development/Libraries
98 Requires:               pkgconfig
99 Requires:               %name-lib = %version-%release
100
101 %package python
102 Summary:                Python modules for manipulating vservers
103 Group:                  Applications/System
104 Requires:               python util-python
105 Obsoletes:              util-vserver-py23
106
107
108 %description
109 util-vserver provides the components and a framework to setup virtual
110 servers.  A virtual server runs inside a linux server. It is nevertheless
111 highly independent. As such, you can run various services with normal
112 configuration. The various vservers can't interact with each other and
113 can't interact with services in the main server.
114
115 This requires a special kernel supporting the new new_s_context and
116 set_ipv4root system call.
117
118 %description lib
119 util-vserver provides the components and a framework to setup virtual
120 servers.  A virtual server runs inside a linux server. It is nevertheless
121 highly independent. As such, you can run various services with normal
122 configuration. The various vservers can't interact with each other and
123 can't interact with services in the main server.
124
125 This package contains the shared libraries needed by all other
126 'util-vserver' subpackages.
127
128 %description core
129 util-vserver provides the components and a framework to setup virtual
130 servers.  A virtual server runs inside a linux server. It is nevertheless
131 highly independent. As such, you can run various services with normal
132 configuration. The various vservers can't interact with each other and
133 can't interact with services in the main server.
134
135 This package contains utilities which are required to communicate with
136 the Linux-Vserver enabled kernel.
137
138
139 %description build
140 util-vserver provides the components and a framework to setup virtual
141 servers.  A virtual server runs inside a linux server. It is nevertheless
142 highly independent. As such, you can run various services with normal
143 configuration. The various vservers can't interact with each other and
144 can't interact with services in the main server.
145
146 This package contains utilities which assist in building Vservers.
147
148 %description sysv
149 util-vserver provides the components and a framework to setup virtual
150 servers.  A virtual server runs inside a linux server. It is nevertheless
151 highly independent. As such, you can run various services with normal
152 configuration. The various vservers can't interact with each other and
153 can't interact with services in the main server.
154
155 This package contains the SysV initscripts which start and stop
156 VServers and related tools.
157
158
159 %description legacy
160 util-vserver provides the components and a framework to setup virtual
161 servers.  A virtual server runs inside a linux server. It is nevertheless
162 highly independent. As such, you can run various services with normal
163 configuration. The various vservers can't interact with each other and
164 can't interact with services in the main server.
165
166 This package contains the tools which are needed to work with VServers
167 having an old-style configuration.
168
169
170 %description devel
171 util-vserver provides the components and a framework to setup virtual
172 servers.  A virtual server runs inside a linux server. It is nevertheless
173 highly independent. As such, you can run various services with normal
174 configuration. The various vservers can't interact with each other and
175 can't interact with services in the main server.
176
177 This package contains header files and libraries which are needed to
178 develop VServer related applications.
179
180
181 %description python
182 Python modules for manipulating vservers.  Provides a superset of the
183 functionality of the vserver script (at least will do in the future),
184 but more readily accessible from Python code.
185
186
187 %prep
188 %setup -q
189
190 aclocal -I m4
191 autoconf
192 automake --add-missing
193
194 %build
195 %configure --with-initrddir=%_initrddir --enable-release \
196            %{?_without_dietlibc:--disable-dietlibc}
197
198 %__make %{?_smp_mflags} all
199 %__make %{?_smp_mflags} doc
200
201 %__make -C python
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 %__make DESTDIR="$RPM_BUILD_ROOT" install install-distribution
206
207 rm -f $RPM_BUILD_ROOT/%_libdir/*.la
208
209 MANIFEST_CONFIG='%config' \
210 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
211 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
212
213 # install python bindings
214 %__make -C python DESTDIR="$RPM_BUILD_ROOT" install
215
216
217 %check || :
218 #%__make check
219
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224
225 %post
226 test -d /vservers      || mkdir -m0000 /vservers
227 test -d /vservers/.pkg || mkdir -m0755 /vservers/.pkg
228
229 f="%confdefaultdir/vdirbase"; test -L "$f" -o -e "$f" || ln -s /vservers                        "$f"
230 f="%confdefaultdir/run.rev";  test -L "$f" -o -e "$f" || ln -s %_localstatedir/run/vservers.rev "$f"
231
232 %_sbindir/setattr --barrier /vservers || :
233
234 # add /bin/vsh to list of secure shells
235 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
236     echo /bin/vsh >> /etc/shells
237 fi
238
239
240 %postun
241 # 0 = erase, 1 = upgrade
242 if [ "$1" = 0 ] ; then
243     perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
244 fi
245
246
247 %post   lib -p /sbin/ldconfig
248 %postun lib -p /sbin/ldconfig
249
250
251 %post sysv
252 #%chkconfig --add vservers-default
253 #%chkconfig --add vprocunhide
254 # PlanetLab Node Manager takes care of starting and stopping VServers
255 %chkconfig --del vservers-default
256 # PlanetLab does not require /proc security
257 %chkconfig --del vprocunhide
258
259 %preun sysv
260 #test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
261
262 #test "$1" != 0 || %chkconfig --del vprocunhide
263 #test "$1" != 0 || %chkconfig --del vservers-default
264
265
266 %postun sysv
267 #test "$1" = 0  || %_initrddir/vprocunhide condrestart >/dev/null || :
268
269
270 %triggerin build -- fedora-release
271 function copy()
272 {
273     base=$1
274     shift
275
276     for i; do
277         test -r "$i" || continue
278
279         target=%confdir/.distributions/.common/pubkeys/$base-$(basename "$i")
280         cp -a "$i" "$target"
281     done
282 }
283 copy fedora /usr/share/doc/fedora-release-*/RPM-GPG-*
284 copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
285
286
287 %preun build
288 test "$1" != 0 || rm -f %confdir/.distributions/.common/pubkeys/fedora-*
289
290
291 ## Temporary workaround to remove old v_* files; it will conflict
292 ## somehow with the -legacy package but can be fixed by reinstalling
293 ## this package.
294 ## TODO: remove me in the final .spec file
295 %define v_services      httpd named portmap sendmail smb sshd xinetd gated
296 %triggerun sysv -- util-vserver-sysv < 0.30.198
297 for i in %v_services; do
298         %chkconfig --del v_$i || :
299 done
300
301
302 %post legacy
303 # PlanetLab Node Manager takes care of starting and stopping VServers
304 #%chkconfig --add rebootmgr
305 #%chkconfig --add vservers-legacy
306
307 # PlanetLab does not require these legacy services
308 #for i in %v_services; do
309 #       %chkconfig --add v_$i
310 #done
311
312
313 %preun legacy
314 #test "$1" != 0 || %_initrddir/rebootmgr   stop &>/dev/null || :
315
316 #test "$1" != 0 || for i in %v_services; do
317 #       %chkconfig --del v_$i
318 #done
319
320 #test "$1" != 0 || %chkconfig --del rebootmgr
321 #test "$1" != 0 || %chkconfig --del vservers-legacy
322
323 %postun legacy
324 #test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
325
326
327 %files -f %name-base.list
328 %defattr(-,root,root,-)
329 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
330 %doc doc/*.html doc/*.css
331 /sbin/vshelper
332 %dir %confdir
333 %dir %confdefaultdir
334 %dir %confdefaultdir/apps
335 %dir %confdefaultdir/files
336 %dir %pkglibdir/defaults
337 %ghost %confdefaultdir/vdirbase
338 %ghost %confdefaultdir/run.rev
339
340 %dir %_localstatedir/run/vservers
341 %dir %_localstatedir/run/vservers.rev
342 %dir %_localstatedir/run/vshelper
343
344
345 %files lib -f %name-lib.list
346 %files sysv -f %name-sysv.list
347
348
349 %files core -f %name-core.list
350 %defattr(-,root,root,-)
351 %dir %pkglibdir
352
353
354 %files build -f %name-build.list
355 %defattr(-,root,root,-)
356 %doc contrib/yum*.patch
357 %dir %confdir/.distributions
358 %dir %confdir/.distributions/*
359 %dir %confdir/.distributions/*/apt
360 %dir %confdir/.distributions/.common
361 %dir %confdir/.distributions/.common/pubkeys
362 %dir %confdefaultdir/apps/vunify
363 %dir %confdefaultdir/apps/vunify/hash
364
365
366 %files legacy -f %name-legacy.list
367 %defattr(-,root,root,-)
368 %dir %pkglibdir/legacy
369
370
371 %files devel -f %name-devel.list
372 %defattr(-,root,root,-)
373 %doc lib/apidoc/latex/refman.pdf
374 %doc lib/apidoc/html
375
376
377 %files python
378 %defattr(0644,root,root)
379 %_libdir/python2.3/site-packages/*
380
381
382 %changelog
383 * Fri Feb 17 2006 Steve Muir <smuir@cs.princeton.edu>
384 - add support for setting guaranteed CPU share flag in rspec
385
386 * Fri Jan 13 2006 Steve Muir <smuir@cs.princeton.edu>
387 - fix bug in python/vserverimpl.c where attempting to adjust CPU share
388   for a context that didn't exist would cause an error (it should be a
389   safe no-op)
390
391 * Fri Dec  2 2005 Steve Muir <smuir@cs.princeton.edu>
392 - fix bugs in python/vserverimpl.c where exceptions were not raised when
393   they should be and thus occured later at unexpected times
394 - add support for stopping a vserver
395
396 * Wed Nov  9 2005 Steve Muir <smuir@cs.princeton.edu>
397 - add support for removing resource limits e.g., when a slice is deleted
398
399 * Mon Nov  7 2005 Steve Muir <smuir@cs.princeton.edu>
400 - fix file descriptor leak in vduimpl
401 - clean up handling of network parameters
402 - don't rely upon /etc/vservers/foo.conf to initialise vserver object
403
404 * Wed Nov  2 2005 Steve Muir <smuir@cs.princeton.edu>
405 - fix Python modules to handling scheduling parameters correctly
406
407 * Fri Oct 28 2005 Steve Muir <smuir@cs.princeton.edu>
408 - raise exception about being over disk limit after setting usage values
409
410 * Fri Oct  7 2005 Steve Muir <smuir@cs.princeton.edu>
411 - create common function to be used for entering a vserver and applying
412   resource limits
413
414 * Thu Aug 21 2005 Mark Huang <mlhuang@cs.princeton.edu>
415 - restore build of python modules
416
417 * Sat Aug 20 2005 Mark Huang <mlhuang@cs.princeton.edu>
418 - upgrade to util-vserver-0.30.208
419 - forward-port vbuild and legacy support until we can find a suitable
420   replacement
421 - make vsh use new vc_create_context() call
422
423 * Thu Jul 28 2005 Steve Muir <smuir@cs.princeton.edu>
424 - add support for static vserver IDs to vuseradd and vuserdel
425
426 * Thu Jul 21 2005 Steve Muir <smuir@cs.princeton.edu>
427 - add bwlimit and cpulimit modules
428
429 * Fri Jul 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-1
430 - require the -lib subpackage by -devel
431 - copy GPG keys from /etc/pki/rpm-gpg/
432
433 * Mon Jun 20 2005 Steve Muir <smuir@cs.princeton.edu>
434 - import Marc's vdu implementation
435
436 * Wed Jun 15 2005 Steve Muir <smuir@cs.princeton.edu>
437 - 'vserver-init start' functionality subsumed by Node Manager
438
439 * Thu Jun 02 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
440 - Fixed vlimit command
441
442 * Wed May 25 2005 Steve Muir <smuir@cs.princeton.edu>
443 - add Python modules for manipulating vservers
444
445 * Fri Apr 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.206-1
446 - added patches to make yum work in chroot environments
447 - version 0.30.206
448
449 * Thu Apr  7 2005 Steve Muir <smuir@cs.princeton.edu>
450 - vuserdel changes: don't shutdown vserver, just kill all processes;
451   unmount all mountpoints in vserver before deleting
452
453 * Thu Mar 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.205-0
454 - added some %%descriptions
455 - copy GPG keys from the system into the confdir
456 - buildrequire dietlibc-0.25
457 - BuildRequire beecrypt-devel
458 - cleanups
459 - use %%global instead of %%define
460 - removed 'run.rev' as a vserver-local variable and made it a system-wide setting
461
462 * Wed Jan 26 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.198-0.3
463 - updated BuildRequires:
464 - use 'setattr --barrier' instead of 'chattr +t' in the %%post scriptlet
465 - moved the v_* initscripts to legacy
466 - do not ship the /vservers directory itself; as it is immutable, the
467   extraction will fail else
468
469 * Fri Nov 19 2004 Mark Huang <mlhuang@cs.princeton.edu>
470 - vcached no longer runs as a daemon
471 - do not restart vservers when package is upgraded
472
473 * Wed Nov 17 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-6.planetlab
474 + planetlab-3_0-rc4
475 - PL2445
476 - Both vcached and vuseradd now print a warning message when vbuild
477   succeeds but the resulting new vserver image is smaller in size than
478   the vserver-reference image.
479 - vuseradd: clean up some more junk on failure
480
481 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-5.planetlab
482 + planetlab-3_0-rc3
483 - PL3026: This is the upgraded version of vdu that maintains an
484   internal hash table of files with a nlink count > 1.  Only if vdu
485   sees all hard links to a particular inode does it add its size and
486   block count to the total.
487
488 * Fri Nov 12 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-4.planetlab
489 - PL2445 Use -b option to du to avoid rounding errors.
490
491 * Sat Nov  6 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-3.planetlab
492 + planetlab-3_0-rc2
493 - don't create the symbolic link /home/slice/.ssh, this is not how
494   pl_sshd works
495
496 * Mon Oct 11 2004 Marc E. Fiuczynski <mef@cs.princeton.edu>
497 - added vsh
498
499 * Thu Sep  9 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.194-0
500 - documented switches for 'rpmbuild'
501
502 * Wed Aug 11 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.29-1.planetlab
503 - initial PlanetLab 3.0 build.
504
505 * Wed May 26 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.215-0
506 - (re)added the MANIFEST_* variables which were lost some time ago;
507   this will preserve %%config files...
508
509 * Mon Mar 15 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.202-0
510 - use file-list for sysv scripts also
511
512 * Sat Mar  6 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.198-0
513 - added vprocunhide-service support
514 - added doxygen support
515 - updated Requires:
516
517 * Wed Oct  1 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.23.5-0
518 - Initial build.