add f12 files
[util-vserver.git] / util-vserver.spec
1 # $Id: util-vserver.spec.in 2807 2008-10-30 01:59:52Z dhozac $
2
3 %if "%{?_without_python:1}" != "1"
4 %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5 %endif
6
7 ## This package understands the following switches:
8 ## --without dietlibc        ...   disable usage of dietlibc
9 ## --with xalan              ...   require/use the xalan xslt processor
10 ## --without doc             ...   disable doc generation
11 ## --with legacy             ...   enable the legacy APIs
12
13 %global confdir         %_sysconfdir/vservers
14 %global confdefaultdir  %confdir/.defaults
15 %global pkglibdir       %_libdir/%name
16 %global chkconfig       /sbin/chkconfig
17
18 %global _localstatedir  %_var
19
20 %global fullver         0.30.216-pre2883
21 %global ver             %( echo %fullver | sed 's/-.*//' )
22 %global subver          %( s=`echo %fullver | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
23
24 # for module-tools
25 %global module_version_varname fullver
26 %global taglevel 0
27
28 %{!?release_func:%global release_func() %1%{?dist}}
29
30 Summary:        Linux virtual server utilities
31 Name:           util-vserver
32 Version:        %ver
33 Release:        %taglevel
34 License:        GPL
35 Group:          System Environment/Base
36 URL:            http://savannah.nongnu.org/projects/util-vserver/
37 Source0:        http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%fullver.tar.bz2
38 #Source1:       http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%fullver.tar.bz2.asc
39 Patch1:         f12.patch
40 BuildRoot:      %_tmppath/%name-%version-%release-root
41 Requires:       init(%name)
42 Requires:       %name-core = %version-%release
43 Requires:       %name-lib  = %version-%release
44 Requires:       diffutils mktemp sed
45 Provides:       vserver = %version-%release
46 Obsoletes:      vserver < %version
47 BuildRequires:  mount vconfig gawk /sbin/ip iptables
48 BuildRequires:  gcc-c++ wget which diffutils
49 BuildRequires:  e2fsprogs-devel e2fsprogs
50 %{!?_without_beecrypt:BuildRequires: beecrypt-devel}
51 %{?_without_beecrypt:BuildRequires: nss-devel}
52 BuildRequires:  e2fsprogs
53 #%%{!?_without_doc:BuildRequires:       doxygen tetex-latex}
54 %{!?_without_python:BuildRequires: python python-devel ctags}
55 Requires(post):         %name-core
56 Requires(pre):          %pkglibdir
57 Requires(postun):       %pkglibdir
58 %{!?_without_dietlibc:BuildRequires:    dietlibc >= 0:0.25}
59 %{?_with_xalan:BuildRequires:   xalan-j}
60
61 %package lib
62 Summary:                Dynamic libraries for util-vserver
63 Group:                  System Environment/Libraries
64
65 %package core
66 Summary:                The core-utilities for util-vserver
67 Group:                  Applications/System
68 Requires:               util-linux
69
70 %package build
71 Summary:                Tools which can be used to build vservers
72 Group:                  Applications/System
73 Requires:               rpm wget binutils tar
74 Requires:               %name = %version-%release
75 Requires(pre):          %confdir
76 Requires(postun):       %confdir
77 Requires(post):         %name-core
78
79 %package sysv
80 Summary:                SysV-initscripts for vserver
81 Group:                  System Environment/Base
82 Provides:               init(%name) = sysv
83 Requires:               make diffutils
84 Requires:               initscripts
85 Requires:               %name = %version-%release
86 Requires(post):         %chkconfig
87 Requires(preun):        %chkconfig
88 Requires(pre):          %_initrddir %pkglibdir
89 requires(postun):       %_initrddir %pkglibdir
90
91 %package legacy
92 Summary:                Legacy utilities for util-vserver
93 Group:                  Applications/System
94 Requires:               %name = %version-%release
95 Requires(post):         %chkconfig
96 Requires(preun):        %chkconfig
97 Requires(pre):          %_initrddir %pkglibdir
98 requires(postun):       %_initrddir %pkglibdir
99
100 %package devel
101 Summary:                Header-files and libraries needed to develop vserver based applications
102 Group:                  Development/Libraries
103 Requires:               pkgconfig
104 Requires:               %name-lib = %version-%release
105
106 %package python
107 Summary:                Python bindings to develop vserver-based applications
108 Group:                  Development/Libraries
109 Requires:               %name-lib = %version-%release
110
111
112 %description
113 util-vserver provides the components and a framework to setup virtual
114 servers.  A virtual server runs inside a linux server. It is nevertheless
115 highly independent. As such, you can run various services with normal
116 configuration. The various vservers can't interact with each other and
117 can't interact with services in the main server.
118
119 This requires a special kernel supporting the new new_s_context and
120 set_ipv4root system call.
121
122 %description lib
123 util-vserver provides the components and a framework to setup virtual
124 servers.  A virtual server runs inside a linux server. It is nevertheless
125 highly independent. As such, you can run various services with normal
126 configuration. The various vservers can't interact with each other and
127 can't interact with services in the main server.
128
129 This package contains the shared libraries needed by all other
130 'util-vserver' subpackages.
131
132 %description core
133 util-vserver provides the components and a framework to setup virtual
134 servers.  A virtual server runs inside a linux server. It is nevertheless
135 highly independent. As such, you can run various services with normal
136 configuration. The various vservers can't interact with each other and
137 can't interact with services in the main server.
138
139 This package contains utilities which are required to communicate with
140 the Linux-Vserver enabled kernel.
141
142
143 %description build
144 util-vserver provides the components and a framework to setup virtual
145 servers.  A virtual server runs inside a linux server. It is nevertheless
146 highly independent. As such, you can run various services with normal
147 configuration. The various vservers can't interact with each other and
148 can't interact with services in the main server.
149
150 This package contains utilities which assist in building Vservers.
151
152 %description sysv
153 util-vserver provides the components and a framework to setup virtual
154 servers.  A virtual server runs inside a linux server. It is nevertheless
155 highly independent. As such, you can run various services with normal
156 configuration. The various vservers can't interact with each other and
157 can't interact with services in the main server.
158
159 This package contains the SysV initscripts which start and stop
160 VServers and related tools.
161
162
163 %description legacy
164 util-vserver provides the components and a framework to setup virtual
165 servers.  A virtual server runs inside a linux server. It is nevertheless
166 highly independent. As such, you can run various services with normal
167 configuration. The various vservers can't interact with each other and
168 can't interact with services in the main server.
169
170 This package contains the tools which are needed to work with VServers
171 having an old-style configuration.
172
173
174 %description devel
175 util-vserver provides the components and a framework to setup virtual
176 servers.  A virtual server runs inside a linux server. It is nevertheless
177 highly independent. As such, you can run various services with normal
178 configuration. The various vservers can't interact with each other and
179 can't interact with services in the main server.
180
181 This package contains header files and libraries which are needed to
182 develop VServer related applications.
183
184 %description python
185 util-vserver provides the components and a framework to setup virtual
186 servers.  A virtual server runs inside a linux server. It is nevertheless
187 highly independent. As such, you can run various services with normal
188 configuration. The various vservers can't interact with each other and
189 can't interact with services in the main server.
190
191 This package contains the files needed to interface with the
192 Linux-VServer API from Python.
193
194
195 %prep
196 %setup -q -n %name-%fullver
197 %patch1 -p0
198
199 %build
200 %configure --with-initrddir=%_initrddir --enable-release \
201            %{?_without_dietlibc:--disable-dietlibc} \
202            %{?_with_legacy:--enable-apis=NOLEGACY} \
203            --with-initscripts=sysv \
204            %{?_without_python:--without-python}
205
206 %__make %{?_smp_mflags} all
207 #%%{!?_without_doc:%__make %{?_smp_mflags} doc}
208
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212 %__make DESTDIR="$RPM_BUILD_ROOT" install install-distribution
213
214 rm -f $RPM_BUILD_ROOT/%_libdir/*.la
215
216 MANIFEST_CONFIG='%config' \
217 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
218 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
219
220
221 %check
222 %__make check
223
224
225 %clean
226 rm -rf $RPM_BUILD_ROOT
227
228
229 %post
230 test -d /vservers      || mkdir -m0000 /vservers
231 test -d /vservers/.pkg || mkdir -m0755 /vservers/.pkg
232
233 f="%confdefaultdir/vdirbase";  test -L "$f" -o -e "$f" || ln -s /vservers                        "$f"
234 f="%confdefaultdir/run.rev";   test -L "$f" -o -e "$f" || ln -s %_localstatedir/run/vservers.rev "$f"
235 f="%confdefaultdir/cachebase"; test -L "$f" -o -e "$f" || ln -s %_localstatedir/cache/vservers   "$f"
236
237 %_sbindir/setattr --barrier /vservers /vservers/.pkg || :
238
239
240 %preun
241 test "$1" != 0 || rm -rf %_localstatedir/cache/vservers/* 2>/dev/null || :
242
243
244 %post   lib -p /sbin/ldconfig
245 %postun lib -p /sbin/ldconfig
246
247
248 %post sysv
249 %chkconfig --add vservers-default
250 %chkconfig --add vprocunhide
251 %chkconfig --add util-vserver
252 %chkconfig util-vserver on
253
254
255 %preun sysv
256 test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
257
258 test "$1" != 0 || %chkconfig --del vprocunhide
259 test "$1" != 0 || %chkconfig --del vservers-default
260 test "$1" != 0 || %chkconfig --del util-vserver
261
262
263 %postun sysv
264 test "$1" = 0  || %_initrddir/vprocunhide condrestart >/dev/null || :
265
266
267 %triggerin build -- fedora-release, centos-release
268 function copy()
269 {
270     base=$1
271     shift
272
273     for i; do
274         test -r "$i" || continue
275
276         target=%confdir/.distributions/.common/pubkeys/$base-$(basename "$i")
277         cp -a "$i" "$target"
278     done
279 }
280 copy fedora /usr/share/doc/fedora-release-*/RPM-GPG-*
281 copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
282 copy centos /usr/share/doc/centos-*/RPM-GPG-KEY-*
283
284
285 %pre build
286 x="%_libdir/util-vserver/distributions/etch"
287 test -d "$x" && mv "$x" "$x.rpmsave" || :
288
289
290 %post build
291 test -d /vservers/.hash || mkdir -m0700 /vservers/.hash
292
293 f="%confdefaultdir/apps/vunify/hash"; test -e "$f"/method -o -e "$f"/00 || \
294         ln -s /vservers/.hash "$f"/00
295
296 %_sbindir/setattr --barrier /vservers/.hash || :
297
298
299 %preun build
300 test "$1" != 0 || rm -f %confdir/.distributions/.common/pubkeys/fedora-*
301
302
303 ## Temporary workaround to remove old v_* files; it will conflict
304 ## somehow with the -legacy package but can be fixed by reinstalling
305 ## this package.
306 ## TODO: remove me in the final .spec file
307 %define v_services      httpd named portmap sendmail smb sshd xinetd gated
308 %triggerun sysv -- util-vserver-sysv < 0.30.198
309 for i in %v_services; do
310         %chkconfig --del v_$i || :
311 done
312
313
314 %post legacy
315 %chkconfig --add rebootmgr
316 %chkconfig --add vservers-legacy
317
318 for i in %v_services; do
319         %chkconfig --add v_$i
320 done
321
322
323 %preun legacy
324 test "$1" != 0 || %_initrddir/rebootmgr   stop &>/dev/null || :
325
326 test "$1" != 0 || for i in %v_services; do
327         %chkconfig --del v_$i
328 done
329
330 test "$1" != 0 || %chkconfig --del rebootmgr
331 test "$1" != 0 || %chkconfig --del vservers-legacy
332
333 %postun legacy
334 test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
335
336
337 %files -f %name-base.list
338 %defattr(-,root,root,-)
339 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
340 %doc doc/*.html doc/*.css
341 /sbin/vshelper
342 %dir %confdir
343 %dir %confdefaultdir
344 %dir %confdefaultdir/apps
345 %dir %confdefaultdir/files
346 %dir %pkglibdir/defaults
347 %ghost %confdefaultdir/cachebase
348 %ghost %confdefaultdir/vdirbase
349 %ghost %confdefaultdir/run.rev
350
351 %dir %_localstatedir/cache/vservers
352 %dir %_localstatedir/run/vservers
353 %dir %_localstatedir/run/vservers.rev
354 %dir %_localstatedir/run/vshelper
355
356
357 %files lib -f %name-lib.list
358 %files sysv -f %name-sysv.list
359
360
361 %files core -f %name-core.list
362 %defattr(-,root,root,-)
363 %dir %pkglibdir
364
365
366 %files build -f %name-build.list
367 %defattr(-,root,root,-)
368 %doc contrib/yum*.patch
369 %dir %confdir/.distributions
370 %dir %confdir/.distributions/*
371 %dir %confdir/.distributions/*/apt
372 %dir %confdir/.distributions/.common
373 %dir %confdir/.distributions/.common/pubkeys
374 %dir %confdefaultdir/apps/vunify
375 %dir %confdefaultdir/apps/vunify/hash
376
377
378 %files legacy -f %name-legacy.list
379 %defattr(-,root,root,-)
380 %dir %pkglibdir/legacy
381
382
383 %files devel -f %name-devel.list
384 %defattr(-,root,root,-)
385 #%%{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
386 #%%{!?_without_doc:%doc lib/apidoc/html}
387
388
389 %files python
390 %defattr(-,root,root,-)
391 %{!?_without_python:%{python_sitearch}/*}
392
393
394 %changelog
395 * Mon Jun 25 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.214-0
396 - updated URLs
397 - get rid of e2fsprogs requirement
398
399 * Fri Dec 29 2006 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.213-0
400 - add --with legacy and --without doc switches
401 - add util-vserver initscript
402
403 * Sun Jan 22 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.30.210-0
404 - do not require 'xalan' anymore by default
405 - removed 'Requires: apt'; apt-rpm is not maintained upstream anymore
406 - removed 'chattr' leftovers
407 - create the '/etc/vservers/.defaults/cachebase' symlink
408 - added /var/cache/vservers and the needed support
409 - set barrier attribute on /vservers/.pkg and /vservers/.hash
410 - added 'centos-release' to the list of packages in the copy-the-keys
411   trigger script
412 - create '/vservers/.hash' and add initial configuration for it
413
414 * Sun Oct 30 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.209-0
415 - version 0.30.209
416 - copy centos keys
417
418 * Sat Jul 16 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-2
419 - updated URLs
420
421 * Fri Jul 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-1
422 - version 0.30.208
423 - require the -lib subpackage by -devel
424 - copy GPG keys from /etc/pki/rpm-gpg/
425
426 * Fri Apr 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.206-1
427 - added patches to make yum work in chroot environments
428 - version 0.30.206
429
430 * Thu Mar 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.205-0
431 - added some %%descriptions
432 - copy GPG keys from the system into the confdir
433 - buildrequire dietlibc-0.25
434 - BuildRequire beecrypt-devel
435 - cleanups
436 - use %%global instead of %%define
437 - removed 'run.rev' as a vserver-local variable and made it a system-wide setting
438
439 * Wed Jan 26 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.198-0.3
440 - updated BuildRequires:
441 - use 'setattr --barrier' instead of 'chattr +t' in the %%post scriptlet
442 - moved the v_* initscripts to legacy
443 - do not ship the /vservers directory itself; as it is immutable, the
444   extraction will fail else
445
446 * Thu Sep  9 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.194-0
447 - documented switches for 'rpmbuild'
448
449 * Wed May 26 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.215-0
450 - (re)added the MANIFEST_* variables which were lost some time ago;
451   this will preserve %%config files...
452
453 * Mon Mar 15 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.202-0
454 - use file-list for sysv scripts also
455
456 * Sat Mar  6 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.198-0
457 - added vprocunhide-service support
458 - added doxygen support
459 - updated Requires:
460
461 * Wed Oct  1 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.23.5-0
462 - Initial build.