bump release
[util-vserver.git] / util-vserver.spec
1 # $Id: util-vserver.spec.in,v 1.49 2005/07/15 19:06:58 ensc Exp $
2
3 ## This package understands the following switches:
4 ## --without dietlibc        ...   disable usage of dietlibc
5 ## --without xalan           ...   do not require/use the xalan xslt processor
6
7 %global confdir         %_sysconfdir/vservers
8 %global confdefaultdir  %confdir/.defaults
9 %global pkglibdir       %_libdir/%name
10 %global __chattr        /usr/bin/chattr
11 %global chkconfig       /sbin/chkconfig
12
13 %global _localstatedir  %_var
14
15
16 %{!?release_func:%global release_func() %1%{?dist}}
17
18 %define name util-vserver
19 %define version 0.30.208
20 %define release 15%{?pldistro:.%{pldistro}}%{?date:.%{date}}
21
22 %define _without_dietlibc 1
23 %define _without_xalan 1
24
25 # don't build debuginfo RPM
26 %define debug_package %{nil}
27
28 Vendor: PlanetLab
29 Packager: PlanetLab Central <support@planet-lab.org>
30 Distribution: PlanetLab 3.0
31 URL: http://cvs.planet-lab.org/cvs/util-vserver
32
33 Summary:        Linux virtual server utilities
34 Name:           util-vserver
35 Version:        0.30.208
36 Release:        %{release}
37 License:        GPL
38 Group:          System Environment/Base
39 #URL:           http://savannah.nongnu.org/projects/util-vserver/
40 Source0:        http://savannah.nongnu.org/download/util-vserver/stable.pkg/%version/%name-%version.tar.bz2
41 BuildRoot:      %_tmppath/%name-%version-%release-root
42 Requires:       init(%name)
43 Requires:       %name-core = %version-%release
44 Requires:       %name-lib  = %version-%release
45 Requires:       diffutils mktemp sed
46 Provides:       vserver = %version-%release
47 Obsoletes:      vserver < %version
48 BuildRequires:  mount vconfig gawk iproute iptables
49 BuildRequires:  gcc-c++ wget which diffutils
50 BuildRequires:  e2fsprogs-devel beecrypt-devel
51 BuildRequires:  doxygen tetex-latex
52 Requires(pre):          %pkglibdir
53 Requires(postun):       %pkglibdir
54 %{!?_without_dietlibc:BuildRequires:    dietlibc >= 0:0.25}
55 %{!?_without_xalan:BuildRequires:       xalan-j}
56
57 %package lib
58 Summary:                Dynamic libraries for util-vserver
59 Group:                  System Environment/Libraries
60
61 %package core
62 Summary:                The core-utilities for util-vserver
63 Group:                  Applications/System
64 Requires:               util-linux
65
66 %package build
67 Summary:                Tools which can be used to build vservers
68 Group:                  Applications/System
69 Requires:               rpm wget binutils tar e2fsprogs
70 Requires:               %name = %version-%release
71 Requires(pre):          %confdir
72 Requires(postun):       %confdir
73
74 %package sysv
75 Summary:                SysV-initscripts for vserver
76 Group:                  System Environment/Base
77 Provides:               init(%name) = sysv
78 Requires:               make diffutils
79 Requires:               initscripts
80 Requires:               %name = %version-%release
81 Requires(post):         %chkconfig
82 Requires(preun):        %chkconfig
83 Requires(pre):          %_initrddir %pkglibdir
84 requires(postun):       %_initrddir %pkglibdir
85
86 %package legacy
87 Summary:                Legacy utilities for util-vserver
88 Group:                  Applications/System
89 Requires:               %name = %version-%release
90 Requires(post):         %chkconfig
91 Requires(preun):        %chkconfig
92 Requires(pre):          %_initrddir %pkglibdir
93 requires(postun):       %_initrddir %pkglibdir
94
95 %package devel
96 Summary:                Header-files and libraries needed to develop vserver based applications
97 Group:                  Development/Libraries
98 Requires:               pkgconfig
99 Requires:               %name-lib = %version-%release
100
101 %package python
102 Summary:                Python modules for manipulating vservers
103 Group:                  Applications/System
104 Requires:               python util-python
105 Obsoletes:              util-vserver-py23 resman
106
107
108 %description
109 util-vserver provides the components and a framework to setup virtual
110 servers.  A virtual server runs inside a linux server. It is nevertheless
111 highly independent. As such, you can run various services with normal
112 configuration. The various vservers can't interact with each other and
113 can't interact with services in the main server.
114
115 This requires a special kernel supporting the new new_s_context and
116 set_ipv4root system call.
117
118 %description lib
119 util-vserver provides the components and a framework to setup virtual
120 servers.  A virtual server runs inside a linux server. It is nevertheless
121 highly independent. As such, you can run various services with normal
122 configuration. The various vservers can't interact with each other and
123 can't interact with services in the main server.
124
125 This package contains the shared libraries needed by all other
126 'util-vserver' subpackages.
127
128 %description core
129 util-vserver provides the components and a framework to setup virtual
130 servers.  A virtual server runs inside a linux server. It is nevertheless
131 highly independent. As such, you can run various services with normal
132 configuration. The various vservers can't interact with each other and
133 can't interact with services in the main server.
134
135 This package contains utilities which are required to communicate with
136 the Linux-Vserver enabled kernel.
137
138
139 %description build
140 util-vserver provides the components and a framework to setup virtual
141 servers.  A virtual server runs inside a linux server. It is nevertheless
142 highly independent. As such, you can run various services with normal
143 configuration. The various vservers can't interact with each other and
144 can't interact with services in the main server.
145
146 This package contains utilities which assist in building Vservers.
147
148 %description sysv
149 util-vserver provides the components and a framework to setup virtual
150 servers.  A virtual server runs inside a linux server. It is nevertheless
151 highly independent. As such, you can run various services with normal
152 configuration. The various vservers can't interact with each other and
153 can't interact with services in the main server.
154
155 This package contains the SysV initscripts which start and stop
156 VServers and related tools.
157
158
159 %description legacy
160 util-vserver provides the components and a framework to setup virtual
161 servers.  A virtual server runs inside a linux server. It is nevertheless
162 highly independent. As such, you can run various services with normal
163 configuration. The various vservers can't interact with each other and
164 can't interact with services in the main server.
165
166 This package contains the tools which are needed to work with VServers
167 having an old-style configuration.
168
169
170 %description devel
171 util-vserver provides the components and a framework to setup virtual
172 servers.  A virtual server runs inside a linux server. It is nevertheless
173 highly independent. As such, you can run various services with normal
174 configuration. The various vservers can't interact with each other and
175 can't interact with services in the main server.
176
177 This package contains header files and libraries which are needed to
178 develop VServer related applications.
179
180
181 %description python
182 Python modules for manipulating vservers.  Provides a superset of the
183 functionality of the vserver script (at least will do in the future),
184 but more readily accessible from Python code.
185
186
187 %prep
188 %setup -q
189
190 aclocal -I m4
191 autoconf
192 automake --add-missing
193
194 %build
195 %configure --with-initrddir=%_initrddir --enable-release \
196            %{?_without_dietlibc:--disable-dietlibc}
197
198 %__make %{?_smp_mflags} all
199 %__make %{?_smp_mflags} doc
200
201 %__make -C python
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 %__make DESTDIR="$RPM_BUILD_ROOT" install install-distribution
206
207 rm -f $RPM_BUILD_ROOT/%_libdir/*.la
208
209 MANIFEST_CONFIG='%config' \
210 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
211 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
212
213 # install python bindings
214 %__make -C python DESTDIR="$PWD/tmp" install
215 install -d $RPM_BUILD_ROOT/%{_datadir}/%{name}
216 install tmp/usr/lib/python*/site-packages/*.{py,so} $RPM_BUILD_ROOT/%{_datadir}/%{name}/
217 install -D -m 755 python/bwlimit $RPM_BUILD_ROOT/%{_sbindir}/bwlimit
218
219
220 %check || :
221 #%__make check
222
223
224 %clean
225 rm -rf $RPM_BUILD_ROOT
226
227
228 %post
229 test -d /vservers      || mkdir -m0000 /vservers
230 test -d /vservers/.pkg || mkdir -m0755 /vservers/.pkg
231
232 f="%confdefaultdir/vdirbase"; test -L "$f" -o -e "$f" || ln -s /vservers                        "$f"
233 f="%confdefaultdir/run.rev";  test -L "$f" -o -e "$f" || ln -s %_localstatedir/run/vservers.rev "$f"
234
235 %_sbindir/setattr --barrier /vservers || :
236
237 # add /bin/vsh to list of secure shells
238 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
239     echo /bin/vsh >> /etc/shells
240 fi
241
242
243 %postun
244 # 0 = erase, 1 = upgrade
245 if [ "$1" = 0 ] ; then
246     perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
247 fi
248
249
250 %post   lib -p /sbin/ldconfig
251 %postun lib -p /sbin/ldconfig
252
253
254 %post sysv
255 #%chkconfig --add vservers-default
256 #%chkconfig --add vprocunhide
257 # PlanetLab Node Manager takes care of starting and stopping VServers
258 %chkconfig --del vservers-default
259 # PlanetLab does not require /proc security
260 %chkconfig --del vprocunhide
261
262 %preun sysv
263 #test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
264
265 #test "$1" != 0 || %chkconfig --del vprocunhide
266 #test "$1" != 0 || %chkconfig --del vservers-default
267
268
269 %postun sysv
270 #test "$1" = 0  || %_initrddir/vprocunhide condrestart >/dev/null || :
271
272
273 %triggerin build -- fedora-release
274 function copy()
275 {
276     base=$1
277     shift
278
279     for i; do
280         test -r "$i" || continue
281
282         target=%confdir/.distributions/.common/pubkeys/$base-$(basename "$i")
283         cp -a "$i" "$target"
284     done
285 }
286 copy fedora /usr/share/doc/fedora-release-*/RPM-GPG-*
287 copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
288
289
290 %preun build
291 test "$1" != 0 || rm -f %confdir/.distributions/.common/pubkeys/fedora-*
292
293
294 ## Temporary workaround to remove old v_* files; it will conflict
295 ## somehow with the -legacy package but can be fixed by reinstalling
296 ## this package.
297 ## TODO: remove me in the final .spec file
298 %define v_services      httpd named portmap sendmail smb sshd xinetd gated
299 %triggerun sysv -- util-vserver-sysv < 0.30.198
300 for i in %v_services; do
301         %chkconfig --del v_$i || :
302 done
303
304
305 %post legacy
306 # PlanetLab Node Manager takes care of starting and stopping VServers
307 #%chkconfig --add rebootmgr
308 #%chkconfig --add vservers-legacy
309
310 # PlanetLab does not require these legacy services
311 #for i in %v_services; do
312 #       %chkconfig --add v_$i
313 #done
314
315
316 %preun legacy
317 #test "$1" != 0 || %_initrddir/rebootmgr   stop &>/dev/null || :
318
319 #test "$1" != 0 || for i in %v_services; do
320 #       %chkconfig --del v_$i
321 #done
322
323 #test "$1" != 0 || %chkconfig --del rebootmgr
324 #test "$1" != 0 || %chkconfig --del vservers-legacy
325
326 %postun legacy
327 #test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
328
329
330 %files -f %name-base.list
331 %defattr(-,root,root,-)
332 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
333 %doc doc/*.html doc/*.css
334 /sbin/vshelper
335 %dir %confdir
336 %dir %confdefaultdir
337 %dir %confdefaultdir/apps
338 %dir %confdefaultdir/files
339 %dir %pkglibdir/defaults
340 %ghost %confdefaultdir/vdirbase
341 %ghost %confdefaultdir/run.rev
342
343 %dir %_localstatedir/run/vservers
344 %dir %_localstatedir/run/vservers.rev
345 %dir %_localstatedir/run/vshelper
346
347
348 %files lib -f %name-lib.list
349 %files sysv -f %name-sysv.list
350
351
352 %files core -f %name-core.list
353 %defattr(-,root,root,-)
354 %dir %pkglibdir
355
356
357 %files build -f %name-build.list
358 %defattr(-,root,root,-)
359 %doc contrib/yum*.patch
360 %dir %confdir/.distributions
361 %dir %confdir/.distributions/*
362 %dir %confdir/.distributions/*/apt
363 %dir %confdir/.distributions/.common
364 %dir %confdir/.distributions/.common/pubkeys
365 %dir %confdefaultdir/apps/vunify
366 %dir %confdefaultdir/apps/vunify/hash
367
368
369 %files legacy -f %name-legacy.list
370 %defattr(-,root,root,-)
371 %dir %pkglibdir/legacy
372
373
374 %files devel -f %name-devel.list
375 %defattr(-,root,root,-)
376 %doc lib/apidoc/latex/refman.pdf
377 %doc lib/apidoc/html
378
379
380 %post python
381 pushd %{_datadir}/%{name} >/dev/null
382
383 # Byte compile and install modules
384 py_modules=
385 for file in *.py ; do
386     if [ -n "$py_modules" ] ; then
387         py_modules="$py_modules,"
388     fi
389     py_modules="$py_modules '${file%*.py}'"
390 done
391 %define setup %{__python} -c "from distutils.core import setup; setup(py_modules=[$py_modules])"
392 %{setup} build
393 %{setup} install
394
395 # Install the prebuilt extensions by hand
396 python_sitelib=$(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
397 install -D -m 755 *.so "$python_sitelib"/
398
399 popd
400
401
402 %triggerpostun python -- util-vserver-python, util-vserver-py23
403 # RPMs get upgraded by installing the new one, then uninstalling the
404 # old one. Since we no longer own the byte-compiled modules, they may
405 # be removed right after we create them in %post if we are upgraded
406 # from a version that did own them at one point. This section should
407 # be removed once all packages have been upgraded to at least this
408 # version.
409 pushd %{_datadir}/%{name} >/dev/null
410
411 # Byte compile and install modules
412 py_modules=
413 for file in *.py ; do
414     if [ -n "$py_modules" ] ; then
415         py_modules="$py_modules,"
416     fi
417     py_modules="$py_modules '${file%*.py}'"
418 done
419 %define setup %{__python} -c "from distutils.core import setup; setup(py_modules=[$py_modules])"
420 %{setup} build
421 %{setup} install
422
423 # Install the prebuilt extensions by hand
424 python_sitelib=$(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
425 install -D -m 755 *.so "$python_sitelib"/
426
427 popd
428
429
430 %preun python
431 # 0 = erase, 1 = upgrade
432 if [ $1 -eq 0 ] ; then
433     python_sitelib=$(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
434     pushd %{_datadir}/%{name} >/dev/null
435     for file in *.py *.so ; do
436         rm -f "$python_sitelib"/${file}*
437     done
438     popd
439 fi
440
441
442 %files python
443 %{_datadir}/%{name}
444 %{_sbindir}/bwlimit
445
446
447 %changelog
448 * Fri Feb 17 2006 Steve Muir <smuir@cs.princeton.edu>
449 - add support for setting guaranteed CPU share flag in rspec
450
451 * Fri Jan 13 2006 Steve Muir <smuir@cs.princeton.edu>
452 - fix bug in python/vserverimpl.c where attempting to adjust CPU share
453   for a context that didn't exist would cause an error (it should be a
454   safe no-op)
455
456 * Fri Dec  2 2005 Steve Muir <smuir@cs.princeton.edu>
457 - fix bugs in python/vserverimpl.c where exceptions were not raised when
458   they should be and thus occured later at unexpected times
459 - add support for stopping a vserver
460
461 * Wed Nov  9 2005 Steve Muir <smuir@cs.princeton.edu>
462 - add support for removing resource limits e.g., when a slice is deleted
463
464 * Mon Nov  7 2005 Steve Muir <smuir@cs.princeton.edu>
465 - fix file descriptor leak in vduimpl
466 - clean up handling of network parameters
467 - don't rely upon /etc/vservers/foo.conf to initialise vserver object
468
469 * Wed Nov  2 2005 Steve Muir <smuir@cs.princeton.edu>
470 - fix Python modules to handling scheduling parameters correctly
471
472 * Fri Oct 28 2005 Steve Muir <smuir@cs.princeton.edu>
473 - raise exception about being over disk limit after setting usage values
474
475 * Fri Oct  7 2005 Steve Muir <smuir@cs.princeton.edu>
476 - create common function to be used for entering a vserver and applying
477   resource limits
478
479 * Thu Aug 21 2005 Mark Huang <mlhuang@cs.princeton.edu>
480 - restore build of python modules
481
482 * Sat Aug 20 2005 Mark Huang <mlhuang@cs.princeton.edu>
483 - upgrade to util-vserver-0.30.208
484 - forward-port vbuild and legacy support until we can find a suitable
485   replacement
486 - make vsh use new vc_create_context() call
487
488 * Thu Jul 28 2005 Steve Muir <smuir@cs.princeton.edu>
489 - add support for static vserver IDs to vuseradd and vuserdel
490
491 * Thu Jul 21 2005 Steve Muir <smuir@cs.princeton.edu>
492 - add bwlimit and cpulimit modules
493
494 * Fri Jul 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-1
495 - require the -lib subpackage by -devel
496 - copy GPG keys from /etc/pki/rpm-gpg/
497
498 * Mon Jun 20 2005 Steve Muir <smuir@cs.princeton.edu>
499 - import Marc's vdu implementation
500
501 * Wed Jun 15 2005 Steve Muir <smuir@cs.princeton.edu>
502 - 'vserver-init start' functionality subsumed by Node Manager
503
504 * Thu Jun 02 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
505 - Fixed vlimit command
506
507 * Wed May 25 2005 Steve Muir <smuir@cs.princeton.edu>
508 - add Python modules for manipulating vservers
509
510 * Fri Apr 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.206-1
511 - added patches to make yum work in chroot environments
512 - version 0.30.206
513
514 * Thu Apr  7 2005 Steve Muir <smuir@cs.princeton.edu>
515 - vuserdel changes: don't shutdown vserver, just kill all processes;
516   unmount all mountpoints in vserver before deleting
517
518 * Thu Mar 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.205-0
519 - added some %%descriptions
520 - copy GPG keys from the system into the confdir
521 - buildrequire dietlibc-0.25
522 - BuildRequire beecrypt-devel
523 - cleanups
524 - use %%global instead of %%define
525 - removed 'run.rev' as a vserver-local variable and made it a system-wide setting
526
527 * Wed Jan 26 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.198-0.3
528 - updated BuildRequires:
529 - use 'setattr --barrier' instead of 'chattr +t' in the %%post scriptlet
530 - moved the v_* initscripts to legacy
531 - do not ship the /vservers directory itself; as it is immutable, the
532   extraction will fail else
533
534 * Fri Nov 19 2004 Mark Huang <mlhuang@cs.princeton.edu>
535 - vcached no longer runs as a daemon
536 - do not restart vservers when package is upgraded
537
538 * Wed Nov 17 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-6.planetlab
539 + planetlab-3_0-rc4
540 - PL2445
541 - Both vcached and vuseradd now print a warning message when vbuild
542   succeeds but the resulting new vserver image is smaller in size than
543   the vserver-reference image.
544 - vuseradd: clean up some more junk on failure
545
546 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-5.planetlab
547 + planetlab-3_0-rc3
548 - PL3026: This is the upgraded version of vdu that maintains an
549   internal hash table of files with a nlink count > 1.  Only if vdu
550   sees all hard links to a particular inode does it add its size and
551   block count to the total.
552
553 * Fri Nov 12 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-4.planetlab
554 - PL2445 Use -b option to du to avoid rounding errors.
555
556 * Sat Nov  6 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-3.planetlab
557 + planetlab-3_0-rc2
558 - don't create the symbolic link /home/slice/.ssh, this is not how
559   pl_sshd works
560
561 * Mon Oct 11 2004 Marc E. Fiuczynski <mef@cs.princeton.edu>
562 - added vsh
563
564 * Thu Sep  9 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.194-0
565 - documented switches for 'rpmbuild'
566
567 * Wed Aug 11 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.29-1.planetlab
568 - initial PlanetLab 3.0 build.
569
570 * Wed May 26 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.215-0
571 - (re)added the MANIFEST_* variables which were lost some time ago;
572   this will preserve %%config files...
573
574 * Mon Mar 15 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.202-0
575 - use file-list for sysv scripts also
576
577 * Sat Mar  6 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.198-0
578 - added vprocunhide-service support
579 - added doxygen support
580 - updated Requires:
581
582 * Wed Oct  1 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.23.5-0
583 - Initial build.