%changelog and Requires.
[util-vserver.git] / util-vserver.spec
1 # $Id: util-vserver.spec.in 2482 2007-01-29 23:37:07Z dhozac $
2
3 ## This package understands the following switches:
4 ## --without dietlibc        ...   disable usage of dietlibc
5 ## --with xalan              ...   require/use the xalan xslt processor
6 ## --without doc             ...   disable doc generation
7 ## --with legacy             ...   enable the legacy APIs
8
9 %global confdir         %_sysconfdir/vservers
10 %global confdefaultdir  %confdir/.defaults
11 %global pkglibdir       %_libdir/%name
12 %global chkconfig       /sbin/chkconfig
13
14 %global _localstatedir  %_var
15
16 %global ver             %( echo 0.30.213 | sed 's/-.*//' )
17 %global subver          %( s=`echo 0.30.213 | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
18 %global fullver         0.30.213
19
20
21 %define name util-vserver
22 %define version 0.30.213
23 %{!?release_func:%global release_func() 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}}
24
25 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
26
27 %define _without_dietlibc 1
28 %define _without_xalan 1
29
30 # don't build debuginfo RPM
31 %define debug_package %{nil}
32
33 Vendor: PlanetLab
34 Packager: PlanetLab Central <support@planet-lab.org>
35 Distribution: PlanetLab 3.0
36 URL: http://cvs.planet-lab.org/cvs/util-vserver
37
38 Summary:        Linux virtual server utilities
39 Name:           util-vserver
40 Version:        %ver
41 Release:        %release_func 0%subver
42 License:        GPL
43 Group:          System Environment/Base
44 #URL:           http://savannah.nongnu.org/projects/util-vserver/
45 Source0:        http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%version.tar.bz2
46 #Source1:       http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%version.tar.bz2.asc
47 BuildRoot:      %_tmppath/%name-%version-%release-root
48 Requires:       init(%name)
49 Requires:       %name-core = %version-%release
50 Requires:       %name-lib  = %version-%release
51 Requires:       diffutils mktemp sed
52 Provides:       vserver = %version-%release
53 Obsoletes:      vserver < %version
54 BuildRequires:  mount vconfig gawk iproute iptables
55 BuildRequires:  gcc-c++ wget which diffutils
56 BuildRequires:  e2fsprogs-devel beecrypt-devel
57 %{!?_without_doc:BuildRequires: doxygen tetex-latex}
58 Requires(post):         %name-core
59 Requires(pre):          %pkglibdir
60 Requires(postun):       %pkglibdir
61 %{!?_without_dietlibc:BuildRequires:    dietlibc >= 0:0.25}
62 %{?_with_xalan:BuildRequires:   xalan-j}
63
64 %package lib
65 Summary:                Dynamic libraries for util-vserver
66 Group:                  System Environment/Libraries
67
68 %package core
69 Summary:                The core-utilities for util-vserver
70 Group:                  Applications/System
71 Requires:               util-linux
72
73 %package build
74 Summary:                Tools which can be used to build vservers
75 Group:                  Applications/System
76 Requires:               rpm wget tar
77 Requires:               %name = %version-%release
78 Requires(pre):          %confdir
79 Requires(postun):       %confdir
80 Requires(post):         %name-core
81
82 %package sysv
83 Summary:                SysV-initscripts for vserver
84 Group:                  System Environment/Base
85 Provides:               init(%name) = sysv
86 Requires:               make diffutils
87 Requires:               initscripts
88 Requires:               %name = %version-%release
89 Requires(post):         %chkconfig
90 Requires(preun):        %chkconfig
91 Requires(pre):          %_initrddir %pkglibdir
92 requires(postun):       %_initrddir %pkglibdir
93
94 %package legacy
95 Summary:                Legacy utilities for util-vserver
96 Group:                  Applications/System
97 Requires:               %name = %version-%release
98 Requires(post):         %chkconfig
99 Requires(preun):        %chkconfig
100 Requires(pre):          %_initrddir %pkglibdir
101 requires(postun):       %_initrddir %pkglibdir
102
103 %package devel
104 Summary:                Header-files and libraries needed to develop vserver based applications
105 Group:                  Development/Libraries
106 Requires:               pkgconfig
107 Requires:               %name-lib = %version-%release
108
109 %package python
110 Summary:                Python modules for manipulating vservers
111 Group:                  Applications/System
112 Requires:               python
113 Obsoletes:              util-vserver-py23 resman
114
115
116 %description
117 util-vserver provides the components and a framework to setup virtual
118 servers.  A virtual server runs inside a linux server. It is nevertheless
119 highly independent. As such, you can run various services with normal
120 configuration. The various vservers can't interact with each other and
121 can't interact with services in the main server.
122
123 This requires a special kernel supporting the new new_s_context and
124 set_ipv4root system call.
125
126 %description lib
127 util-vserver provides the components and a framework to setup virtual
128 servers.  A virtual server runs inside a linux server. It is nevertheless
129 highly independent. As such, you can run various services with normal
130 configuration. The various vservers can't interact with each other and
131 can't interact with services in the main server.
132
133 This package contains the shared libraries needed by all other
134 'util-vserver' subpackages.
135
136 %description core
137 util-vserver provides the components and a framework to setup virtual
138 servers.  A virtual server runs inside a linux server. It is nevertheless
139 highly independent. As such, you can run various services with normal
140 configuration. The various vservers can't interact with each other and
141 can't interact with services in the main server.
142
143 This package contains utilities which are required to communicate with
144 the Linux-Vserver enabled kernel.
145
146
147 %description build
148 util-vserver provides the components and a framework to setup virtual
149 servers.  A virtual server runs inside a linux server. It is nevertheless
150 highly independent. As such, you can run various services with normal
151 configuration. The various vservers can't interact with each other and
152 can't interact with services in the main server.
153
154 This package contains utilities which assist in building Vservers.
155
156 %description sysv
157 util-vserver provides the components and a framework to setup virtual
158 servers.  A virtual server runs inside a linux server. It is nevertheless
159 highly independent. As such, you can run various services with normal
160 configuration. The various vservers can't interact with each other and
161 can't interact with services in the main server.
162
163 This package contains the SysV initscripts which start and stop
164 VServers and related tools.
165
166
167 %description legacy
168 util-vserver provides the components and a framework to setup virtual
169 servers.  A virtual server runs inside a linux server. It is nevertheless
170 highly independent. As such, you can run various services with normal
171 configuration. The various vservers can't interact with each other and
172 can't interact with services in the main server.
173
174 This package contains the tools which are needed to work with VServers
175 having an old-style configuration.
176
177
178 %description devel
179 util-vserver provides the components and a framework to setup virtual
180 servers.  A virtual server runs inside a linux server. It is nevertheless
181 highly independent. As such, you can run various services with normal
182 configuration. The various vservers can't interact with each other and
183 can't interact with services in the main server.
184
185 This package contains header files and libraries which are needed to
186 develop VServer related applications.
187
188
189 %description python
190 Python modules for manipulating vservers.  Provides a superset of the
191 functionality of the vserver script (at least will do in the future),
192 but more readily accessible from Python code.
193
194
195 %prep
196 %setup -q -n %name-%fullver
197
198 aclocal -I m4
199 autoconf
200 automake --add-missing
201
202 %build
203 %configure --with-initrddir=%_initrddir --enable-release \
204            %{?_without_dietlibc:--disable-dietlibc} \
205            %{!?_without_legacy:--enable-apis=NOLEGACY} \
206            --with-initscripts=sysv
207
208 %__make %{?_smp_mflags} all
209 %{!?_without_doc:%__make %{?_smp_mflags} doc}
210
211 %install
212 rm -rf $RPM_BUILD_ROOT
213 %__make DESTDIR="$RPM_BUILD_ROOT" install install-distribution
214
215 rm -f $RPM_BUILD_ROOT/%_libdir/*.la $RPM_BUILD_ROOT%{python_sitearch}/*.{la,a}
216
217 MANIFEST_CONFIG='%config' \
218 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
219 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
220
221 # Generate file list for python package
222 find "%{buildroot}" -name '*.py' | { while read FILE; do
223         f="${FILE#%{buildroot}}"
224         echo "${f}"
225         echo %%ghost "${f}c"
226         echo %%ghost "${f}o"
227 done } > %name-python.list
228
229
230 %check || :
231 #%__make check
232
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237
238 %post
239 test -d /vservers      || mkdir -m0000 /vservers
240 test -d /vservers/.pkg || mkdir -m0755 /vservers/.pkg
241
242 f="%confdefaultdir/vdirbase";  test -L "$f" -o -e "$f" || ln -s /vservers                        "$f"
243 f="%confdefaultdir/run.rev";   test -L "$f" -o -e "$f" || ln -s %_localstatedir/run/vservers.rev "$f"
244 f="%confdefaultdir/cachebase"; test -L "$f" -o -e "$f" || ln -s %_localstatedir/cache/vservers   "$f"
245
246 %_sbindir/setattr --barrier /vservers /vservers/.pkg || :
247
248
249 %preun
250 test "$1" != 0 || rm -rf %_localstatedir/cache/vservers/* 2>/dev/null || :
251
252 # add /bin/vsh to list of secure shells
253 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
254     echo /bin/vsh >> /etc/shells
255 fi
256
257
258 %postun
259 # 0 = erase, 1 = upgrade
260 if [ "$1" = 0 ] ; then
261     perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
262 fi
263
264
265 %post   lib -p /sbin/ldconfig
266 %postun lib -p /sbin/ldconfig
267
268
269 %post sysv
270 #%chkconfig --add vservers-default
271 #%chkconfig --add vprocunhide
272 # PlanetLab Node Manager takes care of starting and stopping VServers
273 %chkconfig --del vservers-default
274 %chkconfig --del util-vserver
275 # PlanetLab does not require /proc security
276 %chkconfig --del vprocunhide
277 # vip6-autod handles IPv6 auto-assignments
278 %chkconfig --add vip6-autod
279
280
281 %preun sysv
282 #test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
283
284 #test "$1" != 0 || %chkconfig --del vprocunhide
285 #test "$1" != 0 || %chkconfig --del vservers-default
286 #test "$1" != 0 || %chkconfig --del util-vserver
287 test "$1" != 0 || %chkconfig --del vip6-autod
288
289
290 %postun sysv
291 #test "$1" = 0  || %_initrddir/vprocunhide condrestart >/dev/null || :
292
293
294 %triggerin build -- fedora-release, centos-release
295 function copy()
296 {
297     base=$1
298     shift
299
300     for i; do
301         test -r "$i" || continue
302
303         target=%confdir/.distributions/.common/pubkeys/$base-$(basename "$i")
304         cp -a "$i" "$target"
305     done
306 }
307 copy fedora /usr/share/doc/fedora-release-*/RPM-GPG-*
308 copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
309 copy centos /usr/share/doc/centos-*/RPM-GPG-KEY-*
310
311
312 %post build
313 test -d /vservers/.hash || mkdir -m0700 /vservers/.hash
314
315 f="%confdefaultdir/apps/vunify/hash"; test -e "$f"/method -o -e "$f"/00 || \
316         ln -s /vservers/.hash "$f"/00
317
318 %_sbindir/setattr --barrier /vservers/.hash || :
319
320
321 %preun build
322 test "$1" != 0 || rm -f %confdir/.distributions/.common/pubkeys/fedora-*
323
324
325 ## Temporary workaround to remove old v_* files; it will conflict
326 ## somehow with the -legacy package but can be fixed by reinstalling
327 ## this package.
328 ## TODO: remove me in the final .spec file
329 %define v_services      httpd named portmap sendmail smb sshd xinetd gated
330 %triggerun sysv -- util-vserver-sysv < 0.30.198
331 for i in %v_services; do
332         %chkconfig --del v_$i || :
333 done
334
335
336 %post legacy
337 # PlanetLab Node Manager takes care of starting and stopping VServers
338 #%chkconfig --add rebootmgr
339 #%chkconfig --add vservers-legacy
340
341 # PlanetLab does not require these legacy services
342 #for i in %v_services; do
343 #       %chkconfig --add v_$i
344 #done
345
346
347 %preun legacy
348 #test "$1" != 0 || %_initrddir/rebootmgr   stop &>/dev/null || :
349
350 #test "$1" != 0 || for i in %v_services; do
351 #       %chkconfig --del v_$i
352 #done
353
354 #test "$1" != 0 || %chkconfig --del rebootmgr
355 #test "$1" != 0 || %chkconfig --del vservers-legacy
356
357 %postun legacy
358 #test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
359
360
361 %files -f %name-base.list
362 %defattr(-,root,root,-)
363 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
364 %doc doc/*.html doc/*.css
365 /sbin/vshelper
366 %dir %confdir
367 %dir %confdefaultdir
368 %dir %confdefaultdir/apps
369 %dir %confdefaultdir/files
370 %dir %pkglibdir/defaults
371 %ghost %confdefaultdir/cachebase
372 %ghost %confdefaultdir/vdirbase
373 %ghost %confdefaultdir/run.rev
374
375 %dir %_localstatedir/cache/vservers
376 %dir %_localstatedir/run/vservers
377 %dir %_localstatedir/run/vservers.rev
378 %dir %_localstatedir/run/vshelper
379
380
381 %files lib -f %name-lib.list
382 %files sysv -f %name-sysv.list
383
384
385 %files core -f %name-core.list
386 %defattr(-,root,root,-)
387 %dir %pkglibdir
388
389
390 %files build -f %name-build.list
391 %defattr(-,root,root,-)
392 %doc contrib/yum*.patch
393 %dir %confdir/.distributions
394 %dir %confdir/.distributions/*
395 %dir %confdir/.distributions/*/apt
396 %dir %confdir/.distributions/.common
397 %dir %confdir/.distributions/.common/pubkeys
398 %dir %confdefaultdir/apps/vunify
399 %dir %confdefaultdir/apps/vunify/hash
400
401
402 %files legacy -f %name-legacy.list
403 %defattr(-,root,root,-)
404 %dir %pkglibdir/legacy
405
406
407 %files devel -f %name-devel.list
408 %defattr(-,root,root,-)
409 %{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
410 %{!?_without_doc:%doc lib/apidoc/html}
411
412
413 %files python -f %name-python.list
414 %{_sbindir}/bwlimit
415 %{_sbindir}/disklimit
416 %{python_sitearch}/vserverimpl.so
417
418
419 %changelog
420 * Wed Oct 03 2007 Daniel Hokka Zakrisson <daniel@hozac.com>
421 - build python code as part of the regular build process
422
423 * Mon Jul 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com>
424 - add vip6-autod
425
426 * Fri Dec 29 2006 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.213-0
427 - add --with legacy and --without doc switches
428 - add util-vserver initscript
429
430 * Fri Feb 17 2006 Steve Muir <smuir@cs.princeton.edu>
431 - add support for setting guaranteed CPU share flag in rspec
432
433 * Sun Jan 22 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.30.210-0
434 - do not require 'xalan' anymore by default
435 - removed 'Requires: apt'; apt-rpm is not maintained upstream anymore
436 - removed 'chattr' leftovers
437 - create the '/etc/vservers/.defaults/cachebase' symlink
438 - added /var/cache/vservers and the needed support
439 - set barrier attribute on /vservers/.pkg and /vservers/.hash
440 - added 'centos-release' to the list of packages in the copy-the-keys
441   trigger script
442 - create '/vservers/.hash' and add initial configuration for it
443
444 * Fri Jan 13 2006 Steve Muir <smuir@cs.princeton.edu>
445 - fix bug in python/vserverimpl.c where attempting to adjust CPU share
446   for a context that didn't exist would cause an error (it should be a
447   safe no-op)
448
449 * Fri Dec  2 2005 Steve Muir <smuir@cs.princeton.edu>
450 - fix bugs in python/vserverimpl.c where exceptions were not raised when
451   they should be and thus occured later at unexpected times
452 - add support for stopping a vserver
453
454 * Wed Nov  9 2005 Steve Muir <smuir@cs.princeton.edu>
455 - add support for removing resource limits e.g., when a slice is deleted
456
457 * Mon Nov  7 2005 Steve Muir <smuir@cs.princeton.edu>
458 - fix file descriptor leak in vduimpl
459 - clean up handling of network parameters
460 - don't rely upon /etc/vservers/foo.conf to initialise vserver object
461
462 * Wed Nov  2 2005 Steve Muir <smuir@cs.princeton.edu>
463 - fix Python modules to handling scheduling parameters correctly
464
465 * Sun Oct 30 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.209-0
466 - version 0.30.209
467 - copy centos keys
468
469 * Fri Oct 28 2005 Steve Muir <smuir@cs.princeton.edu>
470 - raise exception about being over disk limit after setting usage values
471
472 * Fri Oct  7 2005 Steve Muir <smuir@cs.princeton.edu>
473 - create common function to be used for entering a vserver and applying
474   resource limits
475
476 * Thu Aug 21 2005 Mark Huang <mlhuang@cs.princeton.edu>
477 - restore build of python modules
478
479 * Sat Aug 20 2005 Mark Huang <mlhuang@cs.princeton.edu>
480 - upgrade to util-vserver-0.30.208
481 - forward-port vbuild and legacy support until we can find a suitable
482   replacement
483 - make vsh use new vc_create_context() call
484
485 * Thu Jul 28 2005 Steve Muir <smuir@cs.princeton.edu>
486 - add support for static vserver IDs to vuseradd and vuserdel
487
488 * Thu Jul 21 2005 Steve Muir <smuir@cs.princeton.edu>
489 - add bwlimit and cpulimit modules
490
491 * Sat Jul 16 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-2
492 - updated URLs
493
494 * Fri Jul 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-1
495 - version 0.30.208
496 - require the -lib subpackage by -devel
497 - copy GPG keys from /etc/pki/rpm-gpg/
498
499 * Mon Jun 20 2005 Steve Muir <smuir@cs.princeton.edu>
500 - import Marc's vdu implementation
501
502 * Wed Jun 15 2005 Steve Muir <smuir@cs.princeton.edu>
503 - 'vserver-init start' functionality subsumed by Node Manager
504
505 * Thu Jun 02 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
506 - Fixed vlimit command
507
508 * Wed May 25 2005 Steve Muir <smuir@cs.princeton.edu>
509 - add Python modules for manipulating vservers
510
511 * Fri Apr 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.206-1
512 - added patches to make yum work in chroot environments
513 - version 0.30.206
514
515 * Thu Apr  7 2005 Steve Muir <smuir@cs.princeton.edu>
516 - vuserdel changes: don't shutdown vserver, just kill all processes;
517   unmount all mountpoints in vserver before deleting
518
519 * Thu Mar 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.205-0
520 - added some %%descriptions
521 - copy GPG keys from the system into the confdir
522 - buildrequire dietlibc-0.25
523 - BuildRequire beecrypt-devel
524 - cleanups
525 - use %%global instead of %%define
526 - removed 'run.rev' as a vserver-local variable and made it a system-wide setting
527
528 * Wed Jan 26 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.198-0.3
529 - updated BuildRequires:
530 - use 'setattr --barrier' instead of 'chattr +t' in the %%post scriptlet
531 - moved the v_* initscripts to legacy
532 - do not ship the /vservers directory itself; as it is immutable, the
533   extraction will fail else
534
535 * Fri Nov 19 2004 Mark Huang <mlhuang@cs.princeton.edu>
536 - vcached no longer runs as a daemon
537 - do not restart vservers when package is upgraded
538
539 * Wed Nov 17 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-6.planetlab
540 + planetlab-3_0-rc4
541 - PL2445
542 - Both vcached and vuseradd now print a warning message when vbuild
543   succeeds but the resulting new vserver image is smaller in size than
544   the vserver-reference image.
545 - vuseradd: clean up some more junk on failure
546
547 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-5.planetlab
548 + planetlab-3_0-rc3
549 - PL3026: This is the upgraded version of vdu that maintains an
550   internal hash table of files with a nlink count > 1.  Only if vdu
551   sees all hard links to a particular inode does it add its size and
552   block count to the total.
553
554 * Fri Nov 12 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-4.planetlab
555 - PL2445 Use -b option to du to avoid rounding errors.
556
557 * Sat Nov  6 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-3.planetlab
558 + planetlab-3_0-rc2
559 - don't create the symbolic link /home/slice/.ssh, this is not how
560   pl_sshd works
561
562 * Mon Oct 11 2004 Marc E. Fiuczynski <mef@cs.princeton.edu>
563 - added vsh
564
565 * Thu Sep  9 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.194-0
566 - documented switches for 'rpmbuild'
567
568 * Wed Aug 11 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.29-1.planetlab
569 - initial PlanetLab 3.0 build.
570
571 * Wed May 26 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.215-0
572 - (re)added the MANIFEST_* variables which were lost some time ago;
573   this will preserve %%config files...
574
575 * Mon Mar 15 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.202-0
576 - use file-list for sysv scripts also
577
578 * Sat Mar  6 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.198-0
579 - added vprocunhide-service support
580 - added doxygen support
581 - updated Requires:
582
583 * Wed Oct  1 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.23.5-0
584 - Initial build.