bump release
[util-vserver.git] / util-vserver.spec
index 284c9fc..7373d5b 100644 (file)
@@ -17,7 +17,7 @@
 
 %define name util-vserver
 %define version 0.30.208
-%define release 11%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release 15%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 %define _without_dietlibc 1
 %define _without_xalan 1
@@ -102,7 +102,7 @@ Requires:           %name-lib = %version-%release
 Summary:               Python modules for manipulating vservers
 Group:                 Applications/System
 Requires:              python util-python
-Obsoletes:             util-vserver-py23
+Obsoletes:             util-vserver-py23 resman
 
 
 %description
@@ -214,6 +214,7 @@ contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
 %__make -C python DESTDIR="$PWD/tmp" install
 install -d $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install tmp/usr/lib/python*/site-packages/*.{py,so} $RPM_BUILD_ROOT/%{_datadir}/%{name}/
+install -D -m 755 python/bwlimit $RPM_BUILD_ROOT/%{_sbindir}/bwlimit
 
 
 %check || :
@@ -398,6 +399,34 @@ install -D -m 755 *.so "$python_sitelib"/
 popd
 
 
+%triggerpostun python -- util-vserver-python, util-vserver-py23
+# RPMs get upgraded by installing the new one, then uninstalling the
+# old one. Since we no longer own the byte-compiled modules, they may
+# be removed right after we create them in %post if we are upgraded
+# from a version that did own them at one point. This section should
+# be removed once all packages have been upgraded to at least this
+# version.
+pushd %{_datadir}/%{name} >/dev/null
+
+# Byte compile and install modules
+py_modules=
+for file in *.py ; do
+    if [ -n "$py_modules" ] ; then
+       py_modules="$py_modules,"
+    fi
+    py_modules="$py_modules '${file%*.py}'"
+done
+%define setup %{__python} -c "from distutils.core import setup; setup(py_modules=[$py_modules])"
+%{setup} build
+%{setup} install
+
+# Install the prebuilt extensions by hand
+python_sitelib=$(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
+install -D -m 755 *.so "$python_sitelib"/
+
+popd
+
+
 %preun python
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
@@ -411,8 +440,8 @@ fi
 
 
 %files python
-%defattr(0644,root,root)
 %{_datadir}/%{name}
+%{_sbindir}/bwlimit
 
 
 %changelog