tweaks for rebuilding pre3004
[util-vserver.git] / util-vserver.spec
index 6e21ccd..9961d44 100644 (file)
 
 %global _localstatedir %_var
 
-%global fullver                0.30.216-pre2926
+%global fullver                0.30.216-pre3004
 %global ver            %( echo %fullver | sed 's/-.*//' )
 %global subver         %( s=`echo %fullver | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
+%global release                %( echo %subver | sed -e 's,\.,,' )
 
+%global _without_doc 1
 
 # Mandriva does funky stuff that break us.
 %if %{?mandriva_release:1}%{!?mandriva_release:0}
@@ -33,9 +35,6 @@
 %endif
 
 
-%global release pre2926
-#%{!?release_func:%global release_func() %1%{?dist}}
-
 Summary:       Linux virtual server utilities
 Name:          util-vserver
 Version:       %ver
@@ -206,11 +205,16 @@ Linux-VServer API from Python.
 
 
 %build
+# could not reproduce the same trick as for 2926 
+# see log for a843358da4e3f1e894dcf2efc5f5db22d5b4739f
+# 
+#make -f Makefile.svn
 %configure --with-initrddir=%_initrddir --enable-release \
            %{?_without_dietlibc:--disable-dietlibc} \
            %{?_with_legacy:--enable-apis=NOLEGACY} \
            --with-initscripts=sysv \
-           %{?_without_python:--without-python}
+           %{?_without_python:--without-python} \
+          --without-doc
 
 %__make %{?_smp_mflags} all
 %{!?_without_doc:%__make %{?_smp_mflags} doc}
@@ -345,8 +349,11 @@ test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
 
 %files -f %name-base.list
 %defattr(-,root,root,-)
-%doc AUTHORS COPYING ChangeLog NEWS README THANKS
-%doc doc/*.html doc/*.css
+# ChangeLog not in the svn tree, make is helpless to recreate...
+#%doc AUTHORS COPYING ChangeLog NEWS README THANKS
+%doc AUTHORS COPYING NEWS README THANKS
+#%doc doc/*.html doc/*.css
+%doc doc/*.css
 %dir %confdir
 %dir %confdefaultdir
 %dir %confdefaultdir/apps