ready for tagging
[util-vserver.git] / util-vserver.spec
index c0ba3cf..c0938a4 100644 (file)
@@ -1,4 +1,5 @@
-# $Id: util-vserver.spec.in 2482 2007-01-29 23:37:07Z dhozac $
+# $Id$
+%define url $URL$
 
 ## This package understands the following switches:
 ## --without dietlibc        ...   disable usage of dietlibc
 
 %global _localstatedir %_var
 
-%global ver            %( echo 0.30.213 | sed 's/-.*//' )
-%global subver         %( s=`echo 0.30.213 | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
-%global fullver                0.30.213
+%define name util-vserver
+%define version 0.30.214
+%define taglevel 1
 
+%global ver            %( echo %{version} | sed 's/-.*//' )
+%global subver         %( s=`echo %{version} | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
+%global fullver                %{version}
 
-%define name util-vserver
-%define version 0.30.213
-%{!?release_func:%global release_func() 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}}
+
+%{!?release_func:%global release_func() %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}}
 
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
@@ -32,8 +35,8 @@
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://cvs.planet-lab.org/cvs/util-vserver
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary:       Linux virtual server utilities
 Name:          util-vserver
@@ -222,6 +225,9 @@ contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
 find "%{buildroot}" -name '*.py' | { while read FILE; do
        f="${FILE#%{buildroot}}"
        echo "${f}"
+       # need to touch these files, as they are not produced on FC4 or below
+       touch ${FILE}c
+       touch ${FILE}o
        echo %%ghost "${f}c"
        echo %%ghost "${f}o"
 done } > %name-python.list
@@ -423,6 +429,10 @@ done
 * Mon Jul 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com>
 - add vip6-autod
 
+* Mon Jun 25 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.214-0
+- updated URLs
+- get rid of e2fsprogs requirement
+
 * Fri Dec 29 2006 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.213-0
 - add --with legacy and --without doc switches
 - add util-vserver initscript