fedora 13 repositories
[util-vserver.git] / util-vserver.spec
index 574c180..c618870 100644 (file)
 %global _localstatedir %_var
 
 %global fullver                0.30.216-pre2883
+%global modulever 0.30.216
 %global ver            %( echo %fullver | sed 's/-.*//' )
 %global subver         %( s=`echo %fullver | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
 
 # for module-tools
-%global module_version_varname fullver
-%global taglevel 0
+%global module_version_varname modulever
+%global taglevel 2
 
 %{!?release_func:%global release_func() %1%{?dist}}
 
@@ -36,6 +37,9 @@ Group:                System Environment/Base
 URL:           http://savannah.nongnu.org/projects/util-vserver/
 Source0:       http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%fullver.tar.bz2
 #Source1:      http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%fullver.tar.bz2.asc
+Patch1:                f12.patch
+Patch2:                remove-tmpfs.patch
+Patch3:                f13.patch
 BuildRoot:     %_tmppath/%name-%version-%release-root
 Requires:      init(%name)
 Requires:      %name-core = %version-%release
@@ -49,7 +53,7 @@ BuildRequires:        e2fsprogs-devel e2fsprogs
 %{!?_without_beecrypt:BuildRequires: beecrypt-devel}
 %{?_without_beecrypt:BuildRequires: nss-devel}
 BuildRequires: e2fsprogs
-#%%{!?_without_doc:BuildRequires:      doxygen tetex-latex}
+%{!?_without_doc:BuildRequires:        doxygen tetex-latex}
 %{!?_without_python:BuildRequires: python python-devel ctags}
 Requires(post):                %name-core
 Requires(pre):         %pkglibdir
@@ -193,7 +197,10 @@ Linux-VServer API from Python.
 
 %prep
 %setup -q -n %name-%fullver
-
+%patch1 -p0
+%patch2 -p1
+%patch3 -p1
+autoreconf -fi
 
 %build
 %configure --with-initrddir=%_initrddir --enable-release \
@@ -203,7 +210,7 @@ Linux-VServer API from Python.
            %{?_without_python:--without-python}
 
 %__make %{?_smp_mflags} all
-#%%{!?_without_doc:%__make %{?_smp_mflags} doc}
+%{!?_without_doc:%__make %{?_smp_mflags} doc}
 
 
 %install
@@ -249,7 +256,7 @@ test "$1" != 0 || rm -rf %_localstatedir/cache/vservers/* 2>/dev/null || :
 %chkconfig --add vprocunhide
 %chkconfig --add util-vserver
 %chkconfig util-vserver on
-
+service util-vserver restart
 
 %preun sysv
 test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
@@ -381,8 +388,8 @@ test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
 
 %files devel -f %name-devel.list
 %defattr(-,root,root,-)
-#%%{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
-#%%{!?_without_doc:%doc lib/apidoc/html}
+%{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
+%{!?_without_doc:%doc lib/apidoc/html}
 
 
 %files python
@@ -391,6 +398,11 @@ test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
 
 
 %changelog
+* Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-0.30.216-2
+- remove tmpfs mounted /tmp from fstab template
+
+* Tue May 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-0.30.216-1
+
 * Mon Jun 25 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.214-0
 - updated URLs
 - get rid of e2fsprogs requirement