Remove apt dependency
[util-vserver.git] / util-vserver.spec
index a108fe7..fe15ef6 100644 (file)
 
 %define name util-vserver
 %define version 0.30.208
-%define release 5.planetlab%{?date:.%{date}}
+%define release 10%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 %define _without_dietlibc 1
 %define _without_xalan 1
 
+# don't build debuginfo RPM
+%define debug_package %{nil}
+
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab 3.0
@@ -69,7 +72,8 @@ Requires(pre):                %confdir
 Requires(postun):      %confdir
 
 %ifarch %ix86
-Requires:              apt
+# Remove apt dependency, this is not available on Fedora Core
+# Requires:            apt
 %endif
 
 %package sysv
@@ -377,10 +381,26 @@ done
 
 %files python
 %defattr(0644,root,root)
-%_libdir/python2.4/site-packages/*
+%_libdir/python2.3/site-packages/*
 
 
 %changelog
+* Fri Feb 17 2006 Steve Muir <smuir@cs.princeton.edu>
+- add support for setting guaranteed CPU share flag in rspec
+
+* Fri Jan 13 2006 Steve Muir <smuir@cs.princeton.edu>
+- fix bug in python/vserverimpl.c where attempting to adjust CPU share
+  for a context that didn't exist would cause an error (it should be a
+  safe no-op)
+
+* Fri Dec  2 2005 Steve Muir <smuir@cs.princeton.edu>
+- fix bugs in python/vserverimpl.c where exceptions were not raised when
+  they should be and thus occured later at unexpected times
+- add support for stopping a vserver
+
+* Wed Nov  9 2005 Steve Muir <smuir@cs.princeton.edu>
+- add support for removing resource limits e.g., when a slice is deleted
+
 * Mon Nov  7 2005 Steve Muir <smuir@cs.princeton.edu>
 - fix file descriptor leak in vduimpl
 - clean up handling of network parameters