add -fPIC option to the C compiler, required in f31
[vsys.git] / vsyssh.spec
1 #
2 # Vsys shell - sliverland utility
3 #
4 # RPM spec file
5
6 %define name vsyssh
7 %define version 0.99
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys shell - a sliverland vsys client
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Libraries
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24
25 Source0: vsyssh-%{version}.tar.gz
26
27 %description
28 vsyssh is a utility designed to be installed in the slivers, a helper to ease the invokation of vsys scripts.
29
30 %prep 
31 #%setup -q -n vsys-%{version} 
32 %setup
33
34 %build
35 rm -rf $RPM_BUILD_ROOT
36 make -C vsyssh
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/bin
40 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 /usr/bin/vsyssh
48
49 %changelog
50 * Mon Jan 07 2019 Thierry <Parmentelat> - vsys-0.99-4
51 - building on fedora29 requires to tweak ocaml compile environment
52
53 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-3
54 - only cosmetic changes
55
56 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
57 - split the vsyssh package in a separate specfile
58 - so we can preinstall vsyssh in the sliver space
59
60 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
61 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
62 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
63
64 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
65 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
66 - git/master.
67
68 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
69 - fix build for f12
70
71 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
72 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
73  version of vsys.
74
75 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
76 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
77
78 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
79 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
80 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
81 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
82 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
83 - vsys-factory/bm_socket for more details.
84 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
85 - stability audit.
86 - * Version 0.95 (trunk) is the new development version.
87
88 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
89 - Tagging to force an update.
90
91 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
92
93 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
94
95 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
96
97 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
98 - Tagging a trivial fix.
99
100 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
101 - includes new portsummary script for CoMon
102
103 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
104 - trying to fix the taglevel relative to the branch name
105
106 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
107 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
108
109 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
110 - * Don't kill vsys twice on restarts, do it only once
111 - * Restart vsys following a reinstall
112
113 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
114 - Usability changes that are necessary for the stability of CoMon
115
116 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
117 - added patch to pl-ps needed by slicestat
118
119
120
121 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
122 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
123
124 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
125 - accept '-' in filenames also
126
127
128 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
129 - don't overwrite the config file that already exists.
130
131
132 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
133 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
134
135
136
137 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
138 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
139 - it to show up in all slices.
140
141
142
143 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
144 - Added a vsys script for CoMon.
145
146
147 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
148 - ignore non-existent directories after restart.
149
150
151 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
152 - added logrotate configuration to package.
153
154
155 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
156 - Added two new scripts for CoMon on 4.2
157
158
159 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
160
161 - Corrected directory that the script mounts to the correct one:
162 - /var/local/fprobe
163
164
165 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
166 - Pulling the latest changes for the 4.2rc2 release
167
168
169 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
170 - * daemonization, writing to a logfile, and saving the pid
171
172