take vsyssh rpm out of vsys specfile into new vsyssh.spec
[vsys.git] / vsys.spec
index f8fc812..ed6207d 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -34,20 +34,12 @@ invoke services installed by the PlanetLab administration. Slices invoke and
 interact with these services through fifo pipes. Services can be added and
 removed dynamically.
 
-%package -n vsyssh
-Summary: Vsys client
-Group: System Environment/Libraries
-
-%description -n vsyssh
-vsyssh is a simple shell to use vsys through.
-
 %prep
 %setup
 
 %build
 rm -rf $RPM_BUILD_ROOT
 make
-make -C vsyssh
 
 %install
 mkdir -p $RPM_BUILD_ROOT/usr/bin
@@ -57,7 +49,6 @@ mkdir -p $RPM_BUILD_ROOT/vsys
 cp -p vsys $RPM_BUILD_ROOT/usr/bin
 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
 cp -p vsys.conf $RPM_BUILD_ROOT/etc
-cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
 
 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
 
@@ -72,10 +63,6 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) /etc/vsys.conf
 %{_sysconfdir}/logrotate.d/vsys
 
-%files -n vsyssh
-%defattr(-,root,root,-)
-/usr/bin/vsyssh
-
 %post
 chkconfig --add vsys
 chkconfig vsys on