Aesthetic change
[vsys.git] / vsys.spec
index b877bd5..896e031 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -2,22 +2,17 @@
 # Vsys filesystem
 #
 # RPM spec file
-#
-# $Id$
-#
-
-%define url $URL$
 
 %define name vsys
 %define version 0.99
-%define taglevel 0
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: Vsys filesystem 
 Name: %{name}
@@ -29,7 +24,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 #Requires: 
 BuildRequires: inotify-tools-devel
 BuildRequires: ocaml
-BuildRequires: ocaml-docs
+BuildRequires: ocaml-ocamldoc
 
 Source0: vsys-%{version}.tar.gz
 
@@ -39,20 +34,12 @@ invoke services installed by the PlanetLab administration. Slices invoke and
 interact with these services through fifo pipes. Services can be added and
 removed dynamically.
 
-%package -n vsyssh
-Summary: Vsys client
-Group: System Environment/Libraries
-
-%description -n vsyssh
-vsyssh is a simple shell to use vsys through.
-
 %prep
 %setup
 
 %build
 rm -rf $RPM_BUILD_ROOT
 make
-make -C vsyssh
 
 %install
 mkdir -p $RPM_BUILD_ROOT/usr/bin
@@ -62,7 +49,6 @@ mkdir -p $RPM_BUILD_ROOT/vsys
 cp -p vsys $RPM_BUILD_ROOT/usr/bin
 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
 cp -p vsys.conf $RPM_BUILD_ROOT/etc
-cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
 
 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
 
@@ -77,10 +63,6 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) /etc/vsys.conf
 %{_sysconfdir}/logrotate.d/vsys
 
-%files -n vsyssh
-%defattr(-,root,root,-)
-/usr/bin/vsyssh
-
 %post
 chkconfig --add vsys
 chkconfig vsys on
@@ -91,6 +73,14 @@ fi
 %postun
 
 %changelog
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
+- split the vsyssh package in a separate specfile
+- so we can preinstall vsyssh in the sliver space
+
+* Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
+- vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
+- fix build dep to require ocaml-ocamldoc instead of ocaml-docs
+
 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
 - git/master.