Build a vsyssh package.
[vsys.git] / vsys.spec
index 567948c..b877bd5 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -9,7 +9,7 @@
 %define url $URL$
 
 %define name vsys
-%define version 0.95
+%define version 0.99
 %define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -39,34 +39,48 @@ invoke services installed by the PlanetLab administration. Slices invoke and
 interact with these services through fifo pipes. Services can be added and
 removed dynamically.
 
+%package -n vsyssh
+Summary: Vsys client
+Group: System Environment/Libraries
+
+%description -n vsyssh
+vsyssh is a simple shell to use vsys through.
+
 %prep
 %setup
 
 %build
 rm -rf $RPM_BUILD_ROOT
 make
+make -C vsyssh
 
 %install
 mkdir -p $RPM_BUILD_ROOT/usr/bin
 mkdir -p $RPM_BUILD_ROOT/etc/init.d
 mkdir -p $RPM_BUILD_ROOT/vsys
 #cp factory/* $RPM_BUILD_ROOT/vsys
-cp vsys $RPM_BUILD_ROOT/usr/bin
-cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
-cp vsys.conf $RPM_BUILD_ROOT/etc
+cp -p vsys $RPM_BUILD_ROOT/usr/bin
+cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
+cp -p vsys.conf $RPM_BUILD_ROOT/etc
+cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
 
-install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
+install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
+%defattr(-,root,root,-)
 /usr/bin/vsys
 /etc/init.d/vsys
 /vsys
 %config(noreplace) /etc/vsys.conf
 %{_sysconfdir}/logrotate.d/vsys
 
+%files -n vsyssh
+%defattr(-,root,root,-)
+/usr/bin/vsyssh
+
 %post
 chkconfig --add vsys
 chkconfig vsys on
@@ -77,6 +91,10 @@ fi
 %postun
 
 %changelog
+* Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
+- Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
+- git/master.
+
 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
 - fix build for f12