Build a vsyssh package.
[vsys.git] / vsys.spec
index 6e3e4aa..b877bd5 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -39,34 +39,48 @@ invoke services installed by the PlanetLab administration. Slices invoke and
 interact with these services through fifo pipes. Services can be added and
 removed dynamically.
 
+%package -n vsyssh
+Summary: Vsys client
+Group: System Environment/Libraries
+
+%description -n vsyssh
+vsyssh is a simple shell to use vsys through.
+
 %prep
 %setup
 
 %build
 rm -rf $RPM_BUILD_ROOT
 make
+make -C vsyssh
 
 %install
 mkdir -p $RPM_BUILD_ROOT/usr/bin
 mkdir -p $RPM_BUILD_ROOT/etc/init.d
 mkdir -p $RPM_BUILD_ROOT/vsys
 #cp factory/* $RPM_BUILD_ROOT/vsys
-cp vsys $RPM_BUILD_ROOT/usr/bin
-cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
-cp vsys.conf $RPM_BUILD_ROOT/etc
+cp -p vsys $RPM_BUILD_ROOT/usr/bin
+cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
+cp -p vsys.conf $RPM_BUILD_ROOT/etc
+cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
 
-install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
+install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
+%defattr(-,root,root,-)
 /usr/bin/vsys
 /etc/init.d/vsys
 /vsys
 %config(noreplace) /etc/vsys.conf
 %{_sysconfdir}/logrotate.d/vsys
 
+%files -n vsyssh
+%defattr(-,root,root,-)
+/usr/bin/vsyssh
+
 %post
 chkconfig --add vsys
 chkconfig vsys on
@@ -77,6 +91,30 @@ fi
 %postun
 
 %changelog
+* Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
+- Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
+- git/master.
+
+* Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
+- fix build for f12
+
+* Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
+- The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
+ version of vsys.
+
+* Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
+- Getting rid of factory scripts from the main vsys. They now live elsewhere.
+
+* Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
+- * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
+- script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
+- exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
+- do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
+- vsys-factory/bm_socket for more details.
+- * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
+- stability audit.
+- * Version 0.95 (trunk) is the new development version.
+
 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
 - Tagging to force an update.