add -fPIC option to the C compiler, required in f31
[vsys.git] / vsys.spec
index c8022b8..ebac2e3 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -2,34 +2,29 @@
 # Vsys filesystem
 #
 # RPM spec file
-#
-# $Id$
-#
-
-%define url $URL$
 
 %define name vsys
-%define version 0.9
-%define taglevel 5
+%define version 0.99
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
-Summary: Vsys filesystem 
+Summary: Vsys filesystem
 Name: %{name}
 Version: %{version}
 Release: %{release}
 License: GPL
 Group: System Environment/Kernel
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
-#Requires: 
+#Requires:
 BuildRequires: inotify-tools-devel
 BuildRequires: ocaml
-BuildRequires: ocaml-docs
+BuildRequires: ocaml-ocamldoc
 
 Source0: vsys-%{version}.tar.gz
 
@@ -44,6 +39,10 @@ removed dynamically.
 
 %build
 rm -rf $RPM_BUILD_ROOT
+# for fedora 29, that comes with a change in the ocaml language
+# picked that tip here:
+# https://github.com/HaxeFoundation/haxe/issues/6883
+export OCAMLPARAM="safe-string=0,_"
 make
 
 %install
@@ -51,16 +50,17 @@ mkdir -p $RPM_BUILD_ROOT/usr/bin
 mkdir -p $RPM_BUILD_ROOT/etc/init.d
 mkdir -p $RPM_BUILD_ROOT/vsys
 #cp factory/* $RPM_BUILD_ROOT/vsys
-cp vsys $RPM_BUILD_ROOT/usr/bin
-cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
-cp vsys.conf $RPM_BUILD_ROOT/etc
+cp -p vsys $RPM_BUILD_ROOT/usr/bin
+cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
+cp -p vsys.conf $RPM_BUILD_ROOT/etc
 
-install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
+install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
+%defattr(-,root,root,-)
 /usr/bin/vsys
 /etc/init.d/vsys
 /vsys
@@ -71,12 +71,30 @@ rm -rf $RPM_BUILD_ROOT
 chkconfig --add vsys
 chkconfig vsys on
 if [ "$PL_BOOTCD" != "1" ] ; then
-        service vsys restart
+    service vsys restart
 fi
 
 %postun
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - vsys-0.99-4
+- building on fedora29 requires to tweak ocaml compile environment
+
+* Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-3
+- only cosmetic changes
+
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
+- split the vsyssh package in a separate specfile
+- so we can preinstall vsyssh in the sliver space
+
+* Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
+- vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
+- fix build dep to require ocaml-ocamldoc instead of ocaml-docs
+
+* Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
+- Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
+- git/master.
+
 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
 - fix build for f12
 
@@ -127,58 +145,57 @@ fi
 
 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
 - added patch to pl-ps needed by slicestat
-- 
-- 
+-
+-
 
 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
 
 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
 - accept '-' in filenames also
-- 
+-
 
 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
 - don't overwrite the config file that already exists.
-- 
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
-- 
-- 
+-
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
-- Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
+- Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for
 - it to show up in all slices.
-- 
-- 
+-
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
 - Added a vsys script for CoMon.
-- 
+-
 
 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
 - ignore non-existent directories after restart.
-- 
+-
 
 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
 - added logrotate configuration to package.
-- 
+-
 
 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
 - Added two new scripts for CoMon on 4.2
-- 
+-
 
 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
-- 
+-
 - Corrected directory that the script mounts to the correct one:
 - /var/local/fprobe
-- 
+-
 
 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
 - Pulling the latest changes for the 4.2rc2 release
-- 
+-
 
 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
 - * daemonization, writing to a logfile, and saving the pid
-- 
-
+-