add -fPIC option to the C compiler, required in f31
[vsys.git] / vsys.spec
index ed6207d..ebac2e3 100644 (file)
--- a/vsys.spec
+++ b/vsys.spec
@@ -5,7 +5,7 @@
 
 %define name vsys
 %define version 0.99
-%define taglevel 1
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -14,14 +14,14 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %{SCMURL}
 
-Summary: Vsys filesystem 
+Summary: Vsys filesystem
 Name: %{name}
 Version: %{version}
 Release: %{release}
 License: GPL
 Group: System Environment/Kernel
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
-#Requires: 
+#Requires:
 BuildRequires: inotify-tools-devel
 BuildRequires: ocaml
 BuildRequires: ocaml-ocamldoc
@@ -39,6 +39,10 @@ removed dynamically.
 
 %build
 rm -rf $RPM_BUILD_ROOT
+# for fedora 29, that comes with a change in the ocaml language
+# picked that tip here:
+# https://github.com/HaxeFoundation/haxe/issues/6883
+export OCAMLPARAM="safe-string=0,_"
 make
 
 %install
@@ -67,12 +71,22 @@ rm -rf $RPM_BUILD_ROOT
 chkconfig --add vsys
 chkconfig vsys on
 if [ "$PL_BOOTCD" != "1" ] ; then
-        service vsys restart
+    service vsys restart
 fi
 
 %postun
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - vsys-0.99-4
+- building on fedora29 requires to tweak ocaml compile environment
+
+* Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-3
+- only cosmetic changes
+
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
+- split the vsyssh package in a separate specfile
+- so we can preinstall vsyssh in the sliver space
+
 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
@@ -131,58 +145,57 @@ fi
 
 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
 - added patch to pl-ps needed by slicestat
-- 
-- 
+-
+-
 
 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
 
 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
 - accept '-' in filenames also
-- 
+-
 
 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
 - don't overwrite the config file that already exists.
-- 
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
-- 
-- 
+-
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
-- Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
+- Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for
 - it to show up in all slices.
-- 
-- 
+-
+-
 
 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
 - Added a vsys script for CoMon.
-- 
+-
 
 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
 - ignore non-existent directories after restart.
-- 
+-
 
 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
 - added logrotate configuration to package.
-- 
+-
 
 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
 - Added two new scripts for CoMon on 4.2
-- 
+-
 
 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
-- 
+-
 - Corrected directory that the script mounts to the correct one:
 - /var/local/fprobe
-- 
+-
 
 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
 - Pulling the latest changes for the 4.2rc2 release
-- 
+-
 
 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
 - * daemonization, writing to a logfile, and saving the pid
-- 
-
+-