Setting tag www-register-wizard-4.3-2
[www-register-wizard.git] / www-register-wizard.spec
1 #
2 # $Id: PLCWWW.spec 12168 2009-02-22 23:26:24Z thierry $
3 #
4 %define url $URL: https://svn.planet-lab.org/svn/www-register-wizard/trunk/www-register-wizard.spec $
5
6 %define name www-register-wizard
7 %define version 4.3
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: Registration Wizard for Nodes and PCUs
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 # We use set everywhere
28 #Requires: httpd >= 2.0
29 Requires: PLCWWW >= 4.3
30 Requires: PLCAPI >= 4.3
31
32 %description
33
34 The www-register-wizard provides a web interface for MyPLC that integrates and
35 serializes the steps required to register, configure and verify that a node is
36 running correctly.  This is an improvement upon and replacement for the existing 'Add Node' and
37 'Add PCU' forms.
38
39 %prep
40 %setup -q
41
42 %build
43 echo "There is no build stage for this component."
44 echo "All files just need to be installed as is from the codebase."
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 echo "* www-register-wizard: Installing www-register-wizard pages"
50
51 mkdir -p $RPM_BUILD_ROOT/var/www/html
52 # let's be conservative and exclude codebase files, though there should not be any
53 rsync -a --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/registerwizard
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 /var/www/html/registerwizard
61
62 %changelog
63 * Tue Apr 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - www-register-wizard-4.3-2
64 - upgrade to codeigniter 1.7.2 for php-5.3 & f12
65 - enable rewrite_short_tags to preserve support for <?= ?> tag
66
67 * Thu Jul 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.3-1
68 - better error handling on updating node information.
69
70 * Wed Jun 03 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.3-0
71 - update version number to match 4.3 for consistency and clarity.
72
73 * Wed Jun 03 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.2-4
74 - changes to work with 4.3... probably need to update the version information to
75 - avoid confusion.
76
77 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.2-3
78 - bring up to date.
79
80 * Mon Mar 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.2-2
81 - correct typos.
82 - remove extra print statements.
83 - remove 'debug' continue buttons.
84
85 * Fri Mar 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - www-register-wizard-4.2-1
86 - enforced model check on add-pcu.
87 - display clearer messages on stage 8, regarding pcu success or failure.
88
89 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> -
90 - Initial creation of spec file.