add latest centos5 yum (corresponds to the centos 5.6)
[yum.git] / original / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.28
6 Release: 5%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12 Patch0: installonlyn-enable.patch
13 Patch1: yum-mirror-priority.patch
14 Patch3: yum-multilib-policy-best.patch
15 Patch4: no-more-exactarchlist.patch
16 Patch5: geode-arch.patch
17 Patch6: yum-HEAD.patch
18 Patch7: yum-PK-auto-close-fix.patch
19
20 Patch20: yum-manpage-files.patch
21
22 URL: http://yum.baseurl.org/
23 BuildArch: noarch
24 BuildRequires: python
25 BuildRequires: gettext
26 BuildRequires: intltool
27 Conflicts: pirut < 1.1.4
28 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
29 Requires: python-iniparse
30 Requires: python-sqlite
31 Requires: python-urlgrabber >= 3.9.0-8
32 Requires: yum-metadata-parser >= 1.1.0
33 Requires: pygpgme
34 Obsoletes: yum-skip-broken <= 1.1.18
35 Obsoletes: yum-basearchonly <= 1.1.9
36 Obsoletes: yum-plugin-basearchonly <= 1.1.24
37 Obsoletes: yum-allow-downgrade < 1.1.20-0
38 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
39 Obsoletes: yum-plugin-protect-packages < 1.1.27-0
40 Obsoletes: yum-plugin-download-order <= 0.2-2
41 Provides: yum-skip-broken
42 Provides: yum-basearchonly
43 Provides: yum-allow-downgrade
44 Provides: yum-plugin-allow-downgrade
45 Provides: yum-protect-packages
46 Provides: yum-plugin-protect-packages
47 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
48
49 %description
50 Yum is a utility that can check for and automatically download and
51 install updated RPM packages. Dependencies are obtained and downloaded 
52 automatically, prompting the user for permission as necessary.
53
54 %package updatesd
55 Summary: Update notification daemon
56 Group: Applications/System
57 Requires: yum = %{version}-%{release}
58 Requires: dbus-python
59 Requires: pygobject2
60 Requires(preun): /sbin/chkconfig
61 Requires(post): /sbin/chkconfig
62 Requires(preun): /sbin/service
63 Requires(post): /sbin/service
64
65 %description updatesd
66 yum-updatesd provides a daemon which checks for available updates and 
67 can notify you when they are available via email, syslog or dbus. 
68
69 %prep
70 %setup -q
71 %patch1 -p0
72 %patch3 -p0
73 %patch4 -p0
74 %patch5 -p1
75 %patch6 -p1
76 %patch7 -p1
77 %patch20 -p1
78
79 %build
80 make
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 make DESTDIR=$RPM_BUILD_ROOT install
85 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
86 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
87
88 # for now, move repodir/yum.conf back
89 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
90 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
91
92 # yum-updatesd has moved to the separate source version
93 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
94 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
95 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
96 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
97 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
98 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
99
100 # Ghost files:
101 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
102 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
103 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
104 touch $RPM_BUILD_ROOT/var/lib/yum/uuid
105
106 %find_lang %name
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files -f %{name}.lang
112 %defattr(-, root, root, -)
113 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
114 %config(noreplace) %{_sysconfdir}/yum.conf
115 %dir %{_sysconfdir}/yum
116 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
117 %dir %{_sysconfdir}/yum/protected.d
118 %dir %{_sysconfdir}/yum.repos.d
119 %dir %{_sysconfdir}/yum/vars
120 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
121 %{_sysconfdir}/bash_completion.d
122 %dir %{_datadir}/yum-cli
123 %{_datadir}/yum-cli/*
124 %{_bindir}/yum
125 %{python_sitelib}/yum
126 %{python_sitelib}/rpmUtils
127 %dir /var/cache/yum
128 %dir /var/lib/yum
129 %ghost /var/lib/yum/uuid
130 %ghost /var/lib/yum/history
131 %ghost /var/lib/yum/plugins
132 %ghost /var/lib/yum/yumdb
133 %{_mandir}/man*/yum.*
134 %{_mandir}/man*/yum-shell*
135 # plugin stuff
136 %dir %{_sysconfdir}/yum/pluginconf.d 
137 %dir /usr/lib/yum-plugins
138
139 %changelog
140 * Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
141 - Fix auto-close bug with GPG key installs.
142 - Resolves: bug#622179
143 - Fix obsoletes on basearchonly.
144 - Resolves: bug#629138
145
146 * Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
147 - obsoleted yum-plugin-download-order
148
149 * Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
150 - latest head
151 - fix gpg key import
152 - more unicode fixes
153 - output slightly more clear depsovling error msgs
154 - sync up spec file with f13,f14
155
156 * Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
157 - fixes sqlite historydb conversion bug
158 - patches up some unicide issues
159
160
161 * Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
162 - 3.2.28
163
164 * Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
165 - fix regets on metadata when we run into an old file that's larger
166   than the new one
167
168 * Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
169 - broke searching in PK, this patch fixes it.
170
171 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
172 - update to 3.2.27 - lots of fixes since 3.2.26
173
174 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
175 - up to head-as-f13-has and include the skip-broken fix
176
177
178 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
179 - grumble.
180
181 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
182 - final 3.2.26
183
184 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
185 - 3.2.25
186
187 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
188 - revert yum. import patch b/c it breaks a bunch of things
189
190 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
191 - fix up broken build b/c of version-groups.conf file
192
193 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
194 - fixes for odd outputs from ts.run and logs for what we store in history
195
196 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
197 - new head patch - fixes some issues with history and chroots
198
199 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
200 - latest head patch - includes yum history feature.
201
202 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
203 - new head patch - translation updates and a few bug fixes
204
205 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
206 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
207
208
209 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
210 - modify cachedir to include variables
211
212 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
213 - 3.2.24
214
215 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
216 - fix globbing issue 520810
217
218 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
219 - one more head update - fixes some fairly ugly but kind of minor bugs
220
221 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
222 - update to latest head pre 3.2.24
223 - add requirement on python-urlgrabber 3.9.0 and up
224
225 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
226 - latest head - right after freeze
227
228 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
229 - latest head - right before freeze :)
230
231 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
232 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
233
234 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
235 - remove exactarchlist by request for rawhide
236
237 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
238 - update to latest head - make livecd creation work again in rawhide
239 - disable one of the man page patches until after 3.2.24 is released b/c
240   of the changes to the man page in the head patch
241
242
243 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
244 - Update to latest head:
245 - Fix old recursion bug, found by new code.
246 - Resolves: bug#507220
247
248 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
249 - Update to latest head:
250 - Unbreak delPackage() excludes.
251 - Other fixes/etc.
252
253 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
254 - Actually apply the HEAD patch included yesterday :).
255
256 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
257 - update to latest head
258
259 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
260 - truncate changelog
261
262 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
263 - add patch to close rpmdb completely
264
265 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
266 - 3.2.23
267
268 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
269 - jump up to almost 3.2.23. 
270 - had to move patch0 around a bit until we rebase to 3.2.23
271
272 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
273 - fix typo for yum-complete-transaction message.
274
275 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
276 - fix for file:// urls which makes things in pungi/mash work
277
278 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
279 - yum-HEAD minus the yumdb patches
280
281 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
282 - 3.2.22 - 3 patches beyond 3.2.21-16
283
284 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
285 - fix for 490490
286
287 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
288 - update to upstream git to fix conditionals problem on anaconda installs
289
290 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
291 - latest HEAD
292
293 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
294 - f11beta build
295
296 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
297 - second verse, same as the first
298
299 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
300 - merge up a lot of fixes from latest HEAD
301
302 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
303 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
304
305 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
306 - merge up to latest yum head - sort of a pre 3.2.22
307
308 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
309 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
310
311 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
312 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
313
314 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
315 - patch to keep anaconda (and other callers) happy
316 - remove old 6hr patch which is now upstream
317
318 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
319 - patch to latest HEAD to test a number of fixes for alpha
320
321 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
322 - add a small patch to make things play a bit nicer with the logging module
323   in 2.6
324
325
326 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
327 - bump to 3.2.21
328
329 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
330 - merge latest from upstream
331 - move to 6hr metadata
332
333 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
334 - merge patch from upstream and remove now old obsoletes patch
335
336 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
337 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
338
339 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
340 - Rebuild for Python 2.6
341
342 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
343 - update head patch
344
345 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
346 - full patch against HEAD for skipbroken fixes (among others)
347
348 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
349 - Fix listTransaction for skipped packages.
350
351 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
352 - 3.2.20
353
354 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
355 - update HEAD patch
356
357 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
358 - rebase against 3.2.X HEAD
359
360 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
361 - pull patch from git to bring us up to current(ish)
362
363 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
364 - add patch to fix yum install name.arch matching
365
366 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
367 - add patch to fix mash's parser use.
368
369 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
370 - 3.2.19
371
372 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
373 - 3.2.18
374
375 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
376 - add patch from upstream for bug in compare_providers
377
378 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
379 - 3.2.17
380
381 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
382 - Add a couple more upstream patches for even more multilib fixes
383
384 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
385 - Add another patch from upstream for multilib policy and noarch
386
387 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
388 - stupid, stupid, stupid
389
390
391 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
392 - 3.2.16
393
394 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
395 - nine is the luckiest number that there will ever be
396
397 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
398 - after many tries - this one fixes translations AND pungi
399
400 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
401 - once more, with feeling
402
403 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
404 - another big-head-patch
405
406 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
407 - apply patch to bring this up to where HEAD is now.
408
409 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
410 - remove committed patch
411 - obsoletes yum-basearchonly
412
413 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
414 - fix minor typo in comps.py for jkeating
415
416 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
417 - 3.2.13
418
419 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
420 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
421
422
423 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
424 - multilib_policy=best is  now the default
425
426 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
427 - add jeff sheltren's patch to close rh bug 428825
428
429 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
430 - set failovermethod to 'priority' to make jkeating happy
431
432 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
433 - fix mutually obsoleting providers (like glibc!)
434
435 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
436 - 3.2.12
437
438 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
439 - 3.2.11
440
441 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
442 - Remove yumupd.py
443
444 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
445 - 3.2.10
446 - add pygpgme dep
447