113724ea8517fffc82861f903d4ba74f85011f21
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 %global release 2chroot
4  
5 Summary: RPM installer/updater
6 Name: yum
7 Version: 3.2.27
8 Release: %release
9 License: GPLv2+
10 Group: System Environment/Base
11 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
12 Source1: yum.conf.fedora
13 Source2: yum-updatesd.conf.fedora
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch2: yum-manpage-files.patch
17 Patch3: yum-multilib-policy-best.patch
18 Patch4: no-more-exactarchlist.patch
19 Patch5: geode-arch.patch
20 Patch6: yum-HEAD.patch
21 Patch10: yum-3.2.27-chroot.patch
22
23 URL: http://yum.baseurl.org/
24 BuildArch: noarch
25 BuildRequires: python
26 BuildRequires: gettext
27 BuildRequires: intltool
28 Conflicts: pirut < 1.1.4
29 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
30 Requires: python-iniparse
31 Requires: python-sqlite
32 Requires: python-urlgrabber >= 3.9.0-8
33 Requires: yum-metadata-parser >= 1.1.0
34 Requires: pygpgme
35 Obsoletes: yum-skip-broken, yum-basearchonly
36 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
37
38 %description
39 Yum is a utility that can check for and automatically download and
40 install updated RPM packages. Dependencies are obtained and downloaded 
41 automatically prompting the user as necessary.
42
43 %package updatesd
44 Summary: Update notification daemon
45 Group: Applications/System
46 Requires: yum = %{version}-%{release}
47 Requires: dbus-python
48 Requires: pygobject2
49 Requires(preun): /sbin/chkconfig
50 Requires(post): /sbin/chkconfig
51 Requires(preun): /sbin/service
52 Requires(post): /sbin/service
53
54 %description updatesd
55 yum-updatesd provides a daemon which checks for available updates and 
56 can notify you when they are available via email, syslog or dbus. 
57
58 %prep
59 %setup -q
60 %patch1 -p0
61 #%%%patch2 -p0
62 %patch3 -p0
63 %patch4 -p0
64 %patch5 -p1
65 #%%%%patch6 -p1
66 %patch10 -p1
67
68 %build
69
70 make
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 make DESTDIR=$RPM_BUILD_ROOT install
75 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
76 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
77
78 # for now, move repodir/yum.conf back
79 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
80 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
81
82 # yum-updatesd has moved to the separate source version
83 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
84 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
85 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
86 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
87 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
88 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
89
90 %find_lang %name
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files -f %{name}.lang
96 %defattr(-, root, root, -)
97 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
98 %config(noreplace) %{_sysconfdir}/yum.conf
99 %dir %{_sysconfdir}/yum
100 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
101 %dir %{_sysconfdir}/yum.repos.d
102 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
103 %{_sysconfdir}/bash_completion.d
104 %dir %{_datadir}/yum-cli
105 %{_datadir}/yum-cli/*
106 %{_bindir}/yum
107 %{python_sitelib}/yum
108 %{python_sitelib}/rpmUtils
109 %dir /var/cache/yum
110 %dir /var/lib/yum
111 %{_mandir}/man*/yum.*
112 %{_mandir}/man*/yum-shell*
113 # plugin stuff
114 %dir %{_sysconfdir}/yum/pluginconf.d 
115 %dir /usr/lib/yum-plugins
116
117 %changelog
118 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
119 - update to 3.2.27 - lots of fixes since 3.2.26
120
121 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
122 - up to head-as-f13-has and include the skip-broken fix
123
124
125 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
126 - grumble.
127
128 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
129 - final 3.2.26
130
131 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
132 - 3.2.25
133
134 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
135 - revert yum. import patch b/c it breaks a bunch of things
136
137 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
138 - fix up broken build b/c of version-groups.conf file
139
140 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
141 - fixes for odd outputs from ts.run and logs for what we store in history
142
143 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
144 - new head patch - fixes some issues with history and chroots
145
146 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
147 - latest head patch - includes yum history feature.
148
149 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
150 - new head patch - translation updates and a few bug fixes
151
152 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
153 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
154
155
156 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
157 - modify cachedir to include variables
158
159 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
160 - 3.2.24
161
162 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
163 - fix globbing issue 520810
164
165 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
166 - one more head update - fixes some fairly ugly but kind of minor bugs
167
168 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
169 - update to latest head pre 3.2.24
170 - add requirement on python-urlgrabber 3.9.0 and up
171
172 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
173 - latest head - right after freeze
174
175 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
176 - latest head - right before freeze :)
177
178 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
179 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
180
181 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
182 - remove exactarchlist by request for rawhide
183
184 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
185 - update to latest head - make livecd creation work again in rawhide
186 - disable one of the man page patches until after 3.2.24 is released b/c
187   of the changes to the man page in the head patch
188
189
190 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
191 - Update to latest head:
192 - Fix old recursion bug, found by new code.
193 - Resolves: bug#507220
194
195 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
196 - Update to latest head:
197 - Unbreak delPackage() excludes.
198 - Other fixes/etc.
199
200 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
201 - Actually apply the HEAD patch included yesterday :).
202
203 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
204 - update to latest head
205
206 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
207 - truncate changelog
208
209 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
210 - add patch to close rpmdb completely
211
212 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
213 - 3.2.23
214
215 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
216 - jump up to almost 3.2.23. 
217 - had to move patch0 around a bit until we rebase to 3.2.23
218
219 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
220 - fix typo for yum-complete-transaction message.
221
222 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
223 - fix for file:// urls which makes things in pungi/mash work
224
225 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
226 - yum-HEAD minus the yumdb patches
227
228 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
229 - 3.2.22 - 3 patches beyond 3.2.21-16
230
231 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
232 - fix for 490490
233
234 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
235 - update to upstream git to fix conditionals problem on anaconda installs
236
237 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
238 - latest HEAD
239
240 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
241 - f11beta build
242
243 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
244 - second verse, same as the first
245
246 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
247 - merge up a lot of fixes from latest HEAD
248
249 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
250 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
251
252 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
253 - merge up to latest yum head - sort of a pre 3.2.22
254
255 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
256 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
257
258 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
259 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
260
261 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
262 - patch to keep anaconda (and other callers) happy
263 - remove old 6hr patch which is now upstream
264
265 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
266 - patch to latest HEAD to test a number of fixes for alpha
267
268 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
269 - add a small patch to make things play a bit nicer with the logging module
270   in 2.6
271
272
273 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
274 - bump to 3.2.21
275
276 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
277 - merge latest from upstream
278 - move to 6hr metadata
279
280 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
281 - merge patch from upstream and remove now old obsoletes patch
282
283 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
284 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
285
286 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
287 - Rebuild for Python 2.6
288
289 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
290 - update head patch
291
292 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
293 - full patch against HEAD for skipbroken fixes (among others)
294
295 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
296 - Fix listTransaction for skipped packages.
297
298 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
299 - 3.2.20
300
301 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
302 - update HEAD patch
303
304 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
305 - rebase against 3.2.X HEAD
306
307 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
308 - pull patch from git to bring us up to current(ish)
309
310 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
311 - add patch to fix yum install name.arch matching
312
313 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
314 - add patch to fix mash's parser use.
315
316 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
317 - 3.2.19
318
319 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
320 - 3.2.18
321
322 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
323 - add patch from upstream for bug in compare_providers
324
325 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
326 - 3.2.17
327
328 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
329 - Add a couple more upstream patches for even more multilib fixes
330
331 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
332 - Add another patch from upstream for multilib policy and noarch
333
334 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
335 - stupid, stupid, stupid
336
337
338 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
339 - 3.2.16
340
341 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
342 - nine is the luckiest number that there will ever be
343
344 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
345 - after many tries - this one fixes translations AND pungi
346
347 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
348 - once more, with feeling
349
350 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
351 - another big-head-patch
352
353 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
354 - apply patch to bring this up to where HEAD is now.
355
356 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
357 - remove committed patch
358 - obsoletes yum-basearchonly
359
360 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
361 - fix minor typo in comps.py for jkeating
362
363 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
364 - 3.2.13
365
366 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
367 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
368
369
370 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
371 - multilib_policy=best is  now the default
372
373 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
374 - add jeff sheltren's patch to close rh bug 428825
375
376 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
377 - set failovermethod to 'priority' to make jkeating happy
378
379 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
380 - fix mutually obsoleting providers (like glibc!)
381
382 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
383 - 3.2.12
384
385 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
386 - 3.2.11
387
388 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
389 - Remove yumupd.py
390
391 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
392 - 3.2.10
393 - add pygpgme dep
394