sync with f12
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 %global release 5chroot
4  
5 Summary: RPM installer/updater
6 Name: yum
7 Version: 3.2.28
8 Release: %release
9 License: GPLv2+
10 Group: System Environment/Base
11 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
12 Source1: yum.conf.fedora
13 Source2: yum-updatesd.conf.fedora
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch3: yum-multilib-policy-best.patch
17 Patch4: no-more-exactarchlist.patch
18 Patch5: geode-arch.patch
19 Patch6: yum-HEAD.patch
20 Patch7: yum-PK-auto-close-fix.patch
21
22 Patch10: yum-3.2.28-chroot.patch
23
24 Patch20: yum-manpage-files.patch
25
26 URL: http://yum.baseurl.org/
27 BuildArch: noarch
28 BuildRequires: python
29 BuildRequires: gettext
30 BuildRequires: intltool
31 Conflicts: pirut < 1.1.4
32 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
33 Requires: python-iniparse
34 Requires: python-sqlite
35 Requires: python-urlgrabber >= 3.9.0-8
36 Requires: yum-metadata-parser >= 1.1.0
37 Requires: pygpgme
38 Obsoletes: yum-skip-broken <= 1.1.18
39 Obsoletes: yum-basearchonly <= 1.1.9
40 Obsoletes: yum-plugin-basearchonly <= 1.1.24
41 Obsoletes: yum-allow-downgrade < 1.1.20-0
42 Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
43 Obsoletes: yum-plugin-protect-packages < 1.1.27-0
44 Obsoletes: yum-plugin-download-order <= 0.2-2
45 Provides: yum-skip-broken
46 Provides: yum-basearchonly
47 Provides: yum-allow-downgrade
48 Provides: yum-plugin-allow-downgrade
49 Provides: yum-protect-packages
50 Provides: yum-plugin-protect-packages
51 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
52
53 %description
54 Yum is a utility that can check for and automatically download and
55 install updated RPM packages. Dependencies are obtained and downloaded 
56 automatically, prompting the user for permission as necessary.
57
58 %package updatesd
59 Summary: Update notification daemon
60 Group: Applications/System
61 Requires: yum = %{version}-%{release}
62 Requires: dbus-python
63 Requires: pygobject2
64 Requires(preun): /sbin/chkconfig
65 Requires(post): /sbin/chkconfig
66 Requires(preun): /sbin/service
67 Requires(post): /sbin/service
68
69 %description updatesd
70 yum-updatesd provides a daemon which checks for available updates and 
71 can notify you when they are available via email, syslog or dbus. 
72
73 %prep
74 %setup -q
75 %patch1 -p0
76 %patch3 -p0
77 %patch4 -p0
78 %patch5 -p1
79 %patch6 -p1
80 %patch7 -p1
81
82 %patch10 -p1
83
84 %patch20 -p1
85
86 %build
87 make
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 make DESTDIR=$RPM_BUILD_ROOT install
92 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
93 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
94
95 # for now, move repodir/yum.conf back
96 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
97 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
98
99 # yum-updatesd has moved to the separate source version
100 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
101 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
102 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
103 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
104 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
105 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
106
107 # Ghost files:
108 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
109 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
110 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
111 touch $RPM_BUILD_ROOT/var/lib/yum/uuid
112
113 %find_lang %name
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(-, root, root, -)
120 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
121 %config(noreplace) %{_sysconfdir}/yum.conf
122 %dir %{_sysconfdir}/yum
123 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
124 %dir %{_sysconfdir}/yum/protected.d
125 %dir %{_sysconfdir}/yum.repos.d
126 %dir %{_sysconfdir}/yum/vars
127 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
128 %{_sysconfdir}/bash_completion.d
129 %dir %{_datadir}/yum-cli
130 %{_datadir}/yum-cli/*
131 %{_bindir}/yum
132 %{python_sitelib}/yum
133 %{python_sitelib}/rpmUtils
134 %dir /var/cache/yum
135 %dir /var/lib/yum
136 %ghost /var/lib/yum/uuid
137 %ghost /var/lib/yum/history
138 %ghost /var/lib/yum/plugins
139 %ghost /var/lib/yum/yumdb
140 %{_mandir}/man*/yum.*
141 %{_mandir}/man*/yum-shell*
142 # plugin stuff
143 %dir %{_sysconfdir}/yum/pluginconf.d 
144 %dir /usr/lib/yum-plugins
145
146 %changelog
147 * Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
148 - Fix auto-close bug with GPG key installs.
149 - Resolves: bug#622179
150 - Fix obsoletes on basearchonly.
151 - Resolves: bug#629138
152
153 * Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
154 - obsoleted yum-plugin-download-order
155
156 * Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
157 - latest head
158 - fix gpg key import
159 - more unicode fixes
160 - output slightly more clear depsovling error msgs
161 - sync up spec file with f13,f14
162
163 * Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
164 - fixes sqlite historydb conversion bug
165 - patches up some unicide issues
166
167
168 * Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
169 - 3.2.28
170
171 * Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
172 - fix regets on metadata when we run into an old file that's larger
173   than the new one
174
175 * Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
176 - broke searching in PK, this patch fixes it.
177
178 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
179 - update to 3.2.27 - lots of fixes since 3.2.26
180
181 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
182 - up to head-as-f13-has and include the skip-broken fix
183
184
185 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
186 - grumble.
187
188 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
189 - final 3.2.26
190
191 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
192 - 3.2.25
193
194 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
195 - revert yum. import patch b/c it breaks a bunch of things
196
197 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
198 - fix up broken build b/c of version-groups.conf file
199
200 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
201 - fixes for odd outputs from ts.run and logs for what we store in history
202
203 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
204 - new head patch - fixes some issues with history and chroots
205
206 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
207 - latest head patch - includes yum history feature.
208
209 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
210 - new head patch - translation updates and a few bug fixes
211
212 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
213 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
214
215
216 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
217 - modify cachedir to include variables
218
219 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
220 - 3.2.24
221
222 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
223 - fix globbing issue 520810
224
225 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
226 - one more head update - fixes some fairly ugly but kind of minor bugs
227
228 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
229 - update to latest head pre 3.2.24
230 - add requirement on python-urlgrabber 3.9.0 and up
231
232 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
233 - latest head - right after freeze
234
235 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
236 - latest head - right before freeze :)
237
238 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
239 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
240
241 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
242 - remove exactarchlist by request for rawhide
243
244 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
245 - update to latest head - make livecd creation work again in rawhide
246 - disable one of the man page patches until after 3.2.24 is released b/c
247   of the changes to the man page in the head patch
248
249
250 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
251 - Update to latest head:
252 - Fix old recursion bug, found by new code.
253 - Resolves: bug#507220
254
255 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
256 - Update to latest head:
257 - Unbreak delPackage() excludes.
258 - Other fixes/etc.
259
260 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
261 - Actually apply the HEAD patch included yesterday :).
262
263 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
264 - update to latest head
265
266 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
267 - truncate changelog
268
269 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
270 - add patch to close rpmdb completely
271
272 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
273 - 3.2.23
274
275 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
276 - jump up to almost 3.2.23. 
277 - had to move patch0 around a bit until we rebase to 3.2.23
278
279 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
280 - fix typo for yum-complete-transaction message.
281
282 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
283 - fix for file:// urls which makes things in pungi/mash work
284
285 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
286 - yum-HEAD minus the yumdb patches
287
288 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
289 - 3.2.22 - 3 patches beyond 3.2.21-16
290
291 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
292 - fix for 490490
293
294 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
295 - update to upstream git to fix conditionals problem on anaconda installs
296
297 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
298 - latest HEAD
299
300 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
301 - f11beta build
302
303 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
304 - second verse, same as the first
305
306 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
307 - merge up a lot of fixes from latest HEAD
308
309 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
310 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
311
312 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
313 - merge up to latest yum head - sort of a pre 3.2.22
314
315 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
316 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
317
318 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
319 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
320
321 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
322 - patch to keep anaconda (and other callers) happy
323 - remove old 6hr patch which is now upstream
324
325 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
326 - patch to latest HEAD to test a number of fixes for alpha
327
328 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
329 - add a small patch to make things play a bit nicer with the logging module
330   in 2.6
331
332
333 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
334 - bump to 3.2.21
335
336 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
337 - merge latest from upstream
338 - move to 6hr metadata
339
340 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
341 - merge patch from upstream and remove now old obsoletes patch
342
343 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
344 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
345
346 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
347 - Rebuild for Python 2.6
348
349 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
350 - update head patch
351
352 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
353 - full patch against HEAD for skipbroken fixes (among others)
354
355 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
356 - Fix listTransaction for skipped packages.
357
358 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
359 - 3.2.20
360
361 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
362 - update HEAD patch
363
364 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
365 - rebase against 3.2.X HEAD
366
367 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
368 - pull patch from git to bring us up to current(ish)
369
370 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
371 - add patch to fix yum install name.arch matching
372
373 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
374 - add patch to fix mash's parser use.
375
376 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
377 - 3.2.19
378
379 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
380 - 3.2.18
381
382 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
383 - add patch from upstream for bug in compare_providers
384
385 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
386 - 3.2.17
387
388 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
389 - Add a couple more upstream patches for even more multilib fixes
390
391 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
392 - Add another patch from upstream for multilib policy and noarch
393
394 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
395 - stupid, stupid, stupid
396
397
398 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
399 - 3.2.16
400
401 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
402 - nine is the luckiest number that there will ever be
403
404 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
405 - after many tries - this one fixes translations AND pungi
406
407 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
408 - once more, with feeling
409
410 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
411 - another big-head-patch
412
413 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
414 - apply patch to bring this up to where HEAD is now.
415
416 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
417 - remove committed patch
418 - obsoletes yum-basearchonly
419
420 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
421 - fix minor typo in comps.py for jkeating
422
423 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
424 - 3.2.13
425
426 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
427 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
428
429
430 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
431 - multilib_policy=best is  now the default
432
433 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
434 - add jeff sheltren's patch to close rh bug 428825
435
436 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
437 - set failovermethod to 'priority' to make jkeating happy
438
439 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
440 - fix mutually obsoleting providers (like glibc!)
441
442 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
443 - 3.2.12
444
445 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
446 - 3.2.11
447
448 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
449 - Remove yumupd.py
450
451 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
452 - 3.2.10
453 - add pygpgme dep
454