540dd679db13add2a49e3a20945d74be56b3fbf7
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 %global release 4chroot
4  
5 Summary: RPM installer/updater
6 Name: yum
7 Version: 3.2.27
8 Release: %release
9 License: GPLv2+
10 Group: System Environment/Base
11 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
12 Source1: yum.conf.fedora
13 Source2: yum-updatesd.conf.fedora
14 Patch0: installonlyn-enable.patch
15 Patch1: yum-mirror-priority.patch
16 Patch2: yum-manpage-files.patch
17 Patch3: yum-multilib-policy-best.patch
18 Patch4: no-more-exactarchlist.patch
19 Patch5: geode-arch.patch
20 Patch6: yum-HEAD.patch
21 Patch7: yum-do-not-overwrite-keys.patch
22 Patch8: reget-metadata-size-fix.patch
23 Patch10: yum-3.2.27-chroot.patch
24
25 URL: http://yum.baseurl.org/
26 BuildArch: noarch
27 BuildRequires: python
28 BuildRequires: gettext
29 BuildRequires: intltool
30 Conflicts: pirut < 1.1.4
31 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
32 Requires: python-iniparse
33 Requires: python-sqlite
34 Requires: python-urlgrabber >= 3.9.0-8
35 Requires: yum-metadata-parser >= 1.1.0
36 Requires: pygpgme
37 Obsoletes: yum-skip-broken, yum-basearchonly
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
39
40 %description
41 Yum is a utility that can check for and automatically download and
42 install updated RPM packages. Dependencies are obtained and downloaded 
43 automatically prompting the user as necessary.
44
45 %package updatesd
46 Summary: Update notification daemon
47 Group: Applications/System
48 Requires: yum = %{version}-%{release}
49 Requires: dbus-python
50 Requires: pygobject2
51 Requires(preun): /sbin/chkconfig
52 Requires(post): /sbin/chkconfig
53 Requires(preun): /sbin/service
54 Requires(post): /sbin/service
55
56 %description updatesd
57 yum-updatesd provides a daemon which checks for available updates and 
58 can notify you when they are available via email, syslog or dbus. 
59
60 %prep
61 %setup -q
62 %patch1 -p0
63 #%%%patch2 -p0
64 %patch3 -p0
65 %patch4 -p0
66 %patch5 -p1
67 #%%%%patch6 -p1
68 %patch7 -p1
69 %patch8 -p1
70
71 %patch10 -p1
72
73 %build
74 make
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 make DESTDIR=$RPM_BUILD_ROOT install
79 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
80 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
81
82 # for now, move repodir/yum.conf back
83 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
84 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
85
86 # yum-updatesd has moved to the separate source version
87 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
88 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
89 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
90 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
91 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
92 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
93
94 %find_lang %name
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f %{name}.lang
100 %defattr(-, root, root, -)
101 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
102 %config(noreplace) %{_sysconfdir}/yum.conf
103 %dir %{_sysconfdir}/yum
104 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
105 %dir %{_sysconfdir}/yum.repos.d
106 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
107 %{_sysconfdir}/bash_completion.d
108 %dir %{_datadir}/yum-cli
109 %{_datadir}/yum-cli/*
110 %{_bindir}/yum
111 %{python_sitelib}/yum
112 %{python_sitelib}/rpmUtils
113 %dir /var/cache/yum
114 %dir /var/lib/yum
115 %{_mandir}/man*/yum.*
116 %{_mandir}/man*/yum-shell*
117 # plugin stuff
118 %dir %{_sysconfdir}/yum/pluginconf.d 
119 %dir /usr/lib/yum-plugins
120
121 %changelog
122 * Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
123 - fix regets on metadata when we run into an old file that's larger
124   than the new one
125
126 * Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
127 - broke searching in PK, this patch fixes it.
128
129 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
130 - update to 3.2.27 - lots of fixes since 3.2.26
131
132 * Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
133 - up to head-as-f13-has and include the skip-broken fix
134
135
136 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
137 - grumble.
138
139 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
140 - final 3.2.26
141
142 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
143 - 3.2.25
144
145 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
146 - revert yum. import patch b/c it breaks a bunch of things
147
148 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
149 - fix up broken build b/c of version-groups.conf file
150
151 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
152 - fixes for odd outputs from ts.run and logs for what we store in history
153
154 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
155 - new head patch - fixes some issues with history and chroots
156
157 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
158 - latest head patch - includes yum history feature.
159
160 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
161 - new head patch - translation updates and a few bug fixes
162
163 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
164 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
165
166
167 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
168 - modify cachedir to include variables
169
170 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
171 - 3.2.24
172
173 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
174 - fix globbing issue 520810
175
176 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
177 - one more head update - fixes some fairly ugly but kind of minor bugs
178
179 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
180 - update to latest head pre 3.2.24
181 - add requirement on python-urlgrabber 3.9.0 and up
182
183 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
184 - latest head - right after freeze
185
186 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
187 - latest head - right before freeze :)
188
189 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
190 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
191
192 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
193 - remove exactarchlist by request for rawhide
194
195 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
196 - update to latest head - make livecd creation work again in rawhide
197 - disable one of the man page patches until after 3.2.24 is released b/c
198   of the changes to the man page in the head patch
199
200
201 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
202 - Update to latest head:
203 - Fix old recursion bug, found by new code.
204 - Resolves: bug#507220
205
206 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
207 - Update to latest head:
208 - Unbreak delPackage() excludes.
209 - Other fixes/etc.
210
211 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
212 - Actually apply the HEAD patch included yesterday :).
213
214 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
215 - update to latest head
216
217 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
218 - truncate changelog
219
220 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
221 - add patch to close rpmdb completely
222
223 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
224 - 3.2.23
225
226 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
227 - jump up to almost 3.2.23. 
228 - had to move patch0 around a bit until we rebase to 3.2.23
229
230 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
231 - fix typo for yum-complete-transaction message.
232
233 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
234 - fix for file:// urls which makes things in pungi/mash work
235
236 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
237 - yum-HEAD minus the yumdb patches
238
239 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
240 - 3.2.22 - 3 patches beyond 3.2.21-16
241
242 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
243 - fix for 490490
244
245 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
246 - update to upstream git to fix conditionals problem on anaconda installs
247
248 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
249 - latest HEAD
250
251 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
252 - f11beta build
253
254 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
255 - second verse, same as the first
256
257 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
258 - merge up a lot of fixes from latest HEAD
259
260 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
261 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
262
263 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
264 - merge up to latest yum head - sort of a pre 3.2.22
265
266 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
267 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
268
269 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
270 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
271
272 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
273 - patch to keep anaconda (and other callers) happy
274 - remove old 6hr patch which is now upstream
275
276 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
277 - patch to latest HEAD to test a number of fixes for alpha
278
279 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
280 - add a small patch to make things play a bit nicer with the logging module
281   in 2.6
282
283
284 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
285 - bump to 3.2.21
286
287 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
288 - merge latest from upstream
289 - move to 6hr metadata
290
291 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
292 - merge patch from upstream and remove now old obsoletes patch
293
294 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
295 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
296
297 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
298 - Rebuild for Python 2.6
299
300 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
301 - update head patch
302
303 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
304 - full patch against HEAD for skipbroken fixes (among others)
305
306 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
307 - Fix listTransaction for skipped packages.
308
309 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
310 - 3.2.20
311
312 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
313 - update HEAD patch
314
315 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
316 - rebase against 3.2.X HEAD
317
318 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
319 - pull patch from git to bring us up to current(ish)
320
321 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
322 - add patch to fix yum install name.arch matching
323
324 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
325 - add patch to fix mash's parser use.
326
327 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
328 - 3.2.19
329
330 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
331 - 3.2.18
332
333 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
334 - add patch from upstream for bug in compare_providers
335
336 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
337 - 3.2.17
338
339 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
340 - Add a couple more upstream patches for even more multilib fixes
341
342 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
343 - Add another patch from upstream for multilib policy and noarch
344
345 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
346 - stupid, stupid, stupid
347
348
349 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
350 - 3.2.16
351
352 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
353 - nine is the luckiest number that there will ever be
354
355 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
356 - after many tries - this one fixes translations AND pungi
357
358 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
359 - once more, with feeling
360
361 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
362 - another big-head-patch
363
364 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
365 - apply patch to bring this up to where HEAD is now.
366
367 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
368 - remove committed patch
369 - obsoletes yum-basearchonly
370
371 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
372 - fix minor typo in comps.py for jkeating
373
374 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
375 - 3.2.13
376
377 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
378 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
379
380
381 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
382 - multilib_policy=best is  now the default
383
384 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
385 - add jeff sheltren's patch to close rh bug 428825
386
387 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
388 - set failovermethod to 'priority' to make jkeating happy
389
390 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
391 - fix mutually obsoleting providers (like glibc!)
392
393 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
394 - 3.2.12
395
396 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
397 - 3.2.11
398
399 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
400 - Remove yumupd.py
401
402 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
403 - 3.2.10
404 - add pygpgme dep
405